Jump to content

Problème de connexion base sql


Recommended Posts

  Bonjour, j' ai installé prestashop sur une machine virtuelle qui tourne sur mon pc (avec lamp sous Ubuntu) . La partie www je l' ai récupéré sur le wamp de mon ordi, et la base de données je l' ai récupérée sur mon site en prod.

  Tout fonctionne, sauf que lorsque le lance un /localhost/prestashop sur mon navigateur, je me retrouve connecté sur mon site en prod, et pas en local (l' url change, ce n' est plus localhost/prestashop, mais l' adresse de mon site) . Je pense qu' apache fonctionne, car si je l' arrête, je ne peux plus ouvrir localhost/prestashop.

  Le problème doit si situer au niveau de la base de données. On se connecte sur mon site en prod, et pas en local. Je ne comprends pas, car mon /www était issu d' un site en local. Donc en machine virtuelle, je suis toujours en local.

  Si j' ai bien compris, cela se passe au niveau de /config/setting.inc.php, mais je ne vois pas ou je dois modifier l' adresse de ma base sql.

 

  Merci pour votre aide, bonne journée.

 

  Edit : dans mon fichier de configuration /config/setting.inc.php, je ne vois pas ces lignes, sauf erreur elles n' apparaissent pas.

define(‘_DB_NAME_’, ‘)

define(‘_DB_USER_’, ‘’);

define(‘_DB_PASSWD_’, ”);

 

  Edit 2 : Je n' avais pas ouvert le bon fichier, désolé. Dans /config/setting.inc.php j' ai bien les lignes citées plus haut.  . Mais les parametres dirigent bien vers la base de données en local :

define('_DB_SERVER_', 'localhost');

  Je ne vois vraiment pas pourquoi je suis connecté sur la base de mon site en prod chez mon hébergeur.

 

  Edit 3 : J' ai tenté de me connecter au back office, et j' ai ce message d' erreur :

Fatal error: Uncaught --> Smarty: unable to write file /var/www/prestashop/cache/smarty/compile/e3/f9/77/wrt54134f76c2eb37_10148013 <-- thrown in /var/www/prestashop/tools/smarty/sysplugins/smarty_internal_write_file.php on line 46 
Edited by ungars (see edit history)

Share this post


Link to post
Share on other sites

  Bonjour Oron et merci de me venir en aide.

 

Vérifier vos connexions base de donnée dans votre installation local que vous avez bien mis pour le db_server localhost et root comme login et sans mot de passe sous wamp map etc..

    Vous voulez dire dans /config/setting.inc.php ?

  Dans ce cas, je pense que les rubriques sont renseignées comme il se doit :

define('_DB_SERVER_', 'localhost');
define('_DB_NAME_', 'prestashop');
define('_DB_USER_', 'root');
define('_DB_PASSWD_', 'monmotdepasse');

  Je suis sous lamp, et pas sous wamp.

 

 

A moins que ce soit le cache ctrl+F5 de votre navigateur qui vous joue des tours

  Je ne pense pas, je me connecte aussi via une autre machine sur mon réseau local, en tapant l' adresse ip du serveur virtuel qui héberge prestashop, et le problème est le même.

 

 

il y a aussi le fichier .htaccess qui risque de vous envoyez sur le site en ligne

  Je vous mets ici le contenu de ce fichier, mais je ne vois rien qui pourrait faire cela (je peux me tromper biensur) :

# ~~start~~ Do not remove this comment, Prestashop will keep automatically the code outside this comment when .htaccess will be generated again
# .htaccess automaticaly generated by PrestaShop e-commerce open-source solution
# http://www.prestashop.com - http://www.prestashop.com/forums

<IfModule mod_rewrite.c>
<IfModule mod_env.c>
SetEnv HTTP_MOD_REWRITE On
</IfModule>

RewriteEngine on
RewriteRule . - [E=REWRITEBASE:/prestashop/prestashop/]
RewriteRule ^api/?(.*)$ %{ENV:REWRITEBASE}webservice/dispatcher.php?url=$1 [QSA,L]

# Images
RewriteRule ^([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$1$2$3.jpg [L]
RewriteRule ^([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$1$2$3$4.jpg [L]
RewriteRule ^([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$1$2$3$4$5.jpg [L]
RewriteRule ^([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$1$2$3$4$5$6.jpg [L]
RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$1$2$3$4$5$6$7.jpg [L]
RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$6/$1$2$3$4$5$6$7$8.jpg [L]
RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$6/$7/$1$2$3$4$5$6$7$8$9.jpg [L]
RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$6/$7/$8/$1$2$3$4$5$6$7$8$9$10.jpg [L]
RewriteRule ^c/([0-9]+)(\-[\.*_a-zA-Z0-9-]*)(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/c/$1$2$3.jpg [L]
RewriteRule ^c/([a-zA-Z_-]+)(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/c/$1$2.jpg [L]
# AlphaImageLoader for IE and fancybox
RewriteRule ^images_ie/?([^/]+)\.(jpe?g|png|gif)$ js/jquery/plugins/fancybox/images/$1.$2 [L]

# Dispatcher
RewriteCond %{REQUEST_FILENAME} -s [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [NC,L]
RewriteRule ^.*$ %{ENV:REWRITEBASE}index.php [NC,L]
</IfModule>

AddType application/vnd.ms-fontobject .eot
AddType font/ttf .ttf
AddType font/otf .otf
AddType application/x-font-woff .woff

#If rewrite mod isn't enabled
ErrorDocument 404 /prestashop/prestashop/index.php?controller=404

# ~~end~~ Do not remove this comment, Prestashop will keep automatically the code outside this comment when .htaccess will be generated again

 

Vous avez modifier l'url du site dans onglet Préférence >> Seo&URL's ?

 

  Je ne peux me connecter à mon back office pour faire ça, j' obtiens ce message d' erreur :

Fatal error: Uncaught --> Smarty: unable to write file /var/www/prestashop/cache/smarty/compile/e3/f9/77/wrt54134f76c2eb37_10148013 <-- thrown in /var/www/prestashop/tools/smarty/sysplugins/smarty_internal_write_file.php on line 46 

  J' ai donc fait un chmod -R 777 sur /var/www/prestashop/cache/smarty/compile/, (je ne sais pas si c' est bien, mais en attendant, et je suis en local donc pas grand risque) et là la fenêtre de connexion au back office apparait, et je suis bien en local, mais que là, si je reviens au front office, je suis toujours sur mon serveur en prod. Et de plus, impossible de me connecter :

Il y a une erreur.

    Compte employé inexistant, ou mauvais mot de passe.

  Sauf que j' ai bien tapé mon adresse mail, et j' ai le bon mot de passe... D' ailleurs, si je me connecte sur le back office de mon site en prod (qui a la même base de données) avec ces identifiants je me connecte sans problème.

 

  Si je tente "mot de passe oublié" , je me retrouve avec une autre erreur (peut etre par ce que je suis en local)

Il y a une erreur.

    Une erreur est survenue lors du changement de mot de passe.

  J' ai vidé les caches des deux fichiers dont vous faites référence, sans plus d' avancées.

 

  Merci, bonne soirée.

 

  Edit : je viens d' essayer avec une base de données autre que celle que j' avais, une qui tourne en local sous Wamp, et bien j' ai le même problème, je suis redirigé vers mon site en prod, si je me connecte sur le back office, je suis cette fois ci en local, mais impossible de me logguer, mon identifiant est inconnu !

 

 

Vous avez modifier l'url du site dans onglet Préférence >> Seo&URL's ?

 

  C' est sans doute ça le problème, ou un truc du genre, mais comment faire maintenant, que je ne peux pas me connecter au back office ? Puis je modifier un fichier ?

 

  Bonne soirée.

Edited by ungars (see edit history)

Share this post


Link to post
Share on other sites

Si vous n'avez pas modifier l'url dans Préférence >> Seo&Url's

 

Allez dans la base de donnée via phpmyadmin en local http://localhost/phpmyadmin ou http://127.0.0.1/phpmyadmin,

 

Sélectionnez votre base de donnée puis dans ps_configuration à droite rechercher en affichant tout la table ps_shop_domain et ps_shop_domain_ssl

 

vérifier aussi colonne de gauche

ps_shop_url

Share this post


Link to post
Share on other sites

lamp wamp xamp mamp amp tous le même principe :)

 

Apache Mysql et moteur php.

 

 

 

 

ErrorDocument 404 /prestashop/prestashop/index.php?controller=404
RewriteRule . - [E=REWRITEBASE:/prestashop/prestashop/]

 

Bizarre deux dossiers prestashop ?

 

/var/www/prestashop/cache/smarty/compile/

/var/www/prestashop/cache/smarty/cache/

 

dans ces deux dossiers vous pouvez tout supprimer sauf l'index.php

cela sert a rien de changer le chmod dans ces deux dossiers, vidé les tranquillement. :) ça ne vous casse pas l'accès.

 

Quand vous êtes en local ça ne sert a rien de demander le mot de passe, vu que par défaut vous n'avez as forcément le smtp à moins de configurer avec le smtp de votre fournisseur d'accès internet.

 

Par contre il est possible de modifier le mot de passe manuellement en directe dans la base de donnée.

Edited by Oron (see edit history)

Share this post


Link to post
Share on other sites

  Bonjour,

Bizarre deux dossiers prestashop ?

 

Oui, c' est moi qui a fait une fausse manip en transférant les fichiers sur le ftp de mon hébergement qui me sert à faire mes essais. Vu que ce n' est que moi qui m' en sert, je n' ai pas fait la modification, mais cela fonctionne : http://www.avignon-net.com/prestashop/prestashop/

 

dans ces deux dossiers vous pouvez tout supprimer sauf l'index.php

  Oui, je l' ai fait, mais sans amélioration.

 

cela sert a rien de changer le chmod dans ces deux dossiers, vidé les tranquillement. smile.png ça ne vous casse pas l'accès.

 

  J' ai été obligé de le faire, sinon si je tente de me connecter au back office, je me retrouve avec ce message d' erreur :

Fatal error: Uncaught --> Smarty: unable to write file /var/www/prestashop/cache/smarty/compile/e3/f9/77/wrt54134f76c2eb37_10148013 <-- thrown in /var/www/prestashop/tools/smarty/sysplugins/smarty_internal_write_file.php on line 46 

  Apparament il ne peut ecrire sur ce fichier, donc je l' ai passé en 777. Je n' ai plus ce message d' erreur une fois les permissions modifiées de cette façon.

 

Quand vous êtes en local ça ne sert a rien de demander le mot de passe, vu que par défaut vous n'avez as forcément le smtp à moins de configurer avec le smtp de votre fournisseur d'accès internet.

 

Par contre il est possible de modifier le mot de passe manuellement en directe dans la base de donnée.

 

  Vous parlez de quel mot de passe ? Celui d' admin ou celui de la base de données ?

 

  Donc même avec le ftp qui était en local à l' origine sur mon pc que j' ai transféré sur une machine virtuelle, même avec la base de données que j' avais aussi en local et que j' ai mis sur ma machine virtuelle, je me retrouve connecté sur la base de données du mutualisé... C' est à n' y rien comprendre ! Et pourquoi lorsque je me connecte en admin, je suis cette fois ci en local ? Pourquoi mon mot de passe est refusé ?

 

  Je tenterai la manipulation decrite sur votre précédent message ce soir à mon retour, n' étant pas chez moi. Après je retenterai une réinstallation, en prenant le ftp du mutualisé, et la base de données du mutualisé, peut etre que j' ai trop mixé local et mutualisé, je ne sais pas. C' est la première fois que je suis confronté à ce genre de problème.

 

  En tout cas merci du temps que vous me consacrez.

 

  Bon Dimanche.

Share this post


Link to post
Share on other sites

  Bonjour,

On avance, on avance !

 

 

vérifier aussi colonne de gauche

ps_shop_url


  Effectivement cela pointait vers l' adresse du site en prod, j' ai donc modifié :

Domain varchar 150 : localhost

Domains ssl varchar 150 : localhost

physical uri varchar 150 : /prestashop/

  En local, je me connecte en tapant localhost/prestashop.

 

  Par contre là je coince :

 

Sélectionnez votre base de donnée puis dans ps_configuration à droite rechercher en affichant tout la table ps_shop_domain et ps_shop_domain_ssl

  Je trouve bien ps_configuration à droite, mais si je fais "afficher" , je ne trouve pas de ps_shop_domain ni de ps_shop_domain_ssl, je dois surement mal m' y prendre.

 

  En revanche, le fait d' avoir modifié à gauche, je suis maintenant pour de bon en local ! Mais :

-Aucune photo n' est visible

-Les catégories me mènent vers une erreur 404

  Sans doute quand j' aurai modifié la colonne de droite, cela fonctionnera.

 

  Et toujours impossible de me connecter au back office, mon identifiant est refusé.

 

  Merci pour votre aide, bonne soirée.

Share this post


Link to post
Share on other sites

  Bonsoir,

  Je me permets de faire un up. J' ai refait une installation, en retéléchargeant fichier + base de données sur ma machine virtuelle, le problème est le même, et cette fois, j' ai une page blanche lorsque je tente d' ouvrir la page d' identification pour me connecter au back office...

 

  Il y avait du mieux en modifiant certains éléments de la base de données, mais je suis toujours confronté à ce problème : je n' arrive pas à accéder à ps_shop_domain et ps_shop_domain_ssl dans ps configuration à droite de phpmyadmin. Je ne le trouve pas (voir mon précédent message)

 

  Merci pour votre aide, on approche du but.

Share this post


Link to post
Share on other sites

Bonjour

 

Dans la table ps_config à droite déployer toutes les lignes et rechercher ou utilisé la fonction recherche de votre navigateur et taper

PS_SHOP_DOMAIN et PS_SHOP_DOMAIN_SSL

 

Il faut afficher 1000 ou plus de ligne pour que tout soit visible sur une page.

Share this post


Link to post
Share on other sites

  Bonsoir,

  Et merci pour ces explications qui m' ont permis de trouver ce que je cherchais.

  Donc j' ai modifié :

- A gauche ps_shop_url en mettant localhost

- A droite ps_shop_domain et ps_shop_domain_ssl, en mettant aussi localhost

 

  Cette fois ci je suis bien en local, mais que ce soit en back ou front office, je n' ai qu' une page blanche.

 

  Merci encore pour le coup de main et pour votre patience, bonne soirée.

Share this post


Link to post
Share on other sites

Étape suivante :

 

La ligne sur une 1.5 / 1.6 dans config/defines.inc.php
define('_PS_MODE_DEV_', false); << mettez false à true >> define('_PS_MODE_DEV_', true);
 

Si c'est un problème d'interprétation d'un fichier vous verrez un message d'erreur. Copier Coller au moins la 1ere ligne.
Si le nom de votre dossier d'administration apparait remplacé le par des *****.
 

Share this post


Link to post
Share on other sites

  Bonjour,

  J' ai donc modifié la rubrique comme vous me l' avez demandé :

/* Debug only */
if (!defined('_PS_MODE_DEV_'))
define('_PS_MODE_DEV_', true);

  Je me suis retrouvé avec un problème de permission sur l' ecriture des cache de smarty (je ne sais pas en revanche si c' est cette modification qui a fait ça) . En attendant, j' ai passé ces fichiers en chmod 777.

 

  Donc on avance tout doucement, je suis en local, cette fois la page s' affiche, mais bizarrement :

http://www.avignon-net.com/Capture.png

 

  Si je veux accéder au back office, même chose, avec des problèmes de permissions là aussi.

 

 

  Ca c' est si je me connecte via firefox qui est sur ma machine virtuelle. Si je veux me connecter depuis une autre machine sur mon lan, c' est toujours une page blanche.

 

  Merci beaucoup, bonne journée.

Share this post


Link to post
Share on other sites

Bonjour

 

La cause de l'affichage en texte simple est que le chemin de vos fichier css n'est pas le bon.

A votre place je simplifierai les dossiers /prestashop/ de mettre qu'un seul.

 

Et de mettre le bon chemin dans Préférences >> Seo&Url's d'indiquer localhost/prestashop/ ou si vous voulez gardez vos doubles dossiers localhost/prestashop/prestashop/

 

C'est juste une question de chemin. Là je peux voir ce que vous avez mis, il faudrait visualisé la source.

Share this post


Link to post
Share on other sites

 

 

Je me suis retrouvé avec un problème de permission sur l' ecriture des cache de smarty (je ne sais pas en revanche si c' est cette modification qui a fait ça) . En attendant, j' ai passé ces fichiers en chmod 777.

 

Le cache smarty eet compile vous supprime ce qu'il y a dedans et ne vous cassez pas la tête avec des chmod sur les fichiers dans le cache. A partir du moment que dans vous dossier cache on peut créer, modifier, enregistrer les fichiers.

Share this post


Link to post
Share on other sites

  Bonjour,

 

La cause de l'affichage en texte simple est que le chemin de vos fichier css n'est pas le bon.

A votre place je simplifierai les dossiers /prestashop/ de mettre qu'un seul.

  Je l' ai fait, mais sans changement...

 

 

 

Et de mettre le bon chemin dans Préférences >> Seo&Url's d'indiquer localhost/prestashop/

 

    Je ne peux accéder à mon back office, je ne peux donc effectuer cette opération. J' ai juste fait les modifications sur la base de données :

- A ps_shop_url de cette façon :

Domain varchar 150 : localhost

Domains ssl varchar 150 : localhost

physical uri varchar 150 : /prestashop/

  Et sur ps_shop_domain et ps_shop_domain_ssl, en mettant aussi localhost.

 

  Est ce que c' était ce que vous m' aviez demandé de faire ? Puis je faire encore quelque chose ?

 

 

Le cache smarty eet compile vous supprime ce qu'il y a dedans et ne vous cassez pas la tête avec des chmod sur les fichiers dans le cache. A partir du moment que dans vous dossier cache on peut créer, modifier, enregistrer les fichiers.

 

 

  J' ai été obligé de faire un chmod dessus, sinon je me retrouve avec ce message d' erreur :

Fatal error: Uncaught --> Smarty: unable to write file /var/www/prestashop/cache/smarty/compile/e3/f9/77/wrt54134f76c2eb37_10148013 <-- thrown in /var/www/prestashop/tools/smarty/sysplugins/smarty_internal_write_file.php on line 46 

  En vous remerciant encore pour votre aide, bonne journée.

Edited by ungars (see edit history)

Share this post


Link to post
Share on other sites

  Re,

  Cette fois ci on y est presque je pense : dans ps_shop_url, j' ai modifié la ligne en faisant plusieurs essais (je mettais ce qui fonctionne sous wamp) sans succès, je remets /prestashop/ et je ne sais pour quelle raison, j' ai la page d' accueil qui s' affiche, sans les images (que le diaporama) . Aucun lien en fonctionne (erreur 404) . Je ne sais pas pourquoi cela ne fonctionnait pas avant.

  Donc il reste à savoir pourquoi les liens sont morts, et pourquoi les images ne s' affichent pas.

 

  Bon après midi.

Share this post


Link to post
Share on other sites

 

 

physical uri varchar 150 : /prestashop/

  Et sur ps_shop_domain et ps_shop_domain_ssl, en mettant aussi localhost.

 

si les fichiers sont sur http://localhost/prestashop/prestashop/ il faut mettre localhost/prestashop/prestashop

et pour l'index /prestashop/prestashop/

 

Si les fichiers sont sur http://localhost/prestashop/ il faut mettre localhost/prestashop/ et pour l'index /prestashop/

Share this post


Link to post
Share on other sites

  Bonsoir,

 

 

 

Si les fichiers sont sur http://localhost/prestashop/ il faut mettre localhost/prestashop/ et pour l'index /prestashop/

 

  Oui, je les ai mis ainsi, j' avais fait une erreur lors du transfert de mon mutualisé vers mon pc, maintenant c' est bien l' adresse de prestashop en local sur mon pc. L' index correspond à physical uri varchar c' est ça ? et je dois mettre localhos/prestashop à domain varchar et domain ssl varchar c' est bien ça ?

 

  Merci pour le coup de main, bonne soirée.

Share this post


Link to post
Share on other sites

  Bonsoir,

  J' ai tenté de mettre les mêmes reglages que sur wamp qui tourne en local et sans problème sur la même machine, à savoir sur ps_shop_url :

Domain varchar  : localhost

Domains ssl varchar  : localhost

physical uri varchar  : /prestashop/

  Et sur ps_shop_domain et ps_shop_domain_ssl, en mettant aussi localhost.

 

  Le problème est le même...

 

  Sur Wamp, ou tout fonctionne correctement, j' ai voulu là aussi importer la base de données qui est sur le mutualisé. Avec les reglages ci dessus, j' ai les mêmes problèmes que sur lamp, qui ont motivés l' ouverture de ce post.

 

  N' y a t' il pas autre chose à changer sur la base de données ?

 

  Bonne soirée, bon début de semaine

Share this post


Link to post
Share on other sites

Bonjour

 

Sur c:\wamp\www\prestashop\prestashop = http://localhost/prestashop/prestashop =

dans ps_shop_domain et ps_shop_domain_ssl = localhost/prestashop/prestashop

 

Index /prestashop/prestashop/

 

Sur c:\wamp\www\prestashop\ = http://localhost/prestashop/ =

dans ps_shop_domain et ps_shop_domain_ssl = localhost/prestashop/

 

Index /prestashop/

 

Sur c:\wamp\www\ = http://localhost/ = dans ps_shop_domain et ps_shop_domain_ssl = localhost/

 

Index /

 

Voilà est-ce plus clair vous me suivez ?

Share this post


Link to post
Share on other sites

  Bonsoir et merci pour votre réponse, je tenterai ce soir à mon retour.

 

dans ps_shop_domain et ps_shop_domain_ssl = localhost/prestashop/prestashop

 

Même si maintenant j' ai remis prestashop dans localhost/prestashop ? (il n' est plus dans localhost/prestashop/prestashop, c' était une erreur au début que j' ai corrigé).

 

index /prestashop/

 

  L' index je le trouve ou ?

 

  Merci pour votre aide précieuse et pour votre patience.

Share this post


Link to post
Share on other sites

Quote

index /prestashop/

 

  L' index je le trouve ou ?

 

C'est le chemin de l'index pas le fichier index.php mais ça veut dire que l'index.php se trouve à cet endroit /prestashop/

que c'est la page d'accueil.

Share this post


Link to post
Share on other sites

  Bonsoir,

  Donc j' ai fait le changement comme vous me l' avez indiqué :

- Sous Wamp, après avoir téléchargé la base de données de mon site en prod, j' ai eu à peu près la même image que j' avais déjà eu sous Lamp, à savoir ça . Après avoir fait le changement comme vous m' aviez indiqué (dans ps_shop_domain et ps_shop_domain_ssl = localhost/prestashop/), les liens sont morts, seul le texte et le cadre de la photo apparait pour le diaporama, je n' ai aucune image (la partie Facebook apparait)

- Sous Lamp, seul le texte apparait pour le diaporama (pas le cadre de la photo) , presques toutes les photos apparaissent sur la page d' accueil, les liens fonctionnent avec toutes les images, l' image qui n' apparaissait pas en page d' accueil apparait dans les catégories)

 

  Donc c' est beaucoup mieux sous Lamp, mis à part une photo qui n' apparait pas et le diaporama, reste à savoir pourquoi le même reglage ne fonctionne pas aussi bien sous Wamp.

 

  Merci, bonne soirée.

Share this post


Link to post
Share on other sites

  Bonsoir,

  Alors je viens de me rendre compte que sur Lamp, ou le site apparaissait à peu près comme il faut, les images des catégories ne correspondent pas aux textes... Et sur Lamp, un coup le texte du diaporama apparait, un coup pas, et entre temps je n' ai rien touché. Je ne peux toujours pas me connecter au back office, on me dit que mon compte n' existe pas, alors qu' il existe pourtant.

  Mes sauvegardes de bases de données sont faites via le back office

  Rien n' est logique, et rien pour nous mettre sur la voie d' un semblant de piste. Je ne comprends pas pourquoi cela me pose des problèmes, et comment font les autres pour y arriver.

  Demain je vais rentrer tard, Jeudi je ferai un résumé de tout ce qui a été fait depuis, peut etre que cela sera plus clair comme ça. A l' issue, si on ne trouve pas de solution, je laisserai tomber, à un moment il faut savoir s' arréter.

  Bonne soirée.

Edited by ungars (see edit history)

Share this post


Link to post
Share on other sites

  Ca y est ! Enfin ! J' ai tenté hier une dernière fois de voir là ou je n' avais pas encore regardé. Et là je pense que c' est bon, cela fait 3 transferts que je fais et qui fonctionne. Mis à part une image qui a disparu, je ne sais pas si cela peut arriver au cours d' un transfert, tout fonctionne ! Donc voila comment j' ai fait, car à mon avis d' autres se feront avoir :

-  Renseigner avant de faire la migration sur le site en prod la rubrique "url" dans "préférence" (à la main, dans phpmyadmin, cela ne fonctionne pas, ne me demandez pas pourquoi)

- On fait le transfert, et là on peut accéder au back office (l' ident est connu) . On obtient toujours une erreur 404 (mais là on obtient la page personnalisée de Prestashop) , les images ne sont toujours pas visible.

- Et là le geste qui sauve, on décoche l' option "url simplifiée" dans "seo url" . Sur mon site en prod c' était à "non", quand je l' ai sauvegardé en local c' est passé à "oui" (ne me demandez toujours pas pourquoi")

 

  Donc laisser cette option à "non", est ce que cela va changer grand chose pour moi ?

 

  Bonne journée.

Share this post


Link to post
Share on other sites

Bonjour

 

En local l'urk rewriting n'est pas,nécessaire et cela ne casse pas vos liens vu que c'est noter dans la base de donnée.

Et en local ou en ligne vous pouvez générez les url rewriting manuellement.

 

Pour que l'url rewerting fonctionne en local la fonction doit être activé dans le fichier de configuration apache http.conf

Share this post


Link to post
Share on other sites

  Bonjour, merci pour votre réponse. Je ne trouve pas cette option dans httpd.conf d' apache, j' ai fait une recherche avec "url" , "rewriting" mais je n' ai rien trouvé.

  Cette option doit être désactivée par défaut sur le mutualisé qui héberge mon site en développement.

  Par contre, j' ai désactivé "url simplifiées" sur le mutualisé pour test, quand je l' ai réactivé, j' ai perdu la quasi totalité de mes images sur la page d' accueil (les nouveautés" : http://www.avignon-net.com/prestashop/prestashop/index.php . Savez vous comment je peux les récupérer ?

  En tout cas c' était bien ça mon problème, j' ai depuis fais trois fois l' expérience, c' est cette option qui posait problème lors de la restitution en local de mon site. La première fois une image avait disparu, mais j' ai eu ce problème qu' une seule fois, peut etre que la sauvegarde était corrompue.

 

  Merci beaucoup pour votre aide, bon Dimanche.

Share this post


Link to post
Share on other sites

Bonjour

 

Il faut que je recherche quel est la ligne pour activer l'url rewriting dans http.conf je ne l'ai pas en tête tout le http.conf :)

Quand normalement vous deviez pas perdre les images, en local désactivé le .htaccess en le renommant.

Pour les images si elle n’apparaissent plus faites une régénération des images mais pas forcément toutes ensembles, plutôt par groupe enfin du moins celle qui ne sont pas afficher.

Share this post


Link to post
Share on other sites

  Bonjour merci pour votre réponse.

 

 

Il faut que je recherche quel est la ligne pour activer l'url rewriting dans http.conf je ne l'ai pas en tête tout le http.conf

  En local, comme vous me le disiez ce n' est pas génant, donc pas grave, c' est surtout sur le mutualisé que je ne peux activer cette option, car je n' ai pas accès aux options d' apache, notamment sur le http.conf.

 

  J' ai tenté de regénérer les miniatures, de changer de nom au fichier .htaccess (renommé pour l' occasion .htaccess2) , mes images ne sont toujours pas réapparue...

  J' ai l' impression qu' il ne faut pas activer l' option de réecriture, si le serveur ne le permet pas.

 

  Bon après midi, et merci encore.

Share this post


Link to post
Share on other sites

  Bonjour, je fais un up. J' ai réactivé les miniatures (au passage c' était bien ça qu' il fallait que je fasse) , et rien n' est réapparu, j' ai toujours l' unique image en page d' accueil, par contre sur les catégories, c' est bon, tout y est.

 

  Bonne journée.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More