Jump to content
Sign in to follow this  
bambi

Translations disappears on attempt to make a change

Recommended Posts

Updated from PS1.1 to PS1.2

Tried to change / update manually translation text in back office. After pressing 'update translations' it is indicating 'update succssful' but I loose a good deal of what was translated already.

Any help appreciated ;-)

Dan

Share this post


Link to post
Share on other sites

I found out what the problem was.

It is server related. Need to tellthe server to increase transfer zise.

Created a file called .htaccess with following text

php_value suhosin.request.max_vars 2048
php_value suhosin.post.max_vars 2048

planted the file in the root of the shop.

And all is well.

I am attacheing the file cause it may be difficult for some to creat a .htaccess extention.

htaccess.zip

Share this post


Link to post
Share on other sites

This may work for some, but not for me.

If I add these lines to my .htaccess (I have the PS generated one for pretty urls), I get an error: 500 Server Error.

Share this post


Link to post
Share on other sites

You may need to do a similar change in your php.ini file.
Ask your host, since they control the php configuration...

Share this post


Link to post
Share on other sites

Try adding these two lines to your /php.ini file.
If you don't have one on your server, create on in the root of your site, and type these 2 lines in it.

suhosin.post.max_vars = 2048
suhosin.post.max_value_length = 2048

now try again.

Share this post


Link to post
Share on other sites

I tried that option also, without success but thanks for tat tip... I don't know what is wrong

Share this post


Link to post
Share on other sites

Could be that your hosting is blocking you from making those changes.

You can try to make a phpinfo file, call it info.php inside have:
<?
phpinfo();
?>

Upload it to your root folder and open it in a browser.

Now look for post.max_vars and see if it's there with the value 2048.

Share this post


Link to post
Share on other sites

Thanks for the help! I did it and it says nothing like that if you like i can send you the link.

Share this post


Link to post
Share on other sites

No need, contact your host and ask them about it, sounds like they don't allow you to change those values....

Share this post


Link to post
Share on other sites

i can log in to the hosting panel what should i change and where?

Share this post


Link to post
Share on other sites

If it was something you could change there, I would have suggested it.....

Share this post


Link to post
Share on other sites

Everything is set well, but I still have the problem. I found out it only happens with this template I am using but not with the original one... What could it be? Anyone?

Share this post


Link to post
Share on other sites

you mean that if you switch to the default theme, the translations are there, but when you switch to another theme they are gone?

Share this post


Link to post
Share on other sites

Yes they are onlly translated well in to dutch when I use the original template.

Share this post


Link to post
Share on other sites

same problem to me.
i made some translations, and then, the lines i have transalate are empty, no reason why, no error message!
the problem apears on modules translations and back office.

this is HUGE problem and it cant be fixed somehow, presta is useless to foreign users...

Share this post


Link to post
Share on other sites

the problem is not in all groups, it is in some of them only.

i my case:
group AdminModulesPositions (any thing in last 6 lines, after a save, its gone!)
group AdminOrderMessage - all lines
group AdminOrders - all lines
group AdminOrdersStates - all lines

the deletion of the translated lines it is NOT always, the most of times it happens!!

Share this post


Link to post
Share on other sites

i am continuing the report with problems;
group AdminZones - it deletes the 2-4-6-8-10-12 lines (1-3-5-7-9-11 dont deleted)
group index - it deletes the 1-3-5-7-9-11 etc lines (2-4-6-8-10-12 dont deleted)

Share this post


Link to post
Share on other sites

group AdminTab – it deletes the 2-4-6-8-10-12 lines (1-3-5-7-9-11 dont deleted)

well, after all this, dont say me its my fault....

its NOT my fault, it is something wrong with the save operation in translation tool.

Share this post


Link to post
Share on other sites

my post.max_vars is 1000.

is it wrong?

is it somethink i can change myself, can i bypass it or i must contact to my hosting provider?

Share this post


Link to post
Share on other sites

I have the same problem with my Black&white;them, but work well with default theme. Any help please.

I tried all the permission and ini value, but if it works with default theme, then it is clear that i have some problem within theme folder

Share this post


Link to post
Share on other sites

I've checked post_max_size on my host and it says 20M so I assume that's all right. I also checked the translation file right - set to 755. However when I change something in the Sitemap translation section, it doesn't display anything but when I change 404 error message it works like a charm.

I'm desperate. Do you have any ideas what could be wrong?

thanks

Share this post


Link to post
Share on other sites
What about the settings for suhosin?

/Kjeld


sorry for maybe stupid question but what is suhosin?

Share this post


Link to post
Share on other sites
I've checked post_max_size on my host and it says 20M so I assume that's all right. I also checked the translation file right - set to 755. However when I change something in the Sitemap translation section, it doesn't display anything but when I change 404 error message it works like a charm.

I'm desperate. Do you have any ideas what could be wrong?

thanks


check that do your theme folder have any modules folder, if so then you need to add your language_ISO.php file from original module to this theme module.

It will be a better solution if you do not need that module folder, than just delete all the folder from module folder on theme, it will work well.

PLEASE NOTE CAREFULLY: I TALKED ABOUT ROOT/themes/theme/modules folder, DO NOT delete your ROOT/MODULES folder
And the language ISO file , like for English en.php, you will find this in your root module/your_module folder

Thanks

Share this post


Link to post
Share on other sites

Thanks Arafat but there is no such folder in my theme folder.

I had a look in my lang folder and the language file gets changed when I update it as such:

<?php

global $_LANG;
$_LANG = array();
$_LANG['sitemap_a82be0f551b8708bc08eb33cd9ded0cf'] = 'Contact';

?>



but it doesn't work, doesn't display anything. Could this be related to .htaccess file? however the file has been generated by prestashop itself.

Share this post


Link to post
Share on other sites

For the love of Christ, i am experiencing the same problem and after 3 pages of topic there is no definitive answer, what is the actual feedback of developers? why doesn't prestashop include a check on max post size and problems of such manner to ensure it's complete functionality? post_max_size 8M 8M <- i guess that is ok but still we need a complete checklist to solve this huge setback and get everything going back as it was!

Share this post


Link to post
Share on other sites
For the love of Christ, i am experiencing the same problem and after 3 pages of topic there is no definitive answer, what is the actual feedback of developers? why doesn't prestashop include a check on max post size and problems of such manner to ensure it's complete functionality? post_max_size 8M 8M <- i guess that is ok but still we need a complete checklist to solve this huge setback and get everything going back as it was!


The solution is in post #5 http://www.prestashop.com/forums/viewreply/281750/

You must check with your host how to set it, and some hosts do not allow a php.ini file, you can try to do it in the .htsccess file, but your host will know best.

Share this post


Link to post
Share on other sites

Somebody help me!
My htaccess was hidden and I don't even know it exists, so I put the new htaccess like bambi sugested and now my shop disappeared and shows a message like "Internal server error" 500 Internal Server Error!
I'm sorry but I'm a newbie.
It's possible to get my htaccess file again? I can find it in some backups whithout make the entire backup??? Please say yes!

------------> Problem solved! I found the htaccess in one of my backups and uploaded it. uffff it works!
I've just copy paste the two lines in init file and htaccess (it doesn't work) but I think it's not so simple...we have to put those > or <? ou another thing?

Share this post


Link to post
Share on other sites

After reading through this entire thread and trying all the suggested solutions, it appears to me that if the hosting provider does not allow changes to the php, then it is not possible to save additional translations. Is this correctly understood? Or is there another workaround by now? I am using Prestashop 1.4.7.0 and really like the new template. However, I cannot add the necessary translations to the Danish.

Is there anything else I can try? or do I have to change hosting provider?

Share this post


Link to post
Share on other sites

Hi,

 

My phpinfo is here: http://tutivital.hu/webaruhaz/phpinfo.php . I think it is high enough. but I receive this error message if I would like to work with admin and modules translations:

 

Warning, your hosting provider limits the maximum number of fields to post in a form:

19001 for suhosin.post.max_vars

19001 for suhosin.request.max_vars

1000 for max_input_vars

Please ask your hosting provider to increase the sushosin to: 2604 or edit the language file manualy.

 

The site language is Hungarian (or it would like to be :rolleyes: ).

 

Thanks in advance if you can help.

 

Fecsó

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More