Jump to content

Problème de couleurs différentes sur l'image "block_bg.jpg"


Recommended Posts

J'ai un problème sur mon bloc "Catégories" : il est "coupé" en deux teintes (j'ai du mauve foncé en haut, et du mauve clair en bas)...et je ne parviens pas à identifier le problème.

Il s'agit, en fait, de l'image "block_bg.jpg".
J'ai beau retravailler cette image, la réenregistrer, etc...rien n'y fait!
Quelqu'un aurait-il une piste à explorer?...Merci d'avance!

Share this post


Link to post
Share on other sites

Bonjour,

Regardez du coté du css, vous devez avoir un truc du style :

div.block .block_content {
background:#F1F2F4 url(../img/block_bg.jpg) repeat-x left bottom;
border-left:1px none #D0D3D8;
border-right:1px none #D0D3D8;
min-height:20px;
padding:0.5em 0.7em 0;
}



Nous allons nous intéresse à celle ligne :
background:#F1F2F4 url(../img/block_bg.jpg) repeat-x left bottom;

cette ligne apporte beaucoup d'élément à votre block :
- La couleur de fond
- l'image de fond
- répétition de l'image de fond
- la position de l'image de fond (la première)

Dans votre cas vous avez du modifier l'image block_bg.jpg qui d'origine est de ton gris.
afin de palier à des problèmes de différence fond il avait été rajouté une couleur de fond afin de gérer le background en fonction de la hauteur du block.
cette couleur est #F1F2F4 qui correspond au gris final du dégradé de l'image block_bg.jpg .

Je ne suis peut être pas clair, mais si vous ne changez pas cette valeur (#F1F2F4) vous aurez toujours ce probleme de background.

V++

Atch

Share this post


Link to post
Share on other sites

@ Atch : Merci pour votre aide.
J'avais bien pensé aussi, ayant éliminé d'autres causes possibles, qu'il pouvait y avoir un problème de deux fonds l'un sur l'autre.
Mon image block_bg. n'a bien qu'une seule teinte (même si c'est du dégradé) et ce mauve qui me gêne sur le haut du bloc Catégories semble bien être la couleur que j'ai choisie + une teinte par-dessus qui rend l'image, au final, plus foncée.

Bref, alors moi, dans mon div.block_content, j'ai (en plus par rapport à votre impression d'écran à vous) :
-moz-background-clip : border;
-moz-background-inline-policy : continious;
-moz-background-origin : padding;

...et je ne sais pas à quoi cela correspond, moi...

Par contre, j'ai dans mon background "classique", mon code couleur à moi (#DF90EB) et non plus, bien-sûr, F1F2F4).

Si ma réponse vous donne plus de précision pour m'aider, ce serait chouette!
Merci !

Share this post


Link to post
Share on other sites

Désolée mais je n'ai toujours pas plus d'éléments pour régler mon pbl de couleur différente dans le bloc Catégories (et c'est vraiment vilain...à faire fuir mes futurs clients potentiels!!).
Pourrait-on m'aiguiller un peu plus, suite à mon dernier post?...
Merci !

Share this post


Link to post
Share on other sites

Ma boutique étant loin d'être achevée, je n'ai pas envie de la publier, ne serait-ce que la page d'accueil. Merci de le comprendre.
Je suppose qu'il y a moyen de m'aider même sans imprime-écran ?

Les infos d'Atch me semblaient fort utiles; dommage qu'il ne soit pas allé plus loin dans ses conseils...

Share this post


Link to post
Share on other sites

Oui...C'est exactement le même problème que moi !!

Mais je ne veux pas de gris, moi. J'ai modifié tous mes fonds de blocs en violet.
Donc, il n'y a aucun intérêt pour moi à modifier en #F1F2F4...ou alors, je n'ai rien compris du tout !!

En effet, c'est ma couleur de fond qui me gêne...et non pas l'image background que j'ai enregistrée, sélectionnée exprès.
Je me retrouve avec du violet uni et assez foncé...alors que tous mes autres blocs (et même une grande partie du bloc concerné, le bloc Catégories) sont en violet pâle, dégradé.

Merci d'éclairer à nouveau ma lanterne...

Share this post


Link to post
Share on other sites

Bonsoir,

Ligne 296 du css:

div.block .block_content {
background:#D0D3D8 url(../img/block_bg.jpg) repeat-x scroll left bottom;
border-left:1px none #D0D3D8;
border-right:1px none #D0D3D8;
min-height:20px;
padding:0.5em 0.7em 0;
}
La coupable est là
background:#D0D3D8 url(../img/block_bg.jpg) repeat-x scroll left bottom;

c’est soit la couleur de fond #D0D3D8, soit l’image du backrground block_bg.jpg qui ne correspond pas à votre attente…

Essayez avec #F1F2F4 à le place #D0D3D8

soit :

div.block .block_content {
background:#F1F2F4 url(../img/block_bg.jpg) repeat-x scroll left bottom;
border-left:1px none #D0D3D8;
border-right:1px none #D0D3D8;
min-height:20px;
padding:0.5em 0.7em 0;
}
V++

Atch

Signature
Nouveau template / New template “ Atch_grunge”
Boutique en ligne...
Mes templates : Atchworks(free) / Atch brown and Blue/ Atch_glam

Share this post


Link to post
Share on other sites

Non, logique peut-être...mais il n'empêche que votre truc ne donne rien chez moi.
De plus, à la ligne 296, je n'ai pas le block content...Il est ailleurs, bien plus loin, le mien...Comme quoi, chaque cas semble différent à traiter parfois.
Merci.

Share this post


Link to post
Share on other sites
Non, logique peut-être...mais il n'empêche que votre truc ne donne rien chez moi.
De plus, à la ligne 296, je n'ai pas le block content...Il est ailleurs, bien plus loin, le mien...Comme quoi, chaque cas semble différent à traiter parfois.
Merci.


cherchez dans votre global.css

la ligne :
div.block .block_content

localisez le background et modifiez la valeur #D0D3D8, ou autre je ne sais pas ce que vous avez, par la couleur qui vous correspond...

Essayez par exemple #f4daf8.... qui est un rose(pale) et non un gris.

Merci de ta patiente bilgates ;)

V++

Atch

Share this post


Link to post
Share on other sites

Bien-sûr, j'ai justement modifié la couleur de mon background du block_content, il y a plusieurs jours, concernant donc mon bloc Catégories (l.927). Et c'est là que les choses se sont dégradées...

Alors, voilà ce que j'ai dans mon Globalcss, au niveau du block_content :

-moz-background-clip: border;
-moz-background-inline-policy: continious;
-moz-background-origin: padding;
background: #DF90EB url (../img/block_bg.jpg) repeat-x scroll left bottom;
border-left: 1px none #D0D3D8;
border-right: 1px none #D0D3D8;
...........

Share this post


Link to post
Share on other sites

Du coup, je pense que je vais régler mon problème en choisissant une autre teinte, plus claire...et, surtout, en évitant mes dégradés.
Le résultat est acceptable même s'il ne correspond pas exactement à mes souhaits de couleur initiaux.
Merci à Bilgates et à Atch pour leur aide...et patience, en effet!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More