Jump to content

[free module] Manufacturers block with brand logo


Recommended Posts

  • 2 weeks later...

Thank you for this module.

Work great on 1.6.0.9

 

La partie configuration du module est vide par contre. Est-il utile de laisser cette partie alors qu'aucune configuration n'est possible? Au moins prévenir du fait que c'est module automatisé et que cet onglet ne sert à rien.

 

Merci encore !

Share this post


Link to post
Share on other sites
  • 3 weeks later...

I might be confused as to what this mod is supposed to do.  I thought by default, Prestashop already had a section for uploading one manufacturer image to be displayed everywhere regardless of size.  I am not using the default template, so that might be the issue. The information above says: Module can be placed in most important hooks in prestashop like: - left column, - right column, - footer , section, - top section, - homepage, which would lead to me think there is configuration of the module.

Share this post


Link to post
Share on other sites
  • 1 month later...

I might be confused as to what this mod is supposed to do.  I thought by default, Prestashop already had a section for uploading one manufacturer image to be displayed everywhere regardless of size.  I am not using the default template, so that might be the issue. The information above says: Module can be placed in most important hooks in prestashop like: - left column, - right column, - footer , section, - top section, - homepage, which would lead to me think there is configuration of the module.

 

You can use PrestaShop's hook manager for that, under Modules -> Positions.

Share this post


Link to post
Share on other sites

Hi Vekia,

Thanks for this module, works great.

 

Two questions:

1- How can I change the size of the logos, I am uploading 80x40 size logos and your module uses the medium_default image size, so the white space between logos are huge :)

2- What should I change if I want to show the logos on two column instead of one.

 

Basically I want a layout like picture attached!

 

brands.JPG

 

 

Thanks!

 

Btw: I use Prestashop 1.6.0.6

Edited by fatyas (see edit history)

Share this post


Link to post
Share on other sites
  • 3 weeks later...
  • 2 months later...
  • 1 month later...
  • 1 month later...
  • 2 months later...
  • 2 weeks later...

Hi,

Whenever I install this module no configuration shows, just a slideshow with mypresta modules as seen in the attached image. How do I fix this?

Hi, im getting the same... any help?

 

Regards

  • Like 1

Share this post


Link to post
Share on other sites

Hi, im getting the same... any help?

 

Regards

 

Hello,

 

I have exactly the same problem!

 

Also, I wish to know the solution to the images displayed in multiple columns .

 

Thanks for your help.

Share this post


Link to post
Share on other sites
  • 1 month later...

Hi,

 

Its a nice module. But I am trying to display the logos in 4 columns, instead of 1 in home page. Please let me know if that is possible. Thank you.

 

You change the first line of mib.css to:

[you can play with the margin for example to get the desired effect]

 

#mypresta_mib ul, #mypresta_mib li, #mypresta_mib a {display:inline; margin: 15px;}

I have different question though - how can you set a maximum number of manufacturers displayed?

Edited by matik4 (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites
  • 1 month later...
  • 2 weeks later...

Hi There,

 

I have installed the module in my prestashop (1.6.0.14) but i can't see the module and i don't see nothing happend in my frontend.

What is going wrong.

 

Can someone help me with this.

 

Kind regards,

 

Silvio v

Share this post


Link to post
Share on other sites
  • 3 weeks later...
  • 2 weeks later...
  • 1 month later...

Cześc,

 

mamy pytanie czy można zmienić tak ten moduł aby nie wyświetlał dostawców pionowo tylko poziomo?

 

Dodaj do #mypresta_mib ul w mib.css:    display: inline;

powinno dzialac :)

Share this post


Link to post
Share on other sites

Dzięki za odpowiedź, ale niestety moje umiejętności nie pozwalają mi tego za bardzo dokonać. Zmieniłem pierwszą linijkę aby wyglądała tak:

 

"#mypresta_mib ul, #mypresta_mib li, #mypresta_mib a {display:block; width:100%; text-align:center; display:inline}"

 

i nie działa niestety.

 

Mógłbyś podesłać dobrze edytowaną linijkę? Z góry dziękuję za pomoc i przepraszam za kłopot.

 

Mam też pytanie, czy edytuje ten plik PO zainstalowaniu w zakładce "moduły i usługi" czy PRZED?

Share this post


Link to post
Share on other sites

Dzięki za odpowiedź, ale niestety moje umiejętności nie pozwalają mi tego za bardzo dokonać. Zmieniłem pierwszą linijkę aby wyglądała tak:

 

"#mypresta_mib ul, #mypresta_mib li, #mypresta_mib a {display:block; width:100%; text-align:center; display:inline}"

 

i nie działa niestety.

 

Mógłbyś podesłać dobrze edytowaną linijkę? Z góry dziękuję za pomoc i przepraszam za kłopot.

 

Mam też pytanie, czy edytuje ten plik PO zainstalowaniu w zakładce "moduły i usługi" czy PRZED?

 

Witam, masz blad tam w cssie -> brak ; na koncu + zdublowane "display" dlatego nie dziala :)

w zasadzie nie ma znaczenia czy modyfikujesz przed czy po

 

podmien zawartosc mib.css kodem ponizej (byc moze bedziesz musial sie pobawic wartoscia przy "margin" lub "width" zaleznie od ukladu Twojej strony

przydatna funkcja do tego w przegladarce dla podgladu -> wcisnij CTRL+SHIFT+C

pzdr

 

 

#mypresta_mib ul, #mypresta_mib a {display:inline; width:25%; text-align:center; margin: 15px;}

#mypresta_mib a {
    transition: opacity .25s ease-in-out;
   -moz-transition: opacity .25s ease-in-out;
   -webkit-transition: opacity .25s ease-in-out;
   opacity:1.0;

}
#mypresta_mib a:hover {
    opacity:0.7;
}
#mypresta_mib li {
	display: inline;
	width: 25%;
	margin:auto; }

Share this post


Link to post
Share on other sites

zrobiłem wszystko według instrukcji tj. podmieniłem mib.css, skopiowałem na FTP, zainstalowałem. Efekt:

 

pion.jpg

 

Kompletnie nie wiem ocb. Ale i tak, dzięki za zaangażowanie Panie Matik4.

 sprawdz jeszcze cache - wyczysc w prestashop w zakladce 'zaawansowane -> wydajnosc'

do tego Twoj hosting provider rowniez moze miec 'swoj' cache, wiec poszperaj w panelu od hostingu np 'wyczysc cache cdn'

 

edit:

 

w sumie tamten css jest slaby, sprobuj te opcje:

#mypresta_mib ul, #mypresta_mib a {
    display: inline;
    width: 20%;
    text-align: center; }

#mypresta_mib a {
    transition: opacity .25s ease-in-out;
   -moz-transition: opacity .25s ease-in-out;
   -webkit-transition: opacity .25s ease-in-out;
   opacity:1.0; }

#mypresta_mib a:hover {
    opacity:0.7; }

#mypresta_mib li {
   display: block;
   width: 20%;
   margin: auto;
   float: left; }
   
   
@media (max-width: 767px) {
    #mypresta_mib li {
        width: 50%; }
#mypresta_mib ul, #mypresta_mib a {
    width: 50%; } }
Edited by matik4 (see edit history)

Share this post


Link to post
Share on other sites
  • 4 weeks later...

 

Manufacturer (brands) logo images block

This is totally free module and it creates block with manufacturer images (with links to manufacturer page). Module can be placed in most important hooks in prestashop like:

- left column

- right column

- footer section

- top section

- homepage

 

manufacturers-brands-logos-block.png

 

 

download link:

 

 

Hi Vekia!

 

Thanks for this module and also for all the support you always give!

 

I'm new on this and I don't understand enough, so I would really appreciate your help if possible....

 

Your module is great but I would like to have on homepage not only the logos but the manufacturers list itself as it appears on manufacturers page. My intention is that clients can see the promotions we'll have by manufacturer.

 

I've tried a lot of things but even for the best result I got, I received a message that there were no manufacturers. 

 

Can you help, please? Thanks!

Share this post


Link to post
Share on other sites

Hi Vekia!

 

Thanks for this module and also for all the support you always give!

 

I'm new on this and I don't understand enough, so I would really appreciate your help if possible....

 

Your module is great but I would like to have on homepage not only the logos but the manufacturers list itself as it appears on manufacturers page. My intention is that clients can see the promotions we'll have by manufacturer.

 

I've tried a lot of things but even for the best result I got, I received a message that there were no manufacturers. 

 

Can you help, please? Thanks!

 

SOLVED....I found another solution for this.

Share this post


Link to post
Share on other sites
  • 4 months later...
  • 1 month later...

mib.php    

 

can you tell what functionality doing this code in your module

 

<form name="selectform1" id="selectform1" action="'.$_SERVER['REQUEST_URI'].'" method="post"><input type="hidden" name="selecttab" value="1"></form>
        <form name="selectform2" id="selectform2" action="'.$_SERVER['REQUEST_URI'].'" method="post"><input type="hidden" name="selecttab" value="2"></form>
        <form name="selectform3" id="selectform3" action="'.$_SERVER['REQUEST_URI'].'" method="post"><input type="hidden" name="selecttab" value="3"></form>
        <form name="selectform4" id="selectform4" action="'.$_SERVER['REQUEST_URI'].'" method="post"><input type="hidden" name="selecttab" value="4"></form>
        '."<div id='cssmenu'>
            <ul>
               <li class='bgver'><a><span>v".$this->version."</span></a></li>
               <li class='".(Configuration::get('mib_lasttab')==1 ? 'active':'')."'><a href='#' onclick=\"selectform1.submit()\"><span>".$this->l('Configuration')."</span></a></li>
               <li style='position:relative; display:inline-block; float:right; width:65px;'><a href='http://mypresta.eu' target='_blank' title='prestashop modules'><img src='../modules/".$this->name."/logo-white.png' alt='prestashop modules' style=\"position:absolute; top:17px; right:16px;\"/></a></li>
               <li style='position:relative; display:inline-block; float:right;'><a href='http://mypresta.eu/contact.html' target='_blank'><span>".$this->l('Support')."</span></a></li>
               <li style='position:relative; display:inline-block; float:right;'><a href='http://mypresta.eu/modules/advertising-and-marketing/rewards-voucher-codes-after-orders.html' target='_blank'><span>".$this->l('Updates')."</span></a></li>
            </ul>
        </div>".'<link href="../modules/'.$this->name.'/css.css" rel="stylesheet" type="text/css" /><iframe src="//apps.facepages.eu/somestuff/whatsgoingon.html" width="100%" height="150" border="0" style="border:none;"></iframe><div style="float:left; text-align:left; display:inline-block; margin-top:5px;">'.$this->l('like us on Facebook').'</br><iframe src="//www.facebook.com/plugins/like.php?href=http%3A%2F%2Ffacebook.com%2Fmypresta&send=false&layout=button_count&width=120&show_faces=true&font=verdana&colorscheme=light&action=like&height=21&appId=276212249177933" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:120px; height:21px; margin-top:10px;" allowtransparency="true"></iframe>
        </div>
        <div style="float:left; text-align:left; display:inline-block; margin-top:5px;">
        <form target="_blank" action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top" style="margin-top:15px;">
        <input type="hidden" name="cmd" value="_s-xclick">
        <input type="hidden" name="hosted_button_id" value="CRTHNBD2U8KPW">
        <input type="image" src="https://www.paypalobjects.com/en_GB/i/btn/btn_donate_SM.gif" border="0" name="submit" alt="PayPal – The safer, easier way to pay online.">
        <img alt="" border="0" src="https://www.paypalobjects.com/pl_PL/i/scr/pixel.gif" width="1" height="1">
        </form> 

Share this post


Link to post
Share on other sites

 

mib.php    

 

can you tell what functionality doing this code in your module

 

<form name="selectform1" id="selectform1" action="'.$_SERVER['REQUEST_URI'].'" method="post"><input type="hidden" name="selecttab" value="1"></form>
        <form name="selectform2" id="selectform2" action="'.$_SERVER['REQUEST_URI'].'" method="post"><input type="hidden" name="selecttab" value="2"></form>
        <form name="selectform3" id="selectform3" action="'.$_SERVER['REQUEST_URI'].'" method="post"><input type="hidden" name="selecttab" value="3"></form>
        <form name="selectform4" id="selectform4" action="'.$_SERVER['REQUEST_URI'].'" method="post"><input type="hidden" name="selecttab" value="4"></form>
        '."<div id='cssmenu'>
            <ul>
               <li class='bgver'><a><span>v".$this->version."</span></a></li>
               <li class='".(Configuration::get('mib_lasttab')==1 ? 'active':'')."'><a href='#' onclick=\"selectform1.submit()\"><span>".$this->l('Configuration')."</span></a></li>
               <li style='position:relative; display:inline-block; float:right; width:65px;'><a href='http://mypresta.eu' target='_blank' title='prestashop modules'><img src='../modules/".$this->name."/logo-white.png' alt='prestashop modules' style=\"position:absolute; top:17px; right:16px;\"/></a></li>
               <li style='position:relative; display:inline-block; float:right;'><a href='http://mypresta.eu/contact.html' target='_blank'><span>".$this->l('Support')."</span></a></li>
               <li style='position:relative; display:inline-block; float:right;'><a href='http://mypresta.eu/modules/advertising-and-marketing/rewards-voucher-codes-after-orders.html' target='_blank'><span>".$this->l('Updates')."</span></a></li>
            </ul>
        </div>".'<link href="../modules/'.$this->name.'/css.css" rel="stylesheet" type="text/css" /><iframe src="//apps.facepages.eu/somestuff/whatsgoingon.html" width="100%" height="150" border="0" style="border:none;"></iframe><div style="float:left; text-align:left; display:inline-block; margin-top:5px;">'.$this->l('like us on Facebook').'</br><iframe src="//www.facebook.com/plugins/like.php?href=http%3A%2F%2Ffacebook.com%2Fmypresta&send=false&layout=button_count&width=120&show_faces=true&font=verdana&colorscheme=light&action=like&height=21&appId=276212249177933" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:120px; height:21px; margin-top:10px;" allowtransparency="true"></iframe>
        </div>
        <div style="float:left; text-align:left; display:inline-block; margin-top:5px;">
        <form target="_blank" action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top" style="margin-top:15px;">
        <input type="hidden" name="cmd" value="_s-xclick">
        <input type="hidden" name="hosted_button_id" value="CRTHNBD2U8KPW">
        <input type="image" src="https://www.paypalobjects.com/en_GB/i/btn/btn_donate_SM.gif" border="0" name="submit" alt="PayPal – The safer, easier way to pay online.">
        <img alt="" border="0" src="https://www.paypalobjects.com/pl_PL/i/scr/pixel.gif" width="1" height="1">
        </form> 

 

 

see attached - it's developers' small ad on the module's configuration page, I suppose since we got it for free, it's not a big deal? :)

post-581206-0-25639700-1472769832_thumb.png

Edited by matik4 (see edit history)

Share this post


Link to post
Share on other sites
  • 1 month later...

when you want to display it horizontaly go to ftp ---> modules/mib/mib.css en change 

 

#mypresta_mib ul, #mypresta_mib li, #mypresta_mib a {display:block; width:100%; text-align:center;}

 

to

 

#mypresta_mib ul, #mypresta_mib li, #mypresta_mib a {display:inline; width:100%; text-align:center;}

 

To instal this module on 1.6....

Go to your ftp, ---> theme/your theme/modules and upload the unpacked mib.zip (upload the map, not the zip)

Than go to your backoffice and search for Manufacturers Images Block and install it... (you can not config the module on backoffice)
 

It automate hook this module on the left column. And you can change that on the positions modules page...

Share this post


Link to post
Share on other sites

Hi Vekia,

I installed this module in my presta 1.6.1.7 i set it in displayFooter and do not shows, then i remove caché and delete class_index.php and it now is showing, but then i modify other module and the module disappear again...
Can you help me please?
What is happening?

Thanks!

Share this post


Link to post
Share on other sites

Hi Vekia,

 

I installed this module in my presta 1.6.1.7 i set it in displayFooter and do not shows, then i remove caché and delete class_index.php and it now is showing, but then i modify other module and the module disappear again...

Can you help me please?

What is happening?

 

Thanks!

 

Hi Vekia,

 

I found the error, in Performance > debug mode, i set to NO "Enable/disable non-native modules" and the module now is showing.

 

Can be a bug in prestashop 1.6.1.7?

 

Thanks!

Edited by asilvestre87 (see edit history)

Share this post


Link to post
Share on other sites
  • 2 months later...
  • 2 weeks later...

module at the moment does not have any configuration page.

it just creates a feed of manufacturers

 

Hello! 

Is it possible to display this module in another seperate page? 

I have too many logos and when the module is on main page it takes a long time until all logos are loaded.

Share this post


Link to post
Share on other sites
  • 1 month later...

hello,

 

I show brand logos on frontpage horizontal instead vertical with following code in mib.css:

#mypresta_mib ul, #mypresta_mib li, #mypresta_mib a {display: inline; width:100%; text-align:center; float:none;}

at the moment i have onliy 3 logos to show, and they are shown all on left side from the page.

But i like to show them centered in home page. How can i do that that the logos are shown in the middle of the page, one logo beside the other logo?

 

thank you and greetings

Share this post


Link to post
Share on other sites
  • 2 weeks later...
  • 5 months later...
Hi vekia,

 

I appreciate your work in this community. What is the best option to have a block of images of brands in version 1.7? I've tried several things, including trying to edit the following module: https://github.com/PrestaShop/ps_brandlist

 

Thanks again for the active presence in this new version of Prestashop. Do you recommend to take a look at this module in order to help you migrate to the new version?

 

Thank you,

Alex

Share this post


Link to post
Share on other sites
  • 2 weeks later...
  • 2 months later...
  • 1 month later...
  • 3 weeks later...
  • 4 weeks later...
  • 3 weeks later...
  • 5 weeks later...
  • 4 weeks later...
  • 1 year later...

Hello.

Thank you for your module.

It could be great but I don't can display it on my homepage.
Have you got some idea for solved the problem?

I have 1.6.1.12 version

Thank you !

Share this post


Link to post
Share on other sites
  • 1 month later...
On 7/14/2015 at 1:38 PM, vekia said:

hello

yes it works with 1.6.1

Why it dont work on 1.7.5.2? Installed fine, but when press configure its says what i dont have premisions?

Share this post


Link to post
Share on other sites
  • 8 months later...
  • 1 month later...
On 12/13/2015 at 1:13 AM, Derres said:

Trying it with 1.6.3 and noting is showing in homepage. Zero

I have exactly the same problem. Tried displaying in the footer, on front page - nothing, absolutley nothing is showing. I'm using Presta 1.6.1.24

Can anyone help?

Share this post


Link to post
Share on other sites
  • 6 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More