Jump to content

[Free Module] Maintenance Module


Recommended Posts

Hello Everyone,

 

I want to share my maintenance module. I have checked it with prestashop 1.5 with default theme.

Now It worked with prestashop latest version (1.6)

 

I have update Hours, Minutes and Second with your default shop language.

maintenance.zip

Edited by mdekker
Issues solved. Nice! (see edit history)
  • Like 8

Share this post


Link to post
Share on other sites

hello, cool module, but when we choose the days, is a bit confusing and the calendar below when we select the day does not take over, you can correct some errors?

also leave the translation into Portuguese for those who want to, made ​​in prestashop version 1.6.0.9,

 

lack translate what it says on the page Maintenance,
We're Coming Soon:

days
hours
minutes
Seconds

I have not seen where translate, anyone know?


best regards

pt.php

Edited by Speed2010 (see edit history)

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Hi!

 

Thanks so much! 
 
Would be grateful if you could fix it for Swedish (Svenska)
Days = Dagar 
Hours  = Timmar
Minutes = Minuter
Seconds = Sekunder
 
Equally so to be able to change (We're Coming Soon:) For Optional
 
 
Best Regards
 
MacRoy

Share this post


Link to post
Share on other sites
  • 2 weeks later...
  • 5 months later...

We're coming soon translation is exist in Installed module translation and on Front side.... Days, Minutes, Hours & Seconds will be come according your default language. If you want to change this text then need to edit jquery.simple.dtpicker.js and flipclock.js.

Edited by Ittu (see edit history)

Share this post


Link to post
Share on other sites

We're coming soon translation is exist in Installed module translation and on Front side.... Days, Minutes, Hours & Seconds will be come according your default language. If you want to change this text then need to edit jquery.simple.dtpicker.js and flipclock.js.

Bonjour, Merci pour ce partage , je viens de faire un test en local, quand j'enregistre ma configuration, Est ce normal cette Erreur ? 

Forbidden

You don't have permission to access //************C:/wamp/www/**********/admin*********/index.php on this server. Sinon il fonctionne sur la page maintenance!

 

Edited by Soyons Solidaires (see edit history)

Share this post


Link to post
Share on other sites

Bonjour, Merci pour ce partage , je viens de faire un test en local, quand j'enregistre ma configuration, Est ce normal cette Erreur ? 

Forbidden

You don't have permission to access //************C:/wamp/www/**********/admin*********/index.php on this server. Sinon il fonctionne sur la page maintenance!

 

Are you checking on localhost ?

Share this post


Link to post
Share on other sites

Hello all,

 

Sorry to be a pain in the derriere but it would be great if you could share your questions/answers for the poor Non-French speaking people of the English forum

 

PS. love the module

 

Paul

  • Like 1

Share this post


Link to post
Share on other sites

I have checked on live server and it is working fine without any issue. If you want to check on my server then I will create an environment for you. So let me know that if you want to test this module on my site ?

Share this post


Link to post
Share on other sites
  • 3 weeks later...
  • 1 month later...
  • 4 weeks later...
  • 4 weeks later...

Hi,

I've installed the module on Prestashop 1.6.0.11 single site. The module is implanted correctly in displayMaintenance HOOK but when I set the maintenance mode I continue to see the default page.

Do I need to change other things?

Thanks

Share this post


Link to post
Share on other sites

Tried but still not working

Can you share your site ftp detail on ittuah@gmail.com ? I will check and try to fix it if you needed.

Share this post


Link to post
Share on other sites

Can you share your site ftp detail on ittuah@gmail.com ? I will check and try to fix it if you needed.

Thanks Ittu, I corrected my template. There wasn't the HOOK call. Great module

Share this post


Link to post
Share on other sites
  • 5 months later...
  • 1 month later...

Firstly thanks for the great work! I am quite new to Prestashop so set the right text, imagery in the module but it does not show up on the main site. I had the radio button set to disable on default content, is there an additional step to be done please?

Share this post


Link to post
Share on other sites

Firstly thanks for the great work! I am quite new to Prestashop so set the right text, imagery in the module but it does not show up on the main site. I had the radio button set to disable on default content, is there an additional step to be done please?

Hi,

Please download latest zip of this module so it will be work fine.

Share this post


Link to post
Share on other sites

Issue with module found, please check OP.

Mdekker, I have updated module. Now it is working fine. Please check and remove your comment from main post. If you haven't time to remove then I will remove on tomorrow.

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Hi,

how do I enable this module?

BTW,

I'm new to prestashop

thank you

Hi, You need to install it. After that configure with time and your custom content.

This module will be work when you put your site in maintenance mode.

Share this post


Link to post
Share on other sites
  • 3 weeks later...
  • 4 weeks later...
  • 4 weeks later...
  • 2 years later...
  • 3 months later...
  • 3 months later...
  • 5 months later...
  • 11 months later...
  • 4 weeks later...
On 7/5/2020 at 8:38 AM, Stocks B said:

une version ou un correctif pour 1.7 svp ?

Il marche parfaitement en 1.7.  

Works perfectly with 1.7

Except I have the "We're coming soon" which isn't in the text I typed, and is shown by default, automatically.

The other thing is that I had to edit the maintenance.tpl file to remove my logo, shown in the maintenance page.  

And I don't know if it's a bug, but I couldn't chose the hour, only the day, for the next maintenance.  

By the way, I would love to display a countdown for visitors.

So, yes, you're right, it probably needs a fix for 1.7...

Edited by Ser. (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More