[free] contentBox - html modules - Page 2 - Free Modules & Themes - PrestaShop

Jump to content

Photo

[free] contentBox - html modules

html free js file image upload

#21

Posted 18 September 2014 - 01:26 AM

migcostapt

    PrestaShop Apprentice

  • Members
  • PipPip
  • 40 Active Posts

:o I have heard from some underground communities members (and some unreliable sources) that in fact there are servers haunted by ghosts.. I never expected to meet some one that has such problem  :o 

I have applied some advanced exorcist ninja tactics on the new version of contentBox.. I hope they work on your server O:)  eheh

Now for real :) : for some reason the template system was expecting the name attribute on the custom admin blocks (even if the blocks don't use the name attribute)

Javier could you please test it again and send me some feedback?
Thank you for your patience and for your help on this.
cheers



#22

Posted 22 September 2014 - 04:25 PM

Javier Barcelona

    PrestaShop Enthusiast

  • Members
  • PipPip
  • 449 Active Posts

¡¡¡Works fine!!!

 

No errors in 1.0.3 version... you are a  :ph34r: coder...  :D

 

Thanks (a beer waiting for you in Spain)


Aprende a instalar tu CMS paso a paso | (Beta)

firma-prestashop.png


#23

Posted 24 September 2014 - 01:12 PM

trabajahlf

    PrestaShop Newbie

  • Members
  • Pip
  • 5 Active Posts

I was looking for this for a long time, thanks



#24

Posted 13 October 2014 - 12:30 PM

MastaSplinta

    PrestaShop Newbie

  • Members
  • Pip
  • 3 Active Posts

Hi, can you explain how to set the hook in which you want the content to display? 

Sorry for the newb question 



#25

Posted 17 October 2014 - 11:58 AM

migcostapt

    PrestaShop Apprentice

  • Members
  • PipPip
  • 40 Active Posts

Hi, can you explain how to set the hook in which you want the content to display? 

Sorry for the newb question 

 Hi MastaSplinta, sorry for the delay on the reply.. :/ I have been AFK for a while.
Have you found it? or do you still need help with that?
cheers



#26

Posted 25 October 2014 - 10:12 PM

Artemis909

    PrestaShop Newbie

  • Members
  • Pip
  • 13 Active Posts

Hi, is there some way to show content of contentBox only on *.tpl?

 

This {$content} is working in any *.tpl but only if module is hooked for example in footer.

 

I do not want to hook module anywhere on site but I want to show module content {$content} directly on specific *.tpl file. (custom-contact.tpl)

 

What I have tried is

1) hook module on footer.

2) call its content through {$content} in custom-contact.tpl.

3) hide hooked module on footer by display:none;

 

This is working but it is uncomfortable.


Edited by Artemis909, 25 October 2014 - 10:13 PM.


#27

Posted 26 October 2014 - 01:59 AM

migcostapt

    PrestaShop Apprentice

  • Members
  • PipPip
  • 40 Active Posts

@Artemis909, sorry but I can't understand what you are asking.. are you asking if you can show the module content inside a template file that is not related with the module? If so I really think that you should spend some time reading about how prestashop works.

The correct thing to do should be to create a new custom hook and hook there the contentBox module
http://doc.prestasho.../Managing Hooks

cheers 



#28

Posted 26 October 2014 - 09:10 AM

Artemis909

    PrestaShop Newbie

  • Members
  • Pip
  • 13 Active Posts

Hello,

 

Thank you for answer.

 

So the qustion is how to make new hook for contentBox and use it directly in some-custom.tpl

 

I have successfully done this following this post

 

http://prestatips.in...ook-prestashop/


Edited by Artemis909, 26 October 2014 - 03:43 PM.


#29

Posted 27 October 2014 - 06:22 PM

Guid

    PrestaShop Enthusiast

  • Members
  • PipPip
  • 130 Active Posts

Hi!

 

I downloaded contentbox.org (the generate your module option) last version. But where is the module's #id: (css purposes only) and module's .class: (css purposes only) ?

Those fields appears no more!

 

No #id module appears on DevTools window# (google), like it used to appear on the previous contentbox version, like:

<!-- contentBox module : contentb_7 -->

<div id="contentb7" class="contentb7">

 

 

Thanks for you help!

 

 

PS v. 1.6.0.6



#30

Posted 27 October 2014 - 06:53 PM

migcostapt

    PrestaShop Apprentice

  • Members
  • PipPip
  • 40 Active Posts

But where is the module's #id: (css purposes only) and module's .class: (css purposes only) ?

 


Hi Guid, due to lots and lots of requests, I have decided to remove the div from the main tpl file. By removing this div, contentBox now allows the correct usage of the html5 elements and allows some "more interesting" things with the hooks O:).
Without this div there is no reason for those fields to exist because there is no place for me to add the #id or the .class. Makes sense? :)

you can add a div contentBox's content and tag it with the #id or the .class you want :)
Let me know if you need further help on this.
Cheers
cheers



#31

Posted 27 October 2014 - 08:01 PM

Guid

    PrestaShop Enthusiast

  • Members
  • PipPip
  • 130 Active Posts

Hi Guid, due to lots and lots of requests, I have decided to remove the div from the main tpl file. By removing this div, contentBox now allows the correct usage of the html5 elements and allows some "more interesting" things with the hooks O:).
Without this div there is no reason for those fields to exist because there is no place for me to add the #id or the .class. Makes sense? :)

you can add a div contentBox's content and tag it with the #id or the .class you want :)
Let me know if you need further help on this.
Cheers
cheers

 

Hi, and many thanks for your answer and work.

 

Like i used to change the css on the global css file, now i wonder how to do it...

Should i add an #id to the main tpl file?

How can i change my contentb7 from the global css file?

 

Thanks again for helping.



#32

Posted 27 October 2014 - 10:23 PM

migcostapt

    PrestaShop Apprentice

  • Members
  • PipPip
  • 40 Active Posts

well I decided to add a new feature to contentBox :D
http://screencast.com/t/cVsxMPOamQqS

@Guid you can now add a class and a Id + select the element type from the admin ;)

Please test it and give me some feedback about it :)
cheers



#33

Posted 27 October 2014 - 10:57 PM

Guid

    PrestaShop Enthusiast

  • Members
  • PipPip
  • 130 Active Posts

Hi !

 

Many, many thanks!

I wil for sure!!!



#34

Posted 28 October 2014 - 05:03 PM

Guid

    PrestaShop Enthusiast

  • Members
  • PipPip
  • 130 Active Posts

well I decided to add a new feature to contentBox :D
http://screencast.com/t/cVsxMPOamQqS

@Guid you can now add a class and a Id + select the element type from the admin ;)

Please test it and give me some feedback about it :)
cheers

Hi again!

 

Well i just tried several times the last module version (from contenbox.org), and still a problem, i explain myself:

I download the last v. module. (my ps v. is 1.6.0.6)

Generate module... (name choosen is contentb77)

I install...

Class name choosen is contentb77

ID name choosen is contentb77

 

So far all seems ok... but there is some bug, when i downloaded a second contenbox like:

Generate module... (name choosen is contentb88)

I install...

Class name choosen is contentb88

ID name choosen is contentb88

 

It replaced all previous contentbox names (ID and class) by the last one (ID and class)!!!

 

So i have several contentbox all with the same and last ID and class introduced!!!

 

Thanks for helping with this great module.



#35

Posted 28 October 2014 - 06:50 PM

migcostapt

    PrestaShop Apprentice

  • Members
  • PipPip
  • 40 Active Posts

So far all seems ok... but there is some bug, when i downloaded a second contenbox like:

Generate module... (name choosen is contentb88)

I install...

Class name choosen is contentb88

ID name choosen is contentb88

 

It replaced all previous contentbox names (ID and class) by the last one (ID and class)!!!

 

hey Guid, yep it was a bug.. I was storing all the class's and Id's under the same variable name [cross module].. shame on me.
I have corrected the module generator on the site in order to prevent that from happening :)
you can check it now :)

cheers 


Edited by migcostapt, 28 October 2014 - 08:14 PM.


#36

Posted 28 October 2014 - 07:01 PM

Guid

    PrestaShop Enthusiast

  • Members
  • PipPip
  • 130 Active Posts

Hi migcostapt!

 

Thanks a lot for your quick answer and work, i was really waiting for it!

I gonna apply it right now.



#37

Posted 29 October 2014 - 07:22 PM

Guid

    PrestaShop Enthusiast

  • Members
  • PipPip
  • 130 Active Posts

Hi again migcostapt!

 

There is something strange happening (or maybe i'm just being silly!)

I installed 3 contentboxes (.org last version), their names are contentb77,contentb88 and contentb99 (the only hook is 
"display home"). Those 3 boxes should work inline.
But if i disable or /*comment*/ a contentbox named "contentb1" previously installed (#contentb1 on globla css file, line 8099), the 3 contenboxes stop working inline???
 
(Before to bother you... I tried it on my prestasite1 "local" and on my  http://sitetest.esy.es/ and the same happened.)
 
Please, you can see them on http://sitetest.esy.es/  (the english version).
On my global css file , at the very end i placed this (line 8106):
 
#contentb77 {
    width: 33.33%;
    /*min-width: 250px;*/
    float: left;}
 
#contentb88 {
    width: 33.33%;
    /*min-width: 250px;*/
    float: left;}
 
#contentb99 {
    width: 33.33%;
    /*min-width: 250px;*/
    float: left;}
 
Please if you could get a look on it.
Thanks.


#38

Posted 29 October 2014 - 08:06 PM

migcostapt

    PrestaShop Apprentice

  • Members
  • PipPip
  • 40 Active Posts

 

Hi again migcostapt!

 

you have an error on the line 8041 of global.css :P comment the curly bracket there..
Guid try to use bootstrap :) that is the css framework used on that theme http://getbootstrap.com

Do you have any other questions related with contentBox? :)


Edited by migcostapt, 29 October 2014 - 08:08 PM.


#39

Posted 29 October 2014 - 09:53 PM

Guid

    PrestaShop Enthusiast

  • Members
  • PipPip
  • 130 Active Posts

Hi migcostapt!

 

Oups! Sorry... ya several comments with the curly bracket out of it... 

Turning around.... grrr... Thanks to you now i put it right... it works like it should... let's proceed.

 

****** Your module is really great and now it works fine. **********

 

Good work.

 

I recommend everybody to use it!



#40

Posted 08 December 2014 - 01:47 PM

17dm

    PrestaShop Newbie

  • Members
  • Pip
  • 7 Active Posts

Hi there,

 

total newb question, but..

 

I generated a contentbox, uploaded it via 'add a new module', got a message saying 'module downloaded' but it isn't in my list of modules? Should it be there, or am I looking in the wrong place?

 

(prestashop 1.6.0.6 - if that is relevant)

 

Many thanks,

Wayne





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Cookies help us deliver our services. By using our services, you agree to use our cookies.     Learn more