Jump to content
Sign in to follow this  
Ecom

[Résolu] Passer en production un site installer dans un sous répertoire

Recommended Posts

Bonjour,

J'ai installé Prestashop chez 1and1 dans un sous répertoire de type /monsiteactuel.fr/prestashop.
Aujourd'hui, il n'est pas relié à mon nom de domaine, je dois taper pour y accéder www.monsiteactuel.fr/prestashop/.
Je souhaiterai maintenant accéder directement à prestashop en tapant uniquement www.monsiteactuel.fr
J'ai fait les modifications dans le backOffice de 1and1 (configuration nom de domaine), en allant choisir le répertoire d'install soit /prestashop/ mais je n'ai plus aucun lien qui fonctionne en front office.
Que faut il faire pour que les images et liens restent fonctionnels?
Merci pour votre aide.

Share this post


Link to post
Share on other sites

Il aurait été bon de commencer par une petite recherche. Abordé pas mal de fois.

Share this post


Link to post
Share on other sites

Voici la solution pour ceux qui ne la trouverait pas:
1-Pointer la destination de votre nom de domaine sur le répertoire concerné
2-Modifier dans le setting.inc. php la première ligne define('__PS_BASE_URI__', '/');
Supprimer le /repertoire existant/
Et c'est tout.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More