Jump to content

[RESOLU] champs price manquant dans webmaster tools


Recommended Posts

Bonjour,

j'espère poster au bon endroit (car pour ma part il s'agit de référencement). Si ce n'est pas le cas, merci de déplacer ;)

 

Je tourne avec prestashop 1.6.0.6, thème défault bootstrap, hébergement OVH mutualisé pro.

 

J'ai voulu, dans GG webmaster tools, utiliser la fonction des données structurées. Sur mon ancienne boutique en 1.5 tout allait bien, mais là j'ai un message d'erreur. Sur 388 éléments, il y a 251 éléments contenant une erreur : champs price manquant.

Pourtant dans le récapitulatif des produits, il y a bien un prix dans la colonne price.

 

Quelqu'un pourrait m'expliquer comment fonctionne le balisage shema.org, et si je peux corriger ça ?

 

Merci d'avance.

Edited by Zythom (see edit history)

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Alors début de réponse : j'ai découvert qu'il y avait un forum GG :) et j'y ai posté mon probléme.

Vous pouvez voir ici

 

Si je comprends bien, pour faire un balisage produits, il faut baliser un produit sur la page produit, et non sur une page catégorie qui contient une liste de produits...

Je vais essayer et je vous dirais.

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Bon après vérifications, soit le balisage produit par produit soit le module cité au dessus ont finalement résolu le problème. Plus de message d'erreur sur schema.org...

Zythom,

J'ai que le même problème que toi.

Pourrais-tu détailler la solution que tu appelles "balisage produit par produit", ce n'est pas clair pour moi. Que dois t-on faire au juste?

Merci.

Share this post


Link to post
Share on other sites

Quoi ? Aider un concurrent ? Non mais ça va pas où quoi ?! :D

 

Plaisanterie mise à part...

Mon erreur était que je faisait un balisage sur des pages qui comportaient plusieurs produits (comme les pages catégories), ce qui n'est plus reconnu par GG. Il faut baliser les pages produits (www.domaine.fr/catégorie/produit1, www.domaine.fr/catégorie/produit2, etc...).

En résumé, le balisage ne fonctionnera pas sur les pages qui listent plusieurs produits mais uniquement sur les pages qui ne listent qu'un seul produit.

 

En espérant que tu m'as compris :unsure: (dans le cas contraire, n'hésite pas le MP)

Share this post


Link to post
Share on other sites

  • 1 month later...

Bonjour,

 

Excusez-moi mais je ne comprends pas comment on refait le balisage en pratique.

C'est dans product_list.tpl? Et que doit on changer? 

Merci d'avance de m'aider parce que ça fait une semaine que j'essaie pleins de trucs et ça ne marche pas... 

Share this post


Link to post
Share on other sites

  • 2 months later...

Salut,

 

J'ai eu moi aussi le problème et je l'ai toujours d'ailleur.

Je n'ai pas balisé ma page de catégorie pourtant et c'est la qu'il y a des erreurs

J'ai balisé chaque page de produit comme tu l'as dit plus haut malgré ça j'ai toujours des erreurs sur mes pages de catégories.

Comment supprimer ces messages d'erreurs ?

Quoi ? Aider un concurrent ? Non mais ça va pas où quoi ?! :D

 

Plaisanterie mise à part...

Mon erreur était que je faisait un balisage sur des pages qui comportaient plusieurs produits (comme les pages catégories), ce qui n'est plus reconnu par GG. Il faut baliser les pages produits (www.domaine.fr/catégorie/produit1, www.domaine.fr/catégorie/produit2, etc...).

En résumé, le balisage ne fonctionnera pas sur les pages qui listent plusieurs produits mais uniquement sur les pages qui ne listent qu'un seul produit.

 

En espérant que tu m'as compris :unsure: (dans le cas contraire, n'hésite pas le MP)

Share this post


Link to post
Share on other sites

J'ai balisé chacune de mes pages produit et la dessus il n'y a pas d'erreur

 

Par contre les pages de catégorie qui regroupent mes produits contiennent 1 erreur pour le prix pour chaque produit alors que je ne veux pas les baliser. Je ne sais pas comment retirer ces erreurs

Share this post


Link to post
Share on other sites

  • 8 months later...

Bonjour a tous,

 

Alors j'apporte ma petite contribution pour supprimer les erreurs dans webmaster tools au niveaux des catégories, je viens tout juste de tester, "je reviendrai d'ici quelques jours vous dire si cela a fonctionné"

 

J'utilise le module Gg RICH SNIPPETS, je les simplements dégreffer du "display left column" donc je pense que GG ne cherchera plus les prix manquants dans les catégories ...

Share this post


Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More