Jump to content
sonjasonja

mail templates verdwenen in BO

Recommended Posts

Ik gebruik 1.6.0.7, met theme JewelStore. Zodra ik iets in een mail template in de BO wijzig en het opsla, zijn daarna ALLE email templates verdwenen in de BO. Ik krijg dan bij 'translations' een foutmelding te zien. Voorbeeld:

ik heb de allereerste nederlandse mailtemplate ('Account') gewijzigd door een paar woorden te veranderen. Ik save de template in de BO, en daarna is er geen enkele mailtemplate meer. Bovenaan de pagina 'translations' komt dan onderstaande foutmelding:

 

"Een e-mailfolder bestaat voor de "nl" taal, maar niet voor de standaard taal in /themes/jewelstore/mails/nl/"

 

In ftp staan de templates wel gewoon (bij Jewelstore/mails/nl en bij Jewelstore/mails/en staan alle mails), maar ik kan dan dus vanuit de BO niets meer veranderen omdat ik geen enkele template meer kan zien.

Dit zelfde probleem doet zich voor bij de module email templates, die zijn in de BO ook niet meer zichtbaar (maar wel in ftp) omdat ik daar iets had gewijzigd.

Ik kan nu dus alleen maar vanuit ftp wijzigingen aanbrengen, maar dat is niet de bedoeling, het zou vanuit de BO moeten gaan. Is dit een probleem dat gerelateerd is aan mijn Theme, of aan PS 1.6.0.7?

 

Share this post


Link to post
Share on other sites

ja, die zijn in orde. Maar we gaan 't nogmaals checken (morgen), thanks voor de tip.

we hebben vandaag een upgrade naar 1.6.0.9 gedaan omdat we het vermoeden hebben dat e.e.a. met het theme niet goed gaat (jewelstore theme), er zitten meer 'bugs' in de mails. Helaas is de upgrade helemaal misgegaan, allerlei foutmeldingen bij de 1-click-upgrade waardoor de shop nu helemaal down is. We proberen dat nu te herstellen, maar da's ook nog een heel gedoe, dat zal dus morgen worden. We checken dan nog een keer de schrijfrechten. Mocht je nog andere suggesties hebben, dan houden we ons aanbevolen! We zijn zelf geen professionals op dit vlak, het kost ons eigenlijk in verhouding veel te veel tijd om dit soort details op te lossen (vandaag al meer dan 8 uur bezig geweest met de mails/bugs, en nog geen steek verder, sterker nog, nu helemaal geen site/BO meer). Elke vorm van hulp/advies is meer dan welkom :)

Share this post


Link to post
Share on other sites

Dit heb ik nu ook. Is dit nog bij je opgelost of kan iemand anders mij helpen?

 

Er stond geen enkele mailtemplate meer in en ook de volgende melding:

 

Een e-mailfolder bestaat voor de "nl" taal, maar niet voor de standaard taal in /themes/templatenaam/mails/nl/

Heb ik ze erin gezet en meldingen zijn weg maar ik krijg dus geen mail meer als ik bijvoorbeeld een bestelling geplaatst hebt met bankoverschrijving met de betaalgegevens. Wel een bestelbevestiging.

 

Nu heb ik gekeken bij statussen en daar staan de mailtemplates ook niet meer. Ik kan ze ook niet aanklikken.

 

Edit- Niet meer voor mij van toepassing!

Edited by Peter Pastoor (see edit history)

Share this post


Link to post
Share on other sites

Sorry voor de late reactie. Wij hebben het gelukkig opgelost, het had niets met de schrijfrechten te maken. Wel met het volgende:

 

In het default theme staan mailtemplates, deze staan ook in ons theme Jewelstore. Zodra wij in een mailtemplate (in Jewelstore theme) iets gingen wijzigen, kregen we foutmeldingen zoals uitgelegd. De enige manier waarop we dit konden oplossen, is ervoor zorgen dat in ELKE taal die wij actief hebben en in ELK theme dat onze shop heeft, ervoor te zorgen dat de map met mailtemplates aanwezig is.

Dus: in Default theme moeten bij themes/default/mails alle mailtemplates in het nederlands staan, en ook in het engels. Als dat niet het geval is, dan moet je ze copieren van nederlands naar engels. Vervolgens doe je het zelfde maar dan bij themes/jewelstore/mails (ook NL en EN). Als je dan in je backoffice een mailtemplate gaat aanpassen, dan gaat het helemaal goed.

Wel even opletten bij het copieren van de mails: er is een mapje dat gerelateerd is aan kernmails (bij ons waren dat er 66), en er is een mapje dat aan modules is gerelateerd (bijv. loyalty-module of send-to-a-friend-module). Je moet elk mapje separaat copieren , dus niet alles in 1x.

 

De oplossing is dus niet ingewikkeld, ik snap zelf niet heel veel van ftp maar het is me prima gelukt. Wel secuur werken en checken dat na al het copieren dus in ALLE themes en in ALLE talen die je in je shop gebruikt, alle mailtemplates staan.

Share this post


Link to post
Share on other sites

in sommige gevallen helpt het door gewoon de map mails te verwijderen uit je theme , 

dan wordt de map mails in de root door prestashop gebruikt 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More