Jump to content

Recommended Posts

Buenas a todos.

 

Necesito arreglar este problema , he leído todos los artículos que hay en el foro, en español y ingles, y el problema persiste.

 

Cuando agrego un producto a la cesta y me voy a la caja para confirmar, me aparece  "Su carrito está vacío" una y otra vez.

 

He probado con las 3w , sin las 3w, a borrar cache del pc, a borrar cache del prestashop, todos los rituales que andan por el foro y nada... una vez puntual me funciono y al poco tiempo me dejo de funcionar.

 

Estoy un poco desesperado, hice la migración de la web que tenemos en zencar, y ya las dns y todo apuntan a la web de prestashop, la cual esta en mantenimiento a la espera de arreglar este problema.

 

Tenemos a bastantes clientes esperando y no se que hacer ya para solucionar este problema...

 

Alguien que me eche un cable??

 

Gracias. 

 

Edito --> Para colmo llamo a prestashop para comprar una hora de soporte técnico o que me informen y me llevo 45 min en espera... 

Edited by KriptonitaDesing (see edit history)

Share this post


Link to post
Share on other sites

Como dice Enrique es importante saber que version de Prestashop tienes instalada, pueden ser muchas cosas, tema de cache, cookies, configuracion del .htaccess, algún tema propio del servidor o de su configuracíon .....

 

Tienes en

PREFERENCIAS /  SEO + URLS

Esta opcion asi:

Disable Apache's mod_security module ---> NO

Share this post


Link to post
Share on other sites

 

 

Edito --> Para colmo llamo a prestashop para comprar una hora de soporte técnico o que me informen y me llevo 45 min en espera... 

Consejo. (Aunque siempre hay excepciones, por experiencia, el soporte técnico oficial (el del telefono) estan un poco verdes en la actualidad, mejor preguntas como has hecho por los foros, o contactar con algun desarrollador que veas por el foro (yo no soy) que te pueda ayudar)

 

A lo que te han comentado los compañeros, poco mas que añadir, ya que no se me ocurre nada mas por ahora. 

 

Proporciona la dirección de tu web, como te han comentado para ver..

  • Like 1

Share this post


Link to post
Share on other sites

 

Como dice Enrique es importante saber que version de Prestashop tienes instalada, pueden ser muchas cosas, tema de cache, cookies, configuracion del .htaccess, algún tema propio del servidor o de su configuracíon .....

 

Tienes en

PREFERENCIAS /  SEO + URLS

Esta opcion asi:

Disable Apache's mod_security module ---> NO

Efectivamente eso esta asi.

 

En cuanto daros la url puedo darosla, pero el prestashop esta en modo mantenimiento por lo tanto no podréis entrar, y perdonadme, pero no puedo abrirla, tengo una cartera de unos 30 mil clientes y no puedo permitir que entren con los fallos que ahora genera.

 

La versión de prestashop es la 1.6 , alguna idea mas que mirar?

 

Edito --> Le comentamos a compañeros que miren y les damos acceso, a algunos le aparece y a otros no. 

Edited by KriptonitaDesing (see edit history)

Share this post


Link to post
Share on other sites

Efectivamente eso esta asi.

 

En cuanto daros la url puedo darosla, pero el prestashop esta en modo mantenimiento por lo tanto no podréis entrar, y perdonadme, pero no puedo abrirla, tengo una cartera de unos 30 mil clientes y no puedo permitir que entren con los fallos que ahora genera.

 

La versión de prestashop es la 1.6 , alguna idea mas que mirar?

 

Edito --> Le comentamos a compañeros que miren y les damos acceso, a algunos le aparece y a otros no. 

 Desactiva la opcion que te he dicho, es decir ponlo en SI, genera muchos conflictos en determinados servidores

Share this post


Link to post
Share on other sites

Buenas, supongo que habras hecho la prueba con el reporte de errores activo no? Te tira algun error?

Salu2

Share this post


Link to post
Share on other sites

Yo tengo el mismo problema.

 

PrestaShop™ 1.5.6.1

 

ofivega.com

 

Lo he intentado desde varios ordenadores y siempre pasa, solo desde hace unos días, antes funcionaba perfectamente.

Share this post


Link to post
Share on other sites

¿habéis solucionado el problema?

 

Yo no lo consigo, he cambiado desactivado mod security en apache

 

Y he limpiado el cache con el modulo Flush caches & compiles

 

Pero no cambia nada

 

¿Qué puedo hacer?

 

¿lo ha solucionado KriptonitaDesing ?

 

 

He detectado otro problema, no se añaden productos al carrito, solo admite uno.

 

Creo que el problema comenzó cuando actualicé varios módulos que tenían actualización disponible, pero ahora no recuerdo cuales eran. 

Edited by albertogimeno (see edit history)

Share this post


Link to post
Share on other sites

Revisa con la consola js de Chrome a ver si tienes algún error, revisa tambien el tema de las cookies, si tienes algun modulo relacionado desactivalo y prueba a ver.

Utilizas la plantilla default ¿? si no es asi prueba con ella a ver si te ocurre lo mismo

Share this post


Link to post
Share on other sites
Uncaught TypeError: Cannot set property 'innerHTML' of null ofivega.com/modules/cookieslaw/cookieslaw.js:83

 

 

Esto es lo que aparece cunado abro la consola estando en la siguiente direccion:

 

http://ofivega.com/es/469-toner-compatible-laser-color

 

Si desactivo el modulo de cookies no sale el error en la consola, pero el carrito sigue igual

Edited by albertogimeno (see edit history)

Share this post


Link to post
Share on other sites

Hola a todos veo que esto es de 2014 pero me hoy me está pasando exactamente lo mismo.

El carrito sólo carga 1 producto pero cuando voy a la caja para pagar me muestra el carrito vacío!
 

Alguna ayuda por favor?

  • Like 1

Share this post


Link to post
Share on other sites

Versión de tienda 1.6.1.8
 
Cuando Hago un a compra todo va bien en el primer articulo, pero al momento de hacer "Ir a CAJA" o "Continuar con la Compra" u otro tipo de clic,  CARRITO DE COMPRAS se vacía.

 

Ya vacíe Cookies, y todos los rituales habidos y por haber de post en versiones anteriores

 

SEO + URLs: Configurar URLs / "activar y desactivar" URL Amigables (provando ambas opciones)

SEO + URLs: Configurar URLs / Redirija a la URL canónica / Provando las 3 opciones

  • No hay dirección (bla, bla, bla)
  • 302 Movido temporalmente (bla, bla,)
  • 301 Movido permanentemente (bla, bla)

SEO + URLs: Establecer URL de la tienda / Dominio de la tienda "con www. y sin www. (bcti.mx y www.bcti.mx)

 

 

en verdad esto no me gusta cuando pasan imprevisto que te pueden costar no solo tu trabajo, sino dinero, estaba trabajando con la versión anterior y todo iba muy bien, pero hasta ahora que se actualizó de manera automática, no me había percatado hasta ahora que hacia un prueba, necesito una solución para ya mismo!

Un favor en su solución y explicación hacerlo con palos y manzanas, no soy programador, he aprendido esto solo, en pocas palabras no me sé los términos, a mí me dices en Cpanel y paso a paso, o en el panel de control de prestashop, también paso a paso: (por favor no SUPONGAN que sé) sí he hecho los cambios es porqué he visto muchos vídeos!

 

por cierto!... que horror es mandar un mensaje a PrestaShop!... hay que tener contactos agregados, mis respetos para ustedes que si lo lograron y que ahora me estoy colando por acá para que yo pueda expresarme

Share this post


Link to post
Share on other sites

Hola a todos veo que esto es de 2014 pero me hoy me está pasando exactamente lo mismo.

El carrito sólo carga 1 producto pero cuando voy a la caja para pagar me muestra el carrito vacío!

 

Alguna ayuda por favor?

ME pasa lo mismo... si encuentras la solución me ¿ayudas?... igual si logro encontrar te ayudo!...

 

Por cierto!.. para los de Prestashop!... es un lío poder o hacer saber de un problema en su sistema!... muchas vueltas, muchas ventanas tras ventanas y al final nuevos registros!... que al final te dicen que tienes que identificarte para que termine diciendo que no te reconoce   ("http://forge.prestashop.com/secure/Dashboard.jspa")

Share this post


Link to post
Share on other sites

Yo estoy igual, web inoperativa a 21 diciembre... YUPIII!!!!!!!!!!!! a mi ahora ni entra al carrito, me redirige d enuevo a la pagina principal, algo habre tocado... 

Share this post


Link to post
Share on other sites

Alguien encontró el problema? A mi me migraron la tienda ayer desde Prestashop cloud a Prestashop download 1.6.1.3 y me pasa lo mismo. He hecho todo lo que ponen para solucionarlo y no hay manera. El chico de Prestashop que me ha hecho la migración me confirmó la migración esta mañana y cuando he ido a probarlo y he visto que no funcionaba le he enviado un email enseguida. Desde entonces no me contesta. Antes de la migración iba todo perfectamente. AYUDAAA! Qué estoy desde ayer sin poder tener la página web activa y nos estamos metiendo en el fin de semana. Alguna solución habrá, digo yo.

Gracias.

Share this post


Link to post
Share on other sites

Tento el mismo problema, empezo al migrar mi tienda de prestashop cloud a el hosting con la ultima version al 15/02/2017. Seleccionas un producto y cuando vas pagar te dice que el carro esta vacio, ya prove todos los tips que vi aca y sigo con el mismo problema, si alguien sabe como solucionarlo agradesco la ayuda, saludos

Share this post


Link to post
Share on other sites

Hola al foro.

 

Un cliente se quejo justo hoy que tenía ese problema, mientras a mi en el pc que normalmente lo hago y con Chrome no me daba el error si usaba Mozilla en modo incognito (para estar libre de cookies y demás) me aparecía el error, no me dejaba añadir más de un producto a carrito y con el que añadía si intentaba hacer pedido "carrito vacío", tras probar lo de aquí sin éxito he dado con una solución que me ha funcionado.

 

En su día active en Preferencias/Localización la Geolocalización por IP y descargue el archivo que para ello pide, como no me funcionó para lo que necesitaba el otro día haciendo limpieza del hosting borre el archivo en cuestión pero sin poner la Geolocalización por IP en No. Acabo de hacerlo, he dado a guardar y mano de santo, ya funciona correctamente el carrito, permite añadir, etc....

 

Suerte y muchas ventas  :D

Share this post


Link to post
Share on other sites

Hola al foro.

 

Un cliente se quejo justo hoy que tenía ese problema, mientras a mi en el pc que normalmente lo hago y con Chrome no me daba el error si usaba Mozilla en modo incognito (para estar libre de cookies y demás) me aparecía el error, no me dejaba añadir más de un producto a carrito y con el que añadía si intentaba hacer pedido "carrito vacío", tras probar lo de aquí sin éxito he dado con una solución que me ha funcionado.

 

En su día active en Preferencias/Localización la Geolocalización por IP y descargue el archivo que para ello pide, como no me funcionó para lo que necesitaba el otro día haciendo limpieza del hosting borre el archivo en cuestión pero sin poner la Geolocalización por IP en No. Acabo de hacerlo, he dado a guardar y mano de santo, ya funciona correctamente el carrito, permite añadir, etc....

 

Suerte y muchas ventas  :D

Exacto, con lo caro que está mi tiempo. MUCHAS GRACIAS.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More