Jump to content
BluTiGeS

[MODULE] SALIMITORDER hinweis bei nicht erlaubter Lieferaddresse

Recommended Posts

Hallo zusammen,

 

ich habe ein Modul entwickelt, welches auf der Bestellseite die Lieferadresse gegen die hinterlegte (erlaubten) PLZ je Land vergleicht und falls es nicht übereinstimmt wird ein Dialog angezeigt, dass die Lieferung nicht ausgeführt werden kann.

 

Dies kann z.B. für ein Pizza Lieferdienst verwendet werden der nur Regional liefert.

 

Das Modul ist kostenlos, jedoch über eine Spende würde ich mich natürlich freuen.

 

 

salimitorder_v01.zip

  • Like 2

Share this post


Link to post
Share on other sites

Hallo BluTiGeS,

 

danke fürs Teilen.

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Die Begeisterung hält sich bei mir doch sehr in Grenzen. Man zerschießt sich damit in kurzer Zeit das Frontend.

Nach der Deinstallierung und Cache-Löschung war zwar die Blank Page beim jedem Versuch, einen Artikel in den Korb zu legen, weg. Aber die mir bis dahin unbekannte Fehlermeldung

Impossible to add the product to the cart.
textStatus: 'error'
errorThrown: 'Internal Server Error'
responseText:

verhinderte anschließend jeden Warenkauf.

 

Da dasselbe Fehlverhalten auch bei einer anderen PS-Installation nach Aktivierung bzw. Deinstallation dieses Moduls auftrat, ist der Verursacher für mich eindeutig identifiziert.

 

Ich glaube, das ist noch nicht serienreif. :wacko:

Share this post


Link to post
Share on other sites

Eleazar das Modul ist über ein Jahr alt und wurde nicht weiter gepflegt, aber das was du beschreibt klingt b nicht nach dem Modul, da das Modul nur im template arbeitet und nicht im CART.

Share this post


Link to post
Share on other sites

Ja, ich habe es mir zuvor auch angesehen und nichts Auffälliges entdeckt - aber trotzdem: es gibt einen eindeutigen Zusammenhang mit der Installation dieses Moduls. Wodurch genau, weiß ich auch nicht.

Getestet unter PrestaShop 1.6.1.2RC2 und 1.6.1.2RC4.

 

Ich hatte mich vielleicht etwas missverständlich ausgedrückt: Der Fehler taucht auch im Template auf, nämlich dann, wenn ich den Button In den Warenkorb anklicke.

Edited by eleazar  (see edit history)

Share this post


Link to post
Share on other sites

Eleazar das Modul ist über ein Jahr alt und wurde nicht weiter gepflegt, aber das was du beschreibt klingt b nicht nach dem Modul, da das Modul nur im template arbeitet und nicht im CART.

 

Das einzige das mir jetzt aufgefallen ist, dass es jetzt nicht mehr funktioniert seit paar Tagen, was entweder daran lag:

  • habe das Dev-System auf Produktiv kopiert (hat anfangs noch teils funktioniert, roter Balken ja, Popup nein)

oder

  • Prestashopupdate von 1.6.1 auf 1.6.2

oder

  • ne Kombination aus beiden.

 

Hab reset, deinstallation, reinstallation probiert, erfolglos. Reagiert nicht mehr auf jeglichen Input.

 

Hmmm… vielleicht kann ich dir irgendwie helfen?

 

LG

Edited by thabrad (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More