Jump to content

Modules controller has disappeared?

Recommended Posts

I was trying to add a new item to the BO's left-navigation through Administration --> Menus. Since I could't get what I wanted working, I decided to remove my new entry and go on working.


But all of a sudden, when I click on "Modules", I get the message "controller not found".


I have not fiddled with the existing menu items, I only tried to install a new one. "Modules" still links to "index.php?controller=AdminModules&token-xxx" (as it's supposed to right?)


The file /controllers/admin/AdminModulesController.php is not missing on the server, I tried to empty cache and all, but no luck.....


Please don't tell me if I have to re-install PS....

Link to comment
Share on other sites

The story gets weirder.


After uploading a fresh /controllers/admin/ and a fresh /admin123/ (the BO folder), which both did not help, I figured I'd create a new menu item and set its class to "AdminModules".


That worked! And the "Modules" menu item now works too!


However when I change this new menu item to:


Class: AdminModules

Module: themeconfigurator (or any module you wish)


Not only does this menu item give a "Controller not found", the original "Modules"-menu item also gives this message again.....


What am I doing wrong?


Update: 24/6/2015 (almost a year later!!)


I just did a fresh install of PS 1.6 and this problem is still not fixed....wow!!

Edited by connectcase (see edit history)
Link to comment
Share on other sites

  • Create New...