Jump to content
lex-on

Install Theme "File is too big"

Recommended Posts

i use prestashop 1.6.0.7

 

I purchased a theme and install using the preferences-theme-add theme

 

it occurs "file is too big"

 

Why is that and how to solve it?

Share this post


Link to post
Share on other sites

Easiest solution is to upload it to your themes folder through FTP or similar. 

  • Like 1

Share this post


Link to post
Share on other sites

Hi,

 

I am having the same problem when uploading my theme. 'File is too big'.

 

I've tried via FTP and still no luck. I'm not sure what the problem is as the same theme has worked with no problems since April.

 

Any ideas?

 

Chris

Share this post


Link to post
Share on other sites

I'm having a hard time believing this is still unresolved.  I too have tried uploading via FTP with no result. Version 1.6.0.9

Share this post


Link to post
Share on other sites

increase php environment limitations and then everything will be allright

can you alter php settings with php.ini ?

Share this post


Link to post
Share on other sites

Hello,

Dunno if this is configurable somewhere, but i changed in Uploader.php DEFAULT_MAX_SIZE. Try it. But for me, there was some other error in Uploader.php (file size differs). This import/export thing seems to be buggy..

Regards

Share this post


Link to post
Share on other sites

This question is for Vekia,

 

I just bought the ebay, google, amazon marketplace module. I uploaded my files from my backoffice. I had absolutely no problems with ebay and google.

 

The amazon module I keep getting an error. File too large (limit of 2097152 bytes).

 

I went on filezilla and uploaded it to the modules folder. When I go to modules on my backoffice I do not see it.

 

Please help :)

Share this post


Link to post
Share on other sites

late answer but I'm doing it anyway for anyone who, like me, was looking around for a solution : 

step 1 - change in your php.ini file :

post_max_size = 50M
upload_max_filesize = 50M

(I changed it top 50Mb but you can choose the size you like)

step 2 - edit on the prestashop dashboard :
go to "Administration" and change your Upload Quota (has to be less than what you set on the php.ini file)

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
On 6/26/2014 at 1:51 PM, Mikael K said:

Easiest solution is to upload it to your themes folder through FTP or similar. 

that's work for me too.

prestashop v: 1.7.6.1

local machine (localhost)

steps:

1. Download theme (.zip)

2. Unzip into: /var/www/html/prestashop/theme

3. Go to back office BO and click on: design/theme and logo

4. Add new theme

5. Last option: import from FTP

6. Choose your uploaded theme

7. Go to BO and choose it

Hope it works!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More