Jump to content
Katia93

Install 1.6 s'arrête à "Configuration système" - Pages perso Free

Recommended Posts

Bonjour à toutezéatous,

 

J'essaie d'installer Prestashop 1.6 pour le tester sur mes pages perso de chez Free, mais malgré les divers tests que j'ai pu faire suite aux conseils trouvés dans plusieurs forums, mon installation ne veut pas dépasser l'étape "Configuration système" : j'ai bien 5 smiley sur 6.

 

Voila ce que j'ai fait :

  • J'ai téléchargé le zip sur le site officiel de Prestashop
  • J'ai téléchargé via Filezilla les fichiers sur mon ftp directement à la racine
  • J'ai créé un .htacces directement à la racine pour charger PHP 5 => j'ai écris php 1 (trouvé sur un forum)
  • J'ai créé ma Base de données et pour jouer j'ai créé via phpAdmin un table "test"
  • J'ai modifié quelques fichiers :

=> smarty.config.inc.php

 

La ligne :
$smarty->force_compile = (Configuration::get('PS_SMARTY_FORCE_COMPILE') == _PS_SMARTY_FORCE_COMPILE_) ? true : false;

Mise en commentaire et remplacée par :

$smarty->force_compile = false;

La ligne :

$smarty->compile_check = (Configuration::get('PS_SMARTY_FORCE_COMPILE') >= _PS_SMARTY_CHECK_COMPILE_) ? true : false;

Mise en commentaire et remplacée par :


$smarty->compile_check = false;
=> defines.inc.php
La ligne :
define('_PS_MODE_DEV_', false);

Mise en commentaire et remplacée par :

define('_PS_MODE_DEV_', true);
 

Par ailleurs, j'ai trouvé sur un forum (pour ceux que ça peut intéresser) un fichier pour tester ma connexion MySQL ainsi que ma configuration PHP que j'ai installé directement à la racine de mon site. Le résultat se trouve ici

D'après cette page, ma connexion à MySql est ok avec les paramètres que j'ai renseignés. Ce sont les mêmes que ceux que j'ai mis dans "Configuration système", c'est pour cela que je ne comprends pas pourquoi :
 
1- lorsqu'à ce niveau je demande de Tester ma connexion => il ne me dit pas que c'est ok
2- lorsque je fais "Suivant", j'arrive directement dans ce qui pourrait être l'étape "Installation de la boutique" sans message d'erreur...
Néanmoins, je n'ai vu aucune barre de progression et lorsque je vais dans phpAdmin, aucune table n'a été créée.
Je n'ai pas vu non plus de fichier setting.inc.php
 
En revanche, lorsque je suis à l'étape "Configuration système" et que je clique sur "Suivant", je trouve 7 erreurs dans ma console ;-(
Les erreurs sont les suivantes :
 
  1. Uncaught Error: "onUpdated" can only be used in extension processes. See the content scripts documentation for more details.
  2. extensions/schema_generated_bindings.js:662
     
  1. install.js:25Uncaught ReferenceError: $ is not defined
  1. process.js:26Uncaught ReferenceError: $ is not defined
  1. index.php:231Uncaught ReferenceError: $ is not defined

  1. Uncaught TypeError: Object #<Object> has no method 'sendMessage' chrome-extension://hbdkkfheckcdppiaiabobmennhijkknn/jsr/en_content-pagespeed.js:1
 
Voila, vous savez tout  :blink:
 
SI quelqu'un pouvait me donner un coup de main et me dire où chercher ou quoi faire, je suis preneuse car je commence à ne plus avoir bcp de cheveux à force de me les arracher !!
 
Merci et excellente soirée !

 

Share this post


Link to post
Share on other sites

Bonjour,

 

La meilleur solution est de prendre un vrai hébergeur, on parle de ecommerce, pas d'un cms pour faire une page sur le parka jaune des chat du morbihan.

 

Sinon vous dites avoir un élément bloquant sur la page système, mais sans le nommer donc on ne sait pas.

 

Après vous avez modifier pleins de trucs sans rien comprendre et en appliquant bêtement des topic ou tuto datant de vielles versions de prestashop mais le soucis c'est que tout cela est très périmé.

 

Mais bon je reste persuadé que chercher à installer prestashop sur un hébergeur gratuit est juste aberrant lorsque plusieurs hébergeurs coute moins de 30€ par ans et proposent même le remboursement sous 30 jours ou 1 mois gratuit.

 

Mais bon, quel est donc le truc qui n'est pas conforme sur la page système.

Share this post


Link to post
Share on other sites

Bonjour

 

Comme vous dites sur mes pages perso de chez Free Pages perso les cms ne fonctionne pas sur ces pages Free  a tout compris :)

N'insistez pas vous êtes pas la 1ere personne a vouloir installer sur les pages perso de Free.

 

  1. Uncaught Error: "onUpdated" can only be used in extension processes. See the content scripts documentation for more details.
  2. extensions/schema_generated_bindings.js:662

Cette erreur vous provoque les erreurs suivantes, le système ne peut plus lire la suite donc il déclare tout ce qui est relié en erreur.

Share this post


Link to post
Share on other sites

@mediacom87 : merci pour cette réponse qui m'a beaucoup aidée et que j'ai appréciée tant sur sa forme que sur son fond... Je suis peut-être "idiote" de vouloir installer Prestashop dans un objectif d'évaluation sur un hébergeur qui n'est pas un "vrai" hébergeur, mais c'est mon droit de vouloir essayer puisque rien ne dit que c'est impossible et que d'autres l'on apparemment fait avec succès (peut-être avec une version antérieure de Prestashop mais bon).

Votre réponse est d'autant plus pertinente que vous n'avez même pas pris la peine de lire mon message puisque je dis EXACTEMENT où se situe le pb et non sur la page système comme vous le suggérez.
 
@oron : merci pour votre réponse ultra rapide et précise.
Je vais définitivement laisser tomber les pages perso de free. C'était un 1er essai, vraiment pas concluant  :(
 
Bonne journée !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More