Jump to content
Johnny32

[gelöst] Bildformat nicht anerkannt, erlaubte Formate: GIF, JPG, PNG"

Recommended Posts

Hallo Forum,


 


ich brauche unbedingt Hilfe mit dem folgenden Problem:


 


Seit einigen Tagen bekomme ich eine Fehlermeldung  "Bildformat nicht anerkannt, erlaubte Formate: GIF, JPG, PNG" wenn ich versuche ein Image hochzuladen.


Habe alle drei Image varianten versucht und auch Images versucht hochzuladen die vorher 100% funktioniert haben.


Das komische ist, dass sich Bilder noch bei Produkten hochladen lassen aber nicht bei Kategorien, Hersteller oder slide show etc.


Ich habe kein source code verändert oder irgendwas mit einer PHP Datei gemacht.


PrestaShop-Version: 1.5.6.2 


Das einzige was mir aufgefallen ist, dass im Folder "img/tmp/" eine neue Datei entsteht wenn ich versuche ein Bild hochzuladen obwohl die Fehlermeldung kommt. Ein Beispiel einer Datei war "PSfLaGML" Wenn ich die Datei auf dem Rechner runterlade und die Endung jpg dazu füge ist es das Image was ich versucht habe zu laden.


Wäre für jegliche Hilfe dankbar.


 


Johnny


Share this post


Link to post
Share on other sites

Hallo Jonny,

 

so wie du es beschreibst werden die Bilder zwar auf den Servergeladen, können dann aber nicht umgerechnet werden.

 

Wie gross sind die Bilder, versuche testweise zunächst mal ein ganz winziges Bild (so 10 kb) hochzuladen. Was passiert?

 

Prüfe noch die Ordner-Rechte von:

/img/m

/img/c

 

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Hallo Jonny,

 

so wie du es beschreibst werden die Bilder zwar auf den Servergeladen, können dann aber nicht umgerechnet werden.

 

Wie gross sind die Bilder, versuche testweise zunächst mal ein ganz winziges Bild (so 10 kb) hochzuladen. Was passiert?

 

Prüfe noch die Ordner-Rechte von:

/img/m

/img/c

 

 

Grüsse

Whiley

Danke für die Antwort. 14kb Images gehen nicht.

 

Ich weiß leider nicht wie ich die Ordner Rechte prüfen kann.

 

Grüsse

 

Johnny

Share this post


Link to post
Share on other sites

Wie kommst du denn auf deinen Server?

Falls über FTP FileZilla,  klickst du die o.a. Ordner mit der rechten Maustaste an und gehst auf Dateiberechtigungen.

 

Falls du über cpanel auf den Server gehst: Filemanager suchen, Pfad /img anklicken, dann werden in der äusserst rechten Spalte die Rechte angezeigt.

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Wie kommst du denn auf deinen Server?

Falls über FTP FileZilla,  klickst du die o.a. Ordner mit der rechten Maustaste an und gehst auf Dateiberechtigungen.

 

Falls du über cpanel auf den Server gehst: Filemanager suchen, Pfad /img anklicken, dann werden in der äusserst rechten Spalte die Rechte angezeigt.

 

Grüsse

Whiley

Leider habe ich nur die Web FTP, da kann man nichts ändern.

 

Würde aber nicht verstehen wie über Nacht die Ordner auf einmal schreibgeschützt sind.

 

Was für eine Datei ist denn verantwortlich für die umrechnung?

Share this post


Link to post
Share on other sites

 

Leider habe ich nur die Web FTP, da kann man nichts ändern.

Filezilla ist kostenlos, du bekommst es hier:

http://www.filezilla.de/download.htm

 

 

Was für eine Datei ist denn verantwortlich für die umrechnung?

U.a. die /classes/ImageManager.php

 

 

Grüsse

Whiley

Edited by Whiley (see edit history)
  • Like 2

Share this post


Link to post
Share on other sites

Filezilla ist kostenlos, du bekommst es hier:

http://www.filezilla.de/download.htm

 

U.a. die /classes/ImageManager.php

 

 

Grüsse

Whiley

Also,

 

habe jetzt mal nach den Berechtigungen geschaut, da ist alles ok. Hacken überall und auf 755.

 

Gibt es eine andere Möglichkeit Bilder hochzuladen?

Share this post


Link to post
Share on other sites

Gleiches Problem hier, der Shop läuft insgesamt schon seit 3 Jahren, die 1.5.6.1 seit weiß nicht genau, aber auch schon eine Zeit.

Es wurde nichts umgestellt, die Schreibrechte passen.

 

Serverinfo laut phpinfo:

max_execution_time 1000 1000

max_file_uploads 20 20

max_input_nesting_level 64 64

max_input_time 1000 1000

max_input_vars 10000 10000

memory_limit 2048M 2048M

 

Trotzdem taucht der Fehler immer wieder auf.

Edited by vecxel (see edit history)

Share this post


Link to post
Share on other sites

Hallo vecxel,

 

sorry, ich hatte vergessen diesen thread als gelöst zu markieren. Wir hatten das Problem "direkt" gelöst.

Grundsätzlich ist es so, das die Fehlermeldung "Bildformat nicht anerkannt, erlaubte Formate: GIF, JPG, PNG" nicht nur bei falschem Bildformat, sondern auch bei anderen Warnungen und Fehlern angezeigt wird.

Wenn du mir - per PN - FTP-Zugangsdaten und Shop-Admin-Zugangsdaten schickst schau ich mir die Sache kurz an.

 

Grüsse

Whiley

  • Like 1

Share this post


Link to post
Share on other sites

Guten Morgen,

 

darf ich mich noch an die Diskussion dranhängen ?

 

Habe gestern eine neue Shopinstallation vorgenommen, alle Modulupdates installiert (noch keine
speziellen Änderungen vorgenommen) und wollte gerade einen Artikel testweise anlegen - gleiches
Problem wie Jonny32 u.a.

 

Egal welches Bild ich hochladen will: "xx.jpg : Bildformat nicht anerkannt, erlaubte Formate: GIF, JPG, PNG"

 

Hat Whiley inwischen eine Lösung des Problems gefunden ??

 

Grüsse

JM

 

 

GELÖST - hatte die angepasste php.ini nicht ins Verzeichnis kopiert ! 

Edited by Jmoehnen (see edit history)

Share this post


Link to post
Share on other sites

Hallo Leute,

ich habe den gleichen Fehler. Wie lautet denn die Lösung zur Behebung des Problems?

@Jmoehnen: welche "angepasste php.ini" hast du in das Verzeichnis kopiert?

 

danke

rope

 

PS version: 1.5.3.1

Share this post


Link to post
Share on other sites

1. eine Datei (z.B. mit dem Editor) names php.ini erstellen

2. Inhalt (Höchstwerte bei STRATO):

 

max_input_vars = "4000"
max_execution_time = "120"

 

3. diese Datei in das Prestshopverzeichnis kopieren.

 

 

Es gibt auch andere Möglichkeiten, diese und andere Werte zu beeinflussen (s. auch: Mindestwerte

zum Betreiben deines Shops) , STRATO z.B. lässt aber bei den billig-Domains sonst keine andere Möglichkeit zu ...

 

Habe auch mal festgestellt, dass die mit phpinfo (s. Anlage) ermittelten Werte nicht immer den

Werten entsprach, die im Shop angezeigt wurden. Die Datei phpinfo.php mal bitte auf die Webseite hochladen und im Browser mit http://www<domain>.de/phpinfo starten.

 

Versuchs bitte mal und gib mir Bescheid !

 

PS:

-  Bei welchem Provider ist die Domain  ? 

 

phpinfo.php

Share this post


Link to post
Share on other sites

Hi Jmoehnen,

danke für deine schnelle Antwort. Ich habe beides gemacht, aber leider kommt beim Versuch Bilder im Slidermodul hochzuladen immernoch der gleiche Fehler.

Die Domain und der Webspace sind bei Strato gehostet.

 

ich habe dir eine PN mit dem Link zum Shop geschickt.

 

vG

Share this post


Link to post
Share on other sites

Herlichen Glückwunsch im Kreise der STRATO-Behinderten ! Solche Rüffel fange ich mir bei jeder Frage hier im Forum. Warum STRATO ??? Alle 5 Shops kann ich nicht mit dem 1Klick-Upgrade-Modul auf eine höhere Version bringen - keine Chance !

 

Aber nun zuürck zum Problem:

 

Wie zu ersehen: unsere Werte sind identisch - damit funktioniert es bei mir mehr schlecht als recht .. 

Der einzige Unterschied: ich habe bei einem Shop z..B. PHP-Version 5.5 eingestellt, bei Dir ist es die Version 5.3.

In der Strato-Verwaltung (Verwaltung -> Websitekonfigurator -> PHP-Version einstellen) mal bitte auf PHP umstellen, PHP-Boost ist bei diesem Shop ebenfalls aktiviert.

 

Hier die von STRATO zugesagten PHP-Werte:

 

PHP 5.5.x – config Parameter Wert Bedeutung display_errors Off Zeigt Scriptfehler im Browser an. file_uploads On Ermöglicht das Hochladen von Dateien max_execution_time 60 Sekunden CPU Zeit, bzw. 120 Sekunden abs. Laufzeit Setzt die Maximaldauer für die
Ausführung eines Scriptes memory_limit

128 MB

Beschränkt den maximalen Speicherverbrauch
eines Scripts auf 128 MB post_max_size 48 MB Beschränkt die Menge an Daten, die maximal von PHP über POST akzeptiert wird auf 48 MB. register_globals Off Ermöglicht den Zugriff auf POST & GET Daten über Arrays. safe_mode Off Schaltet den Safemode von PHP aus upload_max_filesize 32 MB Setzt die maximale Grösse von
Dateiuploads auf 32MB. session.gc_maxlifetime 1440 Setzt den Timeout einer PHP-Session
auf 1440 Sekunden session.cache_expire 180 Limitiert die Gültigkeit des
session caches auf 3 Stunden

 

 

 

Dokument2.pdf

Share this post


Link to post
Share on other sites

Danke nochmal für die Hilfe!

hatte bereits eine Lösung gefunden, die mein Problem aus der Welt geschaffen hat.

 

Bezüglich Strato und des nicht funktionierendes 1-click-updates kann ich nur mit meckern!

 

vG

Share this post


Link to post
Share on other sites

War das wirklich der Tip mit dem image-PHP ? Da schrieb doch jemand anschließend, dass dadurch ein anderer

Fehler produziert gäbe ??? 

 

 

 

 

Share this post


Link to post
Share on other sites

Ja, bin noch am tüfteln, wie in Update in unserem Falle überhaupt durchzuführen ist. Komplett lokal  (XAMPP ...).
Schon mal Erfahrung gemacht ?

Share this post


Link to post
Share on other sites

Also der andere Fehler kommt bei mir nicht. Ich schätze das ist Versions- und Kofigurationsabhängig. Ich habe die ImageMaster.php bei mir getauscht und auf den ersten Blick läuft alles gut. Ich bin gerade noch am schauen, was genau in der Datei modifiziert wurde.

 

Mit dem Update habe ich noch keine Erfahrung, habe das Thema vor mir her geschoben :(
Ich schätze, die einzige Möglichkiet besteht darin, den kompletten Shop zu sichern (Backup), über das Konfigurationsmenü bei Strato eine neuere Version installieren (sofern verfügbar) und das Backup wieder einspielen.

Auch die Installation konnte ich nur über das Strato Kofigurations WebIF machen, eine Installation direkt auf dem Space funktioniert nicht - das finde ich echt zum ko**en.

 

vG

Share this post


Link to post
Share on other sites

-> Erst-Installation:

-  immer nur ohne Probleme via FTP und dann die installation & Konfiguration auf dem Server. Dauert eine kleine Ewigkeit,

hat aber bisher immer mehr schlecht als recht funktioniert.

- STRATO-Installation: wahrscheinlich schneller als herkömmlich, dafür stellen die aber i.d.R. immer eine ältere Version

der Shopsoftware zur Verfügung - bei Problemen wird dann im Forum gerüffelt: keine aktuele Version installiert !

 

-> andere Update-Lösung:

- komplett lokal: XAMPP installieren, alles vom Server lokal laden, Upgrade machen, alles wieder auf den Server hochladen

- "halb & halb" - neuen Shop lokal laden, alle relevanten Datein vom Server laden und lokal in den neuen Shop kopieren,

alles wieder auf den Server in ein neues Verzeichnis kopieren und dort ein Update starten (keine Neuinstallation)

 

Wie gesagt: wir müssen da für STRATO einen funktionierenen Weg finden, mit den Shopversionen halbwegs aktuell zu bleiben

(aktuell 1..6.9. !)

 

mfg

JoMö

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More