Jump to content

[résolu] Colonne de gauche et Footer disparus !


Recommended Posts

Bonjour,

 

Cela fait 2 ans que mon site fonctionne sans problème, je suis sur Prestashop 1.4.9 avec un thème acheté sur la boutique Prestashop addon.

 

Il y a quelques jours je vais sur mon site et je m'aperçoit que l'emplacement de la colonne de droite est vide (plus de modules) et que mon footer a complètement  disparu !

 

Ce souci est apparu soudainement, à moins que je ne me suis pas aperçu sur le moment (je ne peux donc dire qu'elle est vraiment la cause).

 

En passant en mode debug. Tout en bas de la page j'ai ces erreurs :

 

Fatal error: Uncaught exception 'SmartyCompilerException' with message 'Syntax Error in template "/footer.tpl" on line 47 "{literal}" missing or misspelled literal closing tag' in /www/tools/smarty/sysplugins/smarty_internal_templatecompilerbase.php:656 Stack trace: #0 /www/tools/smarty/sysplugins/smarty_internal_templatelexer.php(994): Smarty_Internal_TemplateCompilerBase->trigger_template_error('missing or miss...') #1 /www/tools/smarty/sysplugins/smarty_internal_templatelexer.php(916): Smarty_Internal_Templatelexer->yy_r3_7(Array) #2 www/tools/smarty/sysplugins/smarty_internal_templatelexer.php(99): Smarty_Internal_Templatelexer->yylex3() #3

/www/tools/smarty/sysplugins/smarty_internal_smartytemplatecompiler.php(100): Smarty_Internal_Templatelexer->yylex() #4 www/tools/smarty/sysplugins/smarty_internal_templatecompilerbase.php(192): Smarty_Internal_SmartyTemplateCompiler->doCompile('{*?* 2007-2011 ...') #5

/www/ in www/tools/smarty/sysplugins/smarty_internal_templatecompilerbase.php on line 656

 

Je ne sais pas si cela a un rapport avec la disparition de mon footer et de ma colonne mais cela me pose beaucoup de problème, car ma boutique est en ligne avec des clients.

 

Merci beaucoup pour votre aide !

Laurent

 

 

Edited by eightmann (see edit history)

Share this post


Link to post
Share on other sites

Ma dernière sauvegarde est assez vielle, elle datte d'un an et j'ai une erreur dans la base de donnée SQL lors de l'importation  ;). De ce que j'ai vu, il peut sagir d'un problème avec une application installée ou désinstallée, mais j'ai cherché et essayé un peu tout ce qu'il y avais, mais rien en marche.

 

Ce qui est bizarre c'est que je n'ai pas trouvé énormément de personnes avec ce problème, en général c'est soit la colonne soit le footer, mais dans mon cas c'est les deux ..

Share this post


Link to post
Share on other sites

Bonjour

 

Merci de poster sur le bon forum en l'occurrence Difficultés, pannes ou erreurs rencontrées.

topic déplacé.

 

Quel est la dernière modifications que vous avez fait dans le back office niveau module ou niveau performance ?

Share this post


Link to post
Share on other sites

Bonne nouvelle ! J'ai réussi à trouver le problème.

 

Pour ceux qui ont un problème similaire:

 

En faite il y a quelques jours j'ai supprimé les applications inutilisées. En vérifiant le message d'erreur (activation du mode debug de Prestashop) j'ai remarque que le problème venait du fichier footer.tpl, je ne sais pas pourquoi mais à la fin du fichier j'avais le code de l'application Zopin, j'ai donc supprimé le "paragraphe" entier de l'application et le footer ainsi que ma colonne sont réapparus !

 

Merci  pour votre soutien  :)

Share this post


Link to post
Share on other sites

Salut ! 

 

Contente que tu aies trouvé l'origine du problème. Pourrais-tu marquer ton topic comme "résolu" stp ? (Retour sur ton post d'origine > Edit > Editeur complet > Rajoute "résolu"dans le titre).

 

Merci  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More