Jump to content

15ème install (v1.2.5) sans succès sur infomaniak ..


Recommended Posts

Bonjour,
J'ai déjà testé et installé PS sur différents hébergeurs. Mais là, chez infomaniak, je sèche (depuis ce matin, c'est un peu long ..) ; j'ai suivi les différents conseils trouvés ici, j'ai lu et suivi le topic http://www.prestashop.com/forums/viewthread/7622
pour avoir "tout au vert" (notamment rewrite rules et register globals), mais je n'ai pas eu la même chance que son auteur quant au résultat (je penche encore pour un probleme de chmod). Tout est vert mais je suis gelé à l'étape 4, comme si l'install n'écrivait plus rien. Pourtant, si je saute l'étape, change l'admin et supprime le dossier install, le boutique de démo est là, mais impossible d'accéder au BO. Comprends plus, mais plus rien du tout. Autre chose qui à peut être son importance, je n'ai PAS TROUVER MON HTACCESS d'origine (celui en .txt) en dézippant PS .. Je l'avais pourtant dans les versions précédentes, et c'est celui-ci que j'ai dû reprendre et donc modifier pour infomaniak. Dernière chose, j'ai revérifier les droits (777) sur le tuto d'origine. Y a t-il des dossiers ou fichiers nouveauxpour la versions 1.2.5 dont les droits sont à modifier ?J'utilise Cyberduck (OS X), et j'ai bien demander "appliquer réccurentes" pour dossier et sous-dossier.
Voilà voilà. Âmes chartitables bienvenues, même si, un samedi soir, beaucoup ont autre chose au programme ... Merci -

Ci dessous mon htaccess
# URL rewriting module activation
RewriteEngine on

# URL rewriting rules
RewriteRule ^([a-zA-Z0-9-]*)/([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ product.php?id_product=$2$4 [L,E]
RewriteRule ^([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ product.php?id_product=$1$3 [L,E]
RewriteRule ^([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ category.php?id_category=$1 [QSA,L,E]
RewriteRule ^content/([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ cms.php?id_cms=$1 [QSA,L,E]
RewriteRule ^([0-9]+)__([a-zA-Z0-9-]*)(.*)$ supplier.php?id_supplier=$1$3 [QSA,L,E]
RewriteRule ^([0-9]+)_([a-zA-Z0-9-]*)(.*)$ manufacturer.php?id_manufacturer=$1$3 [QSA,L,E]

# Catch 404 errors
ErrorDocument 404 /404.php

php_flag allow_url_fopen On
php_flag allow_url_include On
php_flag register_globals Off

Share this post


Link to post
Share on other sites

Salut,

Je suis chez Infomaniak et j'ai installé ma boutique. De d'abord j'ai eu le même problème, je me suis retrouvée bloquée pendant l'installation. J'ai donc tout viré les dossiers de mon FTP et j'ai été supprimer ma base de donnée directement chez Infomaniak pour tout reprendre dès le début et tout a bien fonctionné.

Pour les permissions de dossier voilà ceux que j'ai mis en CHMOD 777 :

Permission aux dossiers seulement :

/config, /upload, /download, /tools/smarty/compile

Permission aux dossiers et sous-dossiers :

/img, /mails, /modules, /themes/prestashop/lang, /translations

Egalement au fichier sitemap.xml

Pour ton fichier htaccess il se trouve à l'arborescence de ton site, il faut lui ajouter ces ligne :

php_flag allow_url_fopen On
php_flag allow_url_include On
php_flag register_globals Off



Pour sauvegarder la base de donnée bien mettre permission fichier 777 sur admin/bakup

N'oublie pas chez Infomaniak il y a également une modification à faire au niveau des mails. Pour faire fonctionner les mails avec la fonction mail() (et non SMTP), voici ce qu'il convient de faire :

Trouver :

tools/swift/Swift/Connection/NativeMail.php: public function __construct($additional_params=”-oi -f %s”)
tools/swift/Swift/Plugin/MailSend.php: public function __construct($params=”-oi -f %s”)

Remplacer par :

tools/swift/Swift/Connection/NativeMail.php: public function __construct($additional_params=”-oi”)
tools/swift/Swift/Plugin/MailSend.php: public function __construct($params=”-oi”)

Pour être plus précise, dans le fichier tools/swift/Swift/Connection/NativeMail.php, il faut remplacer la ligne

public function __construct($additional_params=”-oi -f %s”)

par

public function __construct($additional_params=”-oi”)

et idem pour l’autre fichier.

J'espère que tu arriveras maintenant à installer ta boutique.

Share this post


Link to post
Share on other sites

Merci pour ta réponse. J'ai été "obligé" de basculer temporairement vers un autre hébergeur, car tout le monde n'a pas daigné répondre comme toi à ma requête( en même temps, un w.e ... je ne m'atendais pas à 50 réponses ;-)), et il fallait bien que j'avance. En réalité, je teste actuellement 3 prestataires, et envisage par la suite de sous-traiter une ou plusieurs parties techniques de cette mise en place (herbergement+installation TPE). Je garde néanmoins précieusement tes infos de coté, car je souhaite revenir chez infomaniak dès que j'ai le temps de recommencer l'install (cet herbergeur est bien noté dans l'ensemble) et j'ai conscience que les soucis rencontrés viennent de moi ... Ca me fera d'ailleurs un bon exercice supplémentaire de migration ... Je suis actuellement sur la préparation des fichiers csv à importer, je regarde ce qui a changé depuis 1 an (je cherche une "matrice propre" avec catégories, produits, descriptifs et urls images...) Encore merci pour ton aide.

Share this post


Link to post
Share on other sites
  • 4 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More