Jump to content
Sign in to follow this  
pasta.pesto

Truc bizarre sur les frais de port [Résolu]

Recommended Posts

Bonjour,

j'ai un truc bizarre qui se passe sur les frais de ports je m'explique, je vendrais en France / Suisse belgique, j'ai donc créé 2 transporteurs :
- La poste lettre max pour la France (transporteur par defaut) : 1 article = 2.47€
- La poste export 3J pour suisse belgique = 1 article = 4.70€

si je me loggue avec un compte en France je met un article dans le panier : Frais de port ok : 2.47€
si je change l'adresse de mon compte et me met en belgique/suisse, je met un article dans le panier : 4.20€ ???

Ensuite si je clique sur commander j'arrive a la page transporteur et là c'est ok il me met bien 4.70€ ??? je comprends pas pourquoi le panier bug soit il me met tout le temps 2.47€ soit il me met le bon montant mais d'ou il sort ces 4€20 ?

Toutes les taxes sont désactivés

Si quelqu'un a une idée :)

Edit : si j'inverse et que je met Export 3J par défaut ça fonctionne pour la suisse & la Belgique mais pour la France ça reste à 0 ...

merci !

Share this post


Link to post
Share on other sites

Bon alors j'ai continué de chercher et là j'ai été faire un tour dans la base de donnée pour trouver ces fameux 4.20€ .... et je les ai trouvé au milieux de tous ce que j'avais créé en frais de port depuis le début !! un vrai foutoir, plus de 200 enregistrements différents pareils pour tous les transporteurs créé depuis le début ....

Donc j'ai tout vidé pour repartir à zéro niveau transport, donc voilà ou j'en suis :
Le transporteur qui gère la France est par défaut et si jamais je suis loggué avec un compte en Belgique ou Suisse le panier reste à zéro en frais de port ... c'est le comportement normal ou pas ?

Share this post


Link to post
Share on other sites

c'est normal tout ça (toutes ces lignes) : lorsque tu modifies un transporteur, ça le recréé. ça évite ainsi - en production - que lorsque tu modifies un tarif, ça ne foute le bordel dans tes enregistrements précédents.

c'est un peu couillon, je l'avoue, mais nécessaire.

j'espère pour toi que tu n'es pas en production. parce que sinon, si tu as changé de tarif de transport entre-temps, tes factures ne vont plus coller !

Share this post


Link to post
Share on other sites

Haaa ok je comprends mieux effectivement j'avais pas pensé à ça :) non effectivement je ne suis pas en production toujours en phase de test donc pas de problème ;)

Merci pour l'explication !

Bon par contre la réaction des frais de ports est très bizarre, j'ai essayé de faire la même manip chez un collègue qui a aussi une boutique en test et ça réagit pareils loggué avec un compte en suisse : Frais de port 0 dans le panier donc je suppose que c'est le comportement normal mais bon c'est trompeur pour le client je trouve

Et puis surtout pourquoi est ce qu'il allait piocher un frais de port deleter depuis un bout de temps (enfin avant que je le supprime ...)

Share this post


Link to post
Share on other sites

oui : 0 tant que t'es pas identifié, ça peut être normal. moi - je me répète - j'ai viré les infos de coûts dans le panier si pas identifié.

s'il est allé chercher des frais de port pas conformes, c'est que t'avais du faire une connerie quelque part. chez moi ça marche nickel. mais il est vrai que la gestion des transports et frais de port c'est un peu tortueux.

(et RESOLU dans le sujet stp)

Share this post


Link to post
Share on other sites

Ba non justement je suis identifié, en suisse ou belgique ça reste a 0 si je suis identifié en france ça marche ... c'est le comportement normal ?

Share this post


Link to post
Share on other sites

non. c'est que t'as un truc qui ne colle pas dans tes paramètres. vérifies. :-)

Share this post


Link to post
Share on other sites

Ben je suis vraiment reparti à 0 et puis ça fait pareils chez un collègue donc j'ai pas l'impression que ce soit un truc paramétré ... au final je crois que je vais virer la ligne Frais de port comme tu as fait c'est mieux je pense !!

Merci pour les infos en tout cas ça m'a permit de mieux comprendre comment presta fonctionnait ;)

Share this post


Link to post
Share on other sites

Allez un petit détails en plus, en fait les frais de port pour les pays qui ne sont pas gérer par "lettre max" (suisse belgique) sont très bien pris en compte à partir du moment ou je vais une fois dans "commander" jusqu'à l'étape "transporteur" je ressort et là tout fonctionne parfaitement ! mais si je vide mon panier pouf tout reste à 0 ...

En fait c'est exactement le problème de cette personne donc je vais continuer sur son post ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More