Jump to content

Blok kategorii PS 1.4 - błąd - wyświetla /**/


Recommended Posts

Słuchajcie mam pewien problem, otóż wczoraj (nie zmieniając nic) blok kategorii zamiast kategorii zaczął wyświetlać /**/ i powiem szczerze nie mam pojęcia co z tym zrobić...

 

Próbowałem odinstalować i zainstalować moduł ponownie, ale nie pomogło, wyłączyłem block layered navigation i też nie pomogło... jakieś sugestie?

 

można zobaczyć tutaj: www.edge.shop.pl/lyzwy - po lewej stronie przy dole...

 

Blok kategorii PS 1.4 - błąd - wyświetla /**/

Share this post


Link to post
Share on other sites

Witam,

 

Dzięki za szybki odzew.

 

poniżej bloccategories.tpl

 

{*

* 2007-2011 PrestaShop 
*
* NOTICE OF LICENSE
*
* This source file is subject to the Academic Free License (AFL 3.0)
* that is bundled with this package in the file LICENSE.txt.
* It is also available through the world-wide-web at this URL:
* If you did not receive a copy of the license and are unable to
* obtain it through the world-wide-web, please send an email
* to [email protected] so we can send you a copy immediately.
*
* DISCLAIMER
*
* Do not edit or add to this file if you wish to upgrade PrestaShop to newer
* versions in the future. If you wish to customize PrestaShop for your
* needs please refer to http://www.prestashop.com for more information.
*
*  @author PrestaShop SA <[email protected]>
*  @copyright  2007-2011 PrestaShop SA
*  @version  Release: $Revision: 6718 $
*  @license    http://opensource.org/licenses/afl-3.0.php  Academic Free License (AFL 3.0)
*  International Registered Trademark & Property of PrestaShop SA
*}
 
<!-- Block categories module -->
<div id="categories_block_left" class="block">
<h4>{l s='Categories' mod='blockcategories'}</h4>
<div class="block_content">
<ul class="tree {if $isDhtml}dhtml{/if}">
{foreach from=$blockCategTree.children item=child name=blockCategTree}
{if $smarty.foreach.blockCategTree.last}
{include file="$branche_tpl_path" node=$child last='true'}
{else}
{include file="$branche_tpl_path" node=$child}
{/if}
{/foreach}
</ul>
{* Javascript moved here to fix bug #PSCFI-151 *}
<script type="text/javascript">
// <![CDATA[
// we hide the tree only if JavaScript is activated
$('div#categories_block_left ul.dhtml').hide();
// ]]>
</script>
</div>
</div>
<!-- /Block categories module -->
 
category-tree-branch.tpl
 
{*
* 2007-2011 PrestaShop 
*
* NOTICE OF LICENSE
*
* This source file is subject to the Academic Free License (AFL 3.0)
* that is bundled with this package in the file LICENSE.txt.
* It is also available through the world-wide-web at this URL:
* If you did not receive a copy of the license and are unable to
* obtain it through the world-wide-web, please send an email
* to [email protected] so we can send you a copy immediately.
*
* DISCLAIMER
*
* Do not edit or add to this file if you wish to upgrade PrestaShop to newer
* versions in the future. If you wish to customize PrestaShop for your
* needs please refer to http://www.prestashop.com for more information.
*
*  @author PrestaShop SA <[email protected]>
*  @copyright  2007-2011 PrestaShop SA
*  @version  Release: $Revision: 6594 $
*  @license    http://opensource.org/licenses/afl-3.0.php  Academic Free License (AFL 3.0)
*  International Registered Trademark & Property of PrestaShop SA
*}
 
<li {if isset($last) && $last == 'true'}class="last"{/if}>
<a href="{$node.link}" {if isset($currentCategoryId) && ($node.id == $currentCategoryId)}class="selected"{/if} title="{$node.desc|escape:html:'UTF-8'}>{$node.name|escape:html:'UTF-8'}</a>
{if $node.children|@count > 0}
<ul>
{foreach from=$node.children item=child name=categoryTreeBranch}
{if isset($smarty.foreach.categoryTreeBranch) && $smarty.foreach.categoryTreeBranch.last}
{include file="$branche_tpl_path" node=$child last='true'}
{else}
{include file="$branche_tpl_path" node=$child last='false'}
{/if}
{/foreach}
</ul>
{/if}
</li>

Share this post


Link to post
Share on other sites

witam,

 

I co nadal nikt nie ma żadnych propozycji?

 

Dodatkowo dodam że coś źle wyświetlają się ceny produktów na stronie danego działu:

 

http://edge.shop.pl/lyzwy/prices-drop

 

Jednak wystarczy wejść na stronę produktu i ceny znowu wyświetlają się poprawnie - źle działa to tylko na liście produktów...

 

Próbowałem wgrać bliki z backup (cały sklep) z czasu kiedy wszystko chodziło dobrze i nadal nic - czy może to być błąd bazy danych??? 

Share this post


Link to post
Share on other sites

nie - po promocji.

 

np. produkt kosztował 280zł dodałem nową cenę - rabat 40zł czyli cena po rabacie to 240, dodatkowo kliknąłem "wyprzedaż"

 

na liście produktów wyświetla mi np. 187zł, ale po wejściu na stronę produktu już jest ok - czyli przekreślone 280 i cena 240.

 

Wcześniej się tak nie działo ... do tego ten blok kategorii - jakaś porażka normalnie..

 

Jeszce teraz mi przyszło do głowy że niedawno uruchomiłem opcjęzakupów bez rejestracji... ale nie wiem czy to może mieć wpływ - zaraz spróbuję :P

Share this post


Link to post
Share on other sites

No nic widzę że nikt też nie wie o co chodzi.

 

Z promocjami okazało się że dzieje się to tylko na 1 z 3 laptopów - nie rozumiem tego :P

 

Natomiast z brakującymi kategoriami /**/

 

1. Znalazłem że zablokowały się na linku:

 

http://edge.shop.pl/lyzwy/16-sprzet-uzywany

 

Który pojawia się kilkakrotnie na stronie głównej - np. po kliknięciu kinkyslider (czego ja nie umieszczałem), pod menu poziomym na górze strony.

 

Próbowałem to firebugiem znaleźć i znalazłem ale niestety nie umiem ustalić gdzie to należałoby edytować w preście. Może ktoś pomoże....

Share this post


Link to post
Share on other sites

No w template było sporo pliczków ale nawet ich usunięcie nie pomogło :(

 

Nadal zamiast kategorii mam /**/ i pałętający się link do sprzętu używanego na całej stronie.

 

A może zna ktoś darmowy alternatywny blok kategorii - może to zadziała...

Share this post


Link to post
Share on other sites

 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More