Jump to content
michaelvips

[resolvido] Loja prestashop adiciona 3 produtos padrões ao pedido automáticamente

Recommended Posts

Olá recentemente estou com o seguinte problema, a cada pedido feito na loja seja de 1 ou mais produtos automáticamente na pagina de pedidos do cliente fica adicionado 3 produtos padrões da loja que nem estão mais cadastrados foram excluidos.

 

Produtos ABAIXO :

 

Blouse - Color : White, Size : M    

Printed Summer Dress - Color : Yellow, Size : M    

Faded Short Sleeve T-shirts - Color : Orange, Size : S
    

 

Em anexo uma foto do erro

 

post-781617-0-91680600-1401896214_thumb.png
 

Edited by michaelvips (see edit history)

Share this post


Link to post
Share on other sites

Vc. mexeu no banco de dados manualmente ? verifique os produtos que estao sendo incluídos no pedido e procure se com o mesmo ID existem produtos duplos.

 

O melhor é vc. deletar estes produtos através do seu back-office. Por favor nao mexa no banco de dados manualmente, pois Prestashop possue um monte de dependencias. Vc. deletando dados em uma tabela manualmente, nao deleta os dados dependentes em outras tabelas, causando uma imparidade.

Share this post


Link to post
Share on other sites

Não mexi nos bancos de dados, os produtos que são adicionados nem mesmo estão mais cadastrados foram deletados há muito tempo

Share this post


Link to post
Share on other sites

Os produtso em questao sao produtos padarao, e nao foram deletados no banco de dados. Como foi que deletou ?


Qual o link da sua loja ?

Share this post


Link to post
Share on other sites

Existem duas maneira de nao usar o padarao. Deletando através do back-officeou entao quando instala a software nao instalar os modelos padarao (opcao mais segura).

 

Deletar os produtos padrao: aba catálogo ->produtos e deleta cada produto manualmente. Nao use delecao em massa, pois se o seu servidor nao estiver configurado corretamente, p. ex. tiver um limíte de memória mouito baixo, capaz de nao executar corretamente, ou o script até o fim. Isto pode causar que os produtos foram deletados somente em partes do banco de dado.

  • Like 1

Share this post


Link to post
Share on other sites

Infelizmente nao posso terminar o meu carrinho pois nao consigo selecionar um estado (apesar de o meu CEP ter sido aceitado). Bug de algum módulo que está usando ? Veja aqui no fórum nos módulos o mesmo problema.

 

O meu carrinho nao contém nenhum produto extra.

 

Pode ser que vc. tinha uma sessao de cookie aberta, aonde vc. tinha adicionado produtos de teste ao seu carrinho ?

 

Delete a sessao cookie no seu browser e também o cache. Tecla F5 ou entao nos settings do seu browser.

Share this post


Link to post
Share on other sites

Veja em anexo o meu carrinho. Nao sei porque mas agora foi possível registrar o meu endereco, ou seja selecionar um estado.

post-741527-0-38093400-1401917265_thumb.jpg

Edited by selectshop.at (see edit history)

Share this post


Link to post
Share on other sites

Mesmo finalizando o pedito eu nao vejo nenhuma anormalidade com produtos extras (veja screen). O único problema que constatei foi na página CMS a qual referenciei mais acima.

post-741527-0-25733400-1401917502_thumb.jpg

Share this post


Link to post
Share on other sites

Já foi resolvido tinha alguns pedidos no banco de dados.
Removemos das tabelas ps_order_carrier, ps_order_detail e ps_order_history.

 

E solucionou o problema, vou adicionar o seu site e vou entrar em contato para contratar seus serviços.

Share this post


Link to post
Share on other sites

Obrigada.

Para remover pedidos, existe um módulo que o faz. Vc. simplesmente seleciona as ordens em questao e nao precisa mexer no banco de dados. ;)

 

http://addons.prestashop.com/en/administration-tools-prestashop-modules/3463-delete-orders.html

ou free

http://www.prestashop.com/forums/topic/191037-free-delete-orders-module/

 

Se o seu problema estiver resolvido, por favor marque como tal. Grata

http://www.prestashop.com/forums/topic/235885-marcar-topicos-resolvidos-com-resolvido/

Share this post


Link to post
Share on other sites

A sua página CMS "Tablea de aplicacoes" contém alguns caracteres de código e está bugando a página. Veja aqui:

http://www.ciplace.com.br/tabela-de-aplicacoes/

 

Somente é aceito HTML padrao. Retrabalhe o texto da página cms e retire todos os comandos que nao sejam HTML padrao.

 

Sim vou resolver isso, obrigado

Mesmo finalizando o pedito eu nao vejo nenhuma anormalidade com produtos extras (veja screen). O único problema que constatei foi na página CMS a qual referenciei mais acima.

 

Sim já resolvi, obrigado.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More