Jump to content
Zythom

[RESOLU] homeslider dans la colonne centrale

Recommended Posts

Bonjour à tous,

 

pour dépanner un ami je lui fais l'upgrade de la 1.5.5.0 vers la 1.6.0.6

Tout se passe relativement bien.

 

J'ai juste du mal avec la page d'accueil. Il veut garder deux colonnes sur le site (left et center), mais sur la homepage le slider se trouve au dessus des colonnes et je voudrais qu'il soit en haut de la colonne centrale.

Je me suis bêtement dit :"tiens, je vais le greffer dans displaycentercolumn" mais ce hook n'existe pas :ph34r:

 

Quelqu'un pourrait-il me dire comment enlever le slider du header et le mettre en haut de la colonne centrale ? (sans qu'il ne bug bien entendu...)

 

Merci

 

PS : je travaille en local

 

EDIT : j'ai dégreffé le module de displayHeader et greffé dans displayhome, et du coup j'ai toutes les images en background l'une au dessus de l'autre en partant du header et pareil mais en dur en partant du bas de la home...

Il faudrait juste m'aider à greffer le module dans displayhome et qu'il continue à "slider" :)

Edited by Zythom (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

NE JAMAIS dégreffer un module du displayHeader !!!

Que le module soit greffé dans ce hook est essentiel à son bon fonctionnement, cela lui permet de charger ses fichiers CSS et JS. Donc forcément si le module n'est plus greffé dans ce hook, cela fonctionne moins bien...

 

Il faut le laisser greffé au hook displayHeader et le greffer également au hook voulu (colonnes, homepage...)

Share this post


Link to post
Share on other sites

Merci Divine :)

Je l'avais remis dans le displayheader (heureusement que je fais ça en local lol) et je l'ai également greffé dans displayhome.

Et c'est là que j'ai un souci : il apparait dans le header (et fonctionne) et en même temps dans la home (ou je n'ai que la première image sans slide).

J'ai lancé liveedit et l'ai déplacé du header vers la home (emplacement vert donc normalement ça marche). Il se positionne bien, j'enregistre, tout est OK.

Sauf qu'en quittant le liveedit et en rafraichissant la page, tout revient comme ci-dessus...

 

Une idée ?

Edited by Zythom (see edit history)

Share this post


Link to post
Share on other sites

le diaporama (slider) pour page d'accueil

Share this post


Link to post
Share on other sites

Etrange alors car il ne devrait pas apparaître dans le header.

Share this post


Link to post
Share on other sites

enfait je m'exprime mal lol

il apparait au dessus des colonnes...

 

OK merci j'ai compris !!! C'était de displayTopColumn que je devais le retirer !!!

 

 

Résolu :)

Edited by Zythom (see edit history)

Share this post


Link to post
Share on other sites

Bon ben finalement c'est pas tout à fait résolu !!!

Je n'arrive pas à place le diaporama au-dessus du bloc produits phares/nouveautés/meilleures ventes...

Je l'ai bien positionné au dessus de tous dans displayHome, mais ma page affiche le bloc des trois (avec les produits) puis le slider, et ensuite encore les produits phares...

Share this post


Link to post
Share on other sites

Il faut vérifier que la position du slider a bien été enregistrée dans l'onglet Modules >> Positions en rafraîchissant la page, parfois le déplacement n'est pas bien pris en compte.

Share this post


Link to post
Share on other sites

J'ai bien le diaporama au dessus des produits phares...

Share this post


Link to post
Share on other sites

Une petite nouveauté : j'ai réinitialisé les trois blocs (nouveauté, produits phares et meilleures ventes), ce qui a corrigé le doublon d'affichage des produits phares.

Mais là je sèche : dans displayHome je n'ai que le slider de greffé, et il se retrouve pourtant sous les trois blocs sur la home page. Du coup je ne peux pas le mettre au dessus, ni avec live edit, ni en le déplaçant dans le bloc vu qu'il y est tout seul...

 

La j'ai vraiment besoin d'un coup de pouce...

Edited by Zythom (see edit history)

Share this post


Link to post
Share on other sites

Le hook displayHome est-il au-dessus du hook sur lequel les produits phares sont greffés ?

Share this post


Link to post
Share on other sites

les trois blocs produits phares/nouveauté/meilleurs ventes ne sont pas dans le displayHome, ils ne sont que dans displayHomeTab et displayHomeTabContent

Share this post


Link to post
Share on other sites

Oui je sais bien... et donc est-ce que les hooks displayHomeTab et displayHomeTabContent sont bien en-dessous du hook displayHome ?

  • Like 1

Share this post


Link to post
Share on other sites

Autant pour moi :)

Oui ils sont bien dans cet ordre : home, hometab, hometabcontent

Share this post


Link to post
Share on other sites

Ce n'est pas dans le back-office qu'il faut regarder cela mais dans le fichier "index.tpl" du thème.

Share this post


Link to post
Share on other sites

Ah OK !!!

 

Donc je modifie ça :

 

{if isset($HOOK_HOME_TAB_CONTENT) && $HOOK_HOME_TAB_CONTENT|trim}
    {if isset($HOOK_HOME_TAB) && $HOOK_HOME_TAB|trim}
        <ul id="home-page-tabs" class="nav nav-tabs clearfix">
            {$HOOK_HOME_TAB}
        </ul>
    {/if}
    <div class="tab-content">{$HOOK_HOME_TAB_CONTENT}</div>
{/if}
{if isset($HOOK_HOME) && $HOOK_HOME|trim}
    <div class="clearfix">{$HOOK_HOME}</div>
{/if}

 

par ça :

 

{if isset($HOOK_HOME) && $HOOK_HOME|trim}
    <div class="clearfix">{$HOOK_HOME}</div>
{/if}

{if isset($HOOK_HOME_TAB_CONTENT) && $HOOK_HOME_TAB_CONTENT|trim}
    {if isset($HOOK_HOME_TAB) && $HOOK_HOME_TAB|trim}
        <ul id="home-page-tabs" class="nav nav-tabs clearfix">
            {$HOOK_HOME_TAB}
        </ul>
    {/if}
    <div class="tab-content">{$HOOK_HOME_TAB_CONTENT}</div>
{/if}
 

 

Correct ?

Share this post


Link to post
Share on other sites

Et ça marche !!!

 

Encore un grand merci Divine !!!

Share this post


Link to post
Share on other sites

Bonjour,


 


Je découvre Prestashop et j'ai fait une boulette...


j'avais le même problème qu'évoqué dans ce post, et j'ai déplacé le slider dans le home... Ca n'a pas fonctionné.


Par contre, j'essaie de remettre le module 'slider' dans DisplayHeader mais DisplayHeader n'apparait pas dans la configuration du thème.


Quelqu'un peut il m'aider pour faire fonctionner correctement ce module?


 


Cordialement


Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More