Jump to content

My product page show 0,- instead of price

Recommended Posts

Okay first of all, here is the link to my webshop (the page where the problem is): http://prosaks.dk/tshirts/1-faded-short-sleeve-tshirts.html#/size-s/color-orange


If you look at the front page it shows the prices right. If you press a product it shows zero (0), but in my cart it shows the right price.


I seen people have the same problem in here at the forum, but i cant really find out how to fix it.




Another thing: The "In stock" button won't be translated. Could anyone give me the path to the file where the text is, and i will do it manually in the script? I don't know how to find the path ...  :(






I hope you can help me!

Nicolai  :)  :)  :)

Link to comment
Share on other sites

  • 5 months later...

Xavier du Tertre      Posted this reply in another thread and it worked for me.




A month ago, we found a bug on whenever you'd set up a group reduction of 10%, the products would display a 90% reduction (the initial feature had been tested with a 50% reduction and that's how it ended up in the final version).


Then, Julien committed this fix: https://github.com/P...9c668de5f81db81


Basically replacing {$group_reduction} with {1-$group_reduction} in themes/yourthemename/product.tpl and merging this in the release.


So is clean!


However, some of you are facing a problem because you are using a theme that was developed from the standard theme of PrestaShop If you combine our fix with a theme that was developed on the previous version of PrestaShop, you get a multiplier equal to {1-1}. And that's why you have prices at $0.


Please check this forge reports and the comments. You'll easily find out how to fix your prices display! http://forge.prestas...owse/PSCSX-1835

Link to comment
Share on other sites

  • 1 year later...
  • 6 years later...
On 1/28/2016 at 8:16 PM, wissammessad said:

Hi, I found the solution for this on a forum.


to fix it:


1: open "themes/xxx(name of them)/product.tpl"

2/ find "{$group_reduction}" in file and replace it with "{1-$group_reduction}"


Thanks for the tip. I took my cue from that and found my own solution, as follows:


I checked out the themes/classic/templates/catalog ---> product.tpl file via my server (l'm using the default theme for Presta), and l noticed this:

    <meta property="product:pretax_price:amount" content="{$product.price_tax_exc}">
    <meta property="product:pretax_price:currency" content="{$currency.iso_code}">
    <meta property="product:price:amount" content="{$product.price_amount}">
    <meta property="product:price:currency" content="{$currency.iso_code}">

It occurred to me: I was feeding the currency symbol into Presta during product spreadsheet upload.

TL;DR: I removed the currency symbol from my upload spreadsheet, and the upload worked, the prices are correct.

Edited by poshshop (see edit history)
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...