Jump to content
nympheur

Copie de mon site de production vers installation locale

Recommended Posts

Bonjour à tous

Voulant installer de nouveaux modules j'ai décidé de développer tout ça en local... jusque la tout va bien

c'est ensuite que ça se gâte!

Alors voici comment j'ai procédé
- je me suis connecté au ftp de mon hébergeur
- j'ai récupéré en local les fichiers et dossiers
- je me suis connecté en phpmyadmin de mon hébergeur j'ai récupéré ma base de données
- j'ai installé wamp server
- j'ai créé une base de données (nom similaire que celle en production)
- j'ai importé les tables avec succès
- j'ai édité la table ps_shop_url et j'ai changé le nom de domain par http://localhost et domain ssl par localhost

- j'ai édité le fichier de conf (settings_inc.php) et renseigné les bonnes valeurs
- j'ai changé le lien par \www\mondossierlocal
- j'ai enregistré, fermé wamp et relancé

- j'ai supprimé le .htaccess
- j'ai vidé les caches smarty

- j'ai essayé de me connecter par wamp à localhost mais ça me dirige vers le site en ligne
- impossible d’accéder au back office en local et idem pour le front office

vous voyez quelque chose qui cloche?
merci pour votre aide

Je sais qu'il y a pas mal de messages qui traitent de ces problèmes et j'ai suivi pas mal de tutos mais rien ne fonctionne dans mon cas

Share this post


Link to post
Share on other sites

Bonjour,

Si il y a une redirection vers le site en ligne, c'est soit que le .htaccess est toujours en place, soit dans phpmyadmin la modification de l'url n'a pas été prise en compte.

Sinon tente de remplacer localhost, par localhost:8888 dans le fichier settings_inc.php. Parfois ça bug à cause de ça ! (sur mac)

Share this post


Link to post
Share on other sites

Bonjour

 

Videz votre cache navigateur ctrl+F5 et le cache :

 

sur la 1.4.x /tools/smarty/cache & /tools/smarty/compile
Supprimer tous les fichiers sauf le index.php s'il y est.

sur la 1.5.x /cache/smarty/cache & /cache/smarty/compile
Supprimer tous les fichiers et dossiers sauf le index.php s'il y est.
 

Share this post


Link to post
Share on other sites

Merci Oron pour l'intervention mais c'est une opération que j'avais déjà effectué.... je continue de chercher

Share this post


Link to post
Share on other sites

Et les cookies ? soit c'est le cache du navigateur, soit le cache smarty, soit le .htaccess

si ces trois ont été vérifier il reste les cookies ou dans un fichier ou base de donnée un lien en dur.

Share this post


Link to post
Share on other sites

Le .htaccess a été supprimé

les cache ont bien été vidé

les cookies également

la j'y perd mon latin je dois bien l'avouer... :wacko:

Share this post


Link to post
Share on other sites

Désolé je ne vois pas d'autre possibilité.

Et la base de donnée en l'ouvrant avec notepad++ vous l'avez vérifié ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More