Jump to content
rafaxpto

Free FAQ Module v1.0

Recommended Posts

Hi there,

thanks for replying to my post and giving me this great solution. Maybe I can suggest some improvements.

1) Able to add a small banner above all the questions as logo or just another picture saying "Frequently Asked Questions"
2) Able to move the questions up and down so that we can easily sort the questions according to relevance
3 ) Able to add Titles or sub title in the FAQ page for example

SHOPPING

Question 1
Question 2
Question 3

PAYMENTS

Question 1
Question 2

4) Able to do a search in the FAQ list with a search text box.

That's all I have for now .... but this is a really great module I have been really trying to find something like this for a while.

Regards
Archproject

  • Like 1

Share this post


Link to post
Share on other sites

This is a great module!!
There's just a problem for me, I install it on Prestashop 1.24, when I am in the FAQ page (only in the FAQ page), the links for my-account.php (/shop/modules/faq/my-account.php) and password.php (/shop/modules/faq/password.php), normally these 2 links should be /shop/my-account.php and /shop/password.php.
Can anyone help me with the pro0blem? Thank you.

Share this post


Link to post
Share on other sites
This is a great module!!
There's just a problem for me, I install it on Prestashop 1.24, when I am in the FAQ page (only in the FAQ page), the links for my-account.php (/shop/modules/faq/my-account.php) and password.php (/shop/modules/faq/password.php), normally these 2 links should be /shop/my-account.php and /shop/password.php.
Can anyone help me with the pro0blem? Thank you.


Hello Sir,
You need to change the path of the links to be relative to the domain of your website, and not relative to the page you are visiting.
Cheers,
Rafa

Share this post


Link to post
Share on other sites

Hello! Wery good module! But I made one change: move faqs.php from modules folder to root of site, because modules folder is disabled to indexing for searching in robots.txt!
Sorry for my bad English =)

Share this post


Link to post
Share on other sites

thanks for this great module! It works. I' now updating their functionalities to improve it. I need these main functionalities:
1: an option of publicated in the database, I want to have some faq in my database but not published. I modified the
backed code to add this new field "publicated". but I have an error Hack attempt when i try to add a faq. which is the
function that validate the parameters or variables in prestashop generally. What is the best option to trace this kinf of
error, because more of the instructions in prestashop finish in die.
2: the second option is group the faqs in categories like products. ? in this topic i just start .. any idea?

Thanks for all.

Share this post


Link to post
Share on other sites

Ok. I really like this module as I have downloaded the module and uploaded it to the site. I'm sure wondering where did it go after I uploaded it? I can't find it anywhere, did the name change? In other words how to I access it after I upload the module? Thanks for any and all help!

Share this post


Link to post
Share on other sites

Hi!

Thanks alot for the mod!

But i trying to make the faq site in "www.mysite.com/faq.php"

But when i installed the mode in module, and then go to the FAQ, it became "http://mysite.com/modules/faq/faqs.php"

How do i do so i can put the file just as "www.mysite/faq.php"


I put all files in the module map and istalled it. Did i do anything wrong? plz help me. =((
Sorry for my bad english

Share this post


Link to post
Share on other sites
Hi!

Thanks alot for the mod!

But i trying to make the faq site in "www.mysite.com/faq.php"

But when i installed the mode in module, and then go to the FAQ, it became "http://mysite.com/modules/faq/faqs.php"

How do i do so i can put the file just as "www.mysite/faq.php"


I put all files in the module map and istalled it. Did i do anything wrong? plz help me. =((
Sorry for my bad english


I moved faqs.php file into root of site and modified templates (path to file)

Share this post


Link to post
Share on other sites
Hi!

Thanks alot for the mod!

But i trying to make the faq site in "www.mysite.com/faq.php"

But when i installed the mode in module, and then go to the FAQ, it became "http://mysite.com/modules/faq/faqs.php"

How do i do so i can put the file just as "www.mysite/faq.php"


I put all files in the module map and istalled it. Did i do anything wrong? plz help me. =((
Sorry for my bad english


I moved faqs.php file into root of site and modified templates (path to file)


Hi!

how did u modified the templates (path to file) then, plz help me.

Share this post


Link to post
Share on other sites

Replace in faq-column.tpl file links from {$module_dir}faqs.php to /faqs.php and don't forget to move file faqs.php to root of site

Share this post


Link to post
Share on other sites

Hi, yes it's a very good module. On my page works perfect.
U should add one option to faq (back end) - hand sort question.
Example: if i wrote 1,2,3,4... etc question and need write 15th question but on first position on faq page :)
Now I need delete all questions :P yes?

Share this post


Link to post
Share on other sites

Yes you need to delete all, tomi. I wrote the functionnality to sort question... If somebody is interested to develop it !

Share this post


Link to post
Share on other sites

Hi !
I first would like to say thank you to everyone for the progresses made in developping this faq module for the community.
This module is very interesting as it allows us to give the customer a kind of "internal user's manual" regarding "how to order" on the website.

I am running PS 1.2.5.
The recent version faq 1.2.2 installs itself correctly in the module directory.
It does not seem to have any impact on other installed modules/blocks.
I succesfully entered some questions and answers.

But I still face two problems already reported at the early beginning of this thread :

1-I cannot access the question/answer updating (the update/modif/edit button in the faq BO does not react).
2-The answers are txt formatted, and I need to give them some better reading quality, using html.

I was thinking that those problems/limitations were resolved since november.
Is it the case ?
Or is it just me doing someting wrong ?
I tried both versions of the faq module : 1.2.1 and 1.2.2, and my results are identical !

Thank you for any information, help or advice in this matter.

Share this post


Link to post
Share on other sites
Hi !
I first would like to say thank you to everyone for the progresses made in developping this faq module for the community.
This module is very interesting as it allows us to give the customer a kind of "internal user's manual" regarding "how to order" on the website.

I am running PS 1.2.5.
The recent version faq 1.2.2 installs itself correctly in the module directory.
It does not seem to have any impact on other installed modules/blocks.
I succesfully entered some questions and answers.

But I still face two problems already reported at the early beginning of this thread :

1-I cannot access the question/answer updating (the update/modif/edit button in the faq BO does not react).
2-The answers are txt formatted, and I need to give them some better reading quality, using html.

I was thinking that those problems/limitations were resolved since november.
Is it the case ?



Note: Hi, I think I am having the same problem as you do. I am running ps 1.2.5 with Moon theme. While installing this module, I dont have to move the faqs.tpl file to the root, if i did so, it will appear 404 error and I cant access the webpage.

However, I can only add new faq but not edit them. Even if i click edit, it will create a new faq... Somehow, i have got razaro to test on it (with his own computer and on firefox browser), he managed to edit the faq section through my back office. Well, I am testing on IE8 and firefox with my computer but fail. I have even asked joel to look into my problem, he accessed to my back office and tested on safari, sadly to find out that joel has no problem with the edit matter too. It seems that only i couldnt edit through my computer, maybe..... the bottom left conner of my BO shows 'tinymce is undefined'error...hopefully someone can answer my question too.

Well, will try it out again with my borther laptop when i have free time, otherwise, I will have to get razaro to help to upload and edit the faq section for me....


nic

Share this post


Link to post
Share on other sites

I have tried it now on 2 different servers with Prestashop 1.3
It's always the same problem: The FAQs do not open.

25064_Lk0c6ixxFHOZrKrmhkAR_t

Share this post


Link to post
Share on other sites

Hello guys,

I have it running on 1.3.1 and confirm that is working great without a problem for me.
I did nothing special to make it work so it is strange that it don`t work for you TheDude, have you give permission rights to the folder ?

You could try this,

<!-- FAQ Module -->

<link rel="stylesheet" type="text/css" href="{$module_dir}lib/apple.css" />
<!-- /FAQ Module -->

to

<!-- FAQ Module -->

<link rel="stylesheet" type="text/css" href="http://www.yoursite.com/modules/faq/lib/apple.css" />
<!-- /FAQ Module -->



Sometime it helps to change it to the full path, i had sometimes modules that where not working correct but changing it to full path to module solved many times my problems.
Worth to try it ;)

Don`t forget when copy from here to change to without the ( - ) cause the forum remove it right away when i post it.

ysco..

Share this post


Link to post
Share on other sites

Yes, i gave CHMOD777
In wich file can i make this changes?

Share this post


Link to post
Share on other sites

Hello mate,

Edit this file faq-header.tpl.

Hope it works for you ;)

ysco..

Share this post


Link to post
Share on other sites

Hello Ysco,

Thanks for your interest for this module. Many thanks for helping people about this module.
Are you interested to develop on it with us ?

Regards,
Joel

Share this post


Link to post
Share on other sites

Hello Joël Gaujard.

Hehe i wish that i had such knowledge so that i could write my own modules.
I m just a beginner and try to help people with things that i have encountered myself.
If i could help you then i did it right away Joël ;)

BTW i love the Faq module and it is great looking and i use it for some time now, i hope that someone can assist you to develop this great module further.

Thanks so far for your work and contribution.

Best regards,

ysco..

Share this post


Link to post
Share on other sites
Here is the Turkish (Türkçe) translation file.
Hello Caglar,
Many thanks for your contribution. I'll contact you by PM for add your name to translator list.

Share this post


Link to post
Share on other sites
Hi there,

Able to add Titles or sub title in the FAQ page for example

SHOPPING

Question 1
Question 2
Question 3

PAYMENTS

Question 1
Question 2
Archproject


Hi there, I would like put Titles like archproject said. I know it is possible (seen here : http://www.cityfarmer.fr/faq.php).

I don't ask you how to develop the module changing the titles directly from the BO but in the .php & .tpl files.

So if you know how we can do that, thanks for your reply, it will help a lot of people i guess.

Share this post


Link to post
Share on other sites

Hello probe16,

I found a hack for display title if you want...

You need to do something like this in faq.tpl file :

{foreach from=$faqs item=faq name=loop}
   {if $smarty.foreach.loop.iteration == 2}{l s='My special title' mod='faq'}{/if}
{$faq.question}

       {$faq.answer}


 
{/foreach}



I test it and it works.

But it's better to define title in BO. Waiting in vain for help to enhance this module.

Regards,
Joel

Share this post


Link to post
Share on other sites

Yes waiting for update of mod for real implementation of title, numbering of FAQ's and sorting, thanks!

Share this post


Link to post
Share on other sites

Me too. Waiting in vain for help...
But I don't understand "numbering of FAQs"... How many questions ? Or just give a number for each question ?

Share this post


Link to post
Share on other sites

OK Rockstar2 ! I understand...
I'll add number in this version for the moment.

Thanks for your idea which I added to roadmap.

Share this post


Link to post
Share on other sites

An important post to announce you a new release !

Version 1.3.2 is released
You can download this module on sourceforce : https://sourceforge.net/projects/modprestafaq/

Special thanks to all translators for theirs translations. Now FAQ module is available in 14 languages.
I think this module is a success with its 870 downloads on source forge.

This is the change log:
Tested and validate for PrestaShop version 1.3.1
Enhance dedicated page : add a name for loop to add numbering.
Correct some minor errors.
Add Italian translation. Thanks to Di Giuseppe Luigi !
Add Swedish translation. Thanks to Hjalmarsson, Mats !
Add Slovak translation. Thanks to Mojš Ladisla !
Add Danish translation. Thanks to Elund Christensen !
Add Polish translation. Thanks to Jakub Gzyl !
Add Turkish translation. Thanks to Caglar !

We still search for developers to enhance this module. We have a roadmap ready...
Of course, all translations are welcome !

Regards,
Joel GAUJARD

Share this post


Link to post
Share on other sites

Hello GreekAirSoft,

Thanks for your contribution. I rename your file to el.php to respect iso language name given by PrestaShop.
But 4 expressions are not translate :(

I just need your complete name (last name + first name) with an URL or mail address. I will send you a PM about this.

Regards,
Joel

Share this post


Link to post
Share on other sites

Hi, here is the romanian translation for this useful module.
Regards,

ro.php

Share this post


Link to post
Share on other sites

Hello Rhobur,

Thanks for your contribution.

I just need your complete name (last name + first name) with an URL or mail address. I will send you a PM about this.

Regards,
Joel

Share this post


Link to post
Share on other sites

Wonderful apps !

But... is there any way to re-order the list, even by diving in the database ?


Best regards !

Share this post


Link to post
Share on other sites

The multilingual site does not work switching languages in the administration. Questions I only write in the default language. (PS v1.3.1.1, FAQ Module v1.3.2)
Does anyone like problem?

Share this post


Link to post
Share on other sites

Hello Clerc,
I just tested to have a question in 3 languages (spanish, french and english) and it works very well. Can you send us an URL to see the problem ?
Regards,
Joel

Share this post


Link to post
Share on other sites

Hello,

First thank you for this module, very good idea !
I also have an issue with the translations : while typing a question in the non default prestashop language, I get the message "vous devez saisir une question". By typing it a second time, it's correctly inserted but without any real language since it's visible in the front end FAQ with all the languages.

Did anyone correct this issue ?
Tks
Regards
Benoît

Share this post


Link to post
Share on other sites

Hi there Joel,

Please could you tell me if this module works with 1.2.5?

Best regards,

Share this post


Link to post
Share on other sites

Hello Mandrin,

F.A.Q. have been developed for PrestaShop 1.1.x so I think it's work on 1.2.5.

Regards,
Joel

Share this post


Link to post
Share on other sites

I have problem with This MOD.
when I add something the error come up:
HTTP 403 - Forbidden
This area is forbidden.

any suggestion?

also Joel , I bought one your MOD,, you know me . you never come back to me.
Please advise me

Share this post


Link to post
Share on other sites

Hi,

This is a great module, very helpful! I am having a small problem with it however. I am using the Wiznav module, and when I click on the FAQ link it causes my wiznav buttons to disappear. Thanks for any help you can offer!

Share this post


Link to post
Share on other sites

I don't get it anymore. I want this module to show in the informationsblock, that I have placed in the right column.
I can edit these links within my cms. But I don't know had to add a link to www.mywebsite.com/faq.php.

Can anyone tell me how to do this?

Fixed it already.

Share this post


Link to post
Share on other sites

Hi - we just wanted to add a few thoughts to this wonderful module.

We have used this module for a number of weeks now and we found the following things that seem to go wrong.

We have loaded 14 questions on each of the 2 PS sites we operate. No problems until recently!

We also use SSL and have found that the recent questions added have activated the SSL break out mode.

We looked and looked at the coding which we had already changed until we had an idea !! ( a light was switched on lol)

In the page faq-colume.tpl we re-wrote the text to the following text:


{l s='FAQ' mod='faq'}



{l s='Do you need help?' mod='faq'}
{l s='Click to see our FAQ section.' mod='faq'}

The most important part to make note of is the bar address – https (https secure mode) yes when we changed this to auto open in Secure mode all our problems ended - no break out page error warnings, no question bars not opening in fact we have to say that both sites are now working with the FAQ module without any visible errors what so ever.

So we just wanted to share this valuable information with other PS users who may also use SSL with their Domains.


Kind regards to all

Great Module well worth installing and twinking for ones own requirements.

Ian

Share this post


Link to post
Share on other sites

Great Module thank you!

Is there any way to make categories for more complex faq pages

Category 1 tittle
q1
q2
q3

Category 2 title
q1
q2
etc....

Thank you in advance for your reply and advice
Julien

Share this post


Link to post
Share on other sites

HI,

I installed the faq module but having an issues. Whenever I add a question the same thing keeps repeating in the back office. And I am not able to delete it either. See the screenshot

Thanks

29828_xDVTrJ4DNzj8xals2dlc_t

Share this post


Link to post
Share on other sites

Hello,
I would like to show my question order by question Name and not by ID.

Thanks in advance for your help.

Share this post


Link to post
Share on other sites

hi, i am really new using prestaShop, and i am not sure about how or what i have to do install the Module
i'd download the Zip, but all files are in the same folder, why ? i am sure i have not to to put all the files in the same folder

Share this post


Link to post
Share on other sites
Hello,
I would like to show my question order by question Name and not by ID.

Thanks in advance for your help.


Hello,
I have quite similar problem: I wish I could put a new question somewhere in the middle of the list without being forced to delete some existing questions, and recreate them downer in the list.

Is there any way to modify a question ID or change the order of questions?

Thanks a lot for this very useful module!

Share this post


Link to post
Share on other sites
Hello,
I would like to show my question order by question Name and not by ID.

Thanks in advance for your help.


Hello,
I have quite similar problem: I wish I could put a new question somewhere in the middle of the list without being forced to delete some existing questions, and recreate them downer in the list.

Is there any way to modify a question ID or change the order of questions?

Thanks a lot for this very useful module!


for this, the only thing u have to do is add and ORDER BY NAME on the Query

Share this post


Link to post
Share on other sites

I have a problem when I type

RewriteEngine on
RewriteCond %{HTTP_HOST} ^www.your_site.com$ [NC]
RewriteRule ^(.*)$ http://your_site.com/$1 [R=301,L]

In /.htaccess

when website start lode just as a your_site.com , without 'www'
javascript doesn't work!!

Please advise.
Thanks in advance for your help.

Share this post


Link to post
Share on other sites

I have installed the latest version of this module v1.3.2 and originally the little graphics above each question showed up, and although I didn't change anything from last night to this morning, except to add the questions and answers, now they do not?

I even put in the full direct path to the graphics within apple.css and they still do not show up.

Another item is that when you mouseover the question, it doesn't show as if it is a link, but if you click on it, the javascript works fine and the answer opens up. Strange.

Any pointers on how I can make the graphics show up again?

Share this post


Link to post
Share on other sites
I have a problem when I type

RewriteEngine on
RewriteCond %{HTTP_HOST} ^www.your_site.com$ [NC]
RewriteRule ^(.*)$ http://your_site.com/$1 [R=301,L]

In /.htaccess

when website start lode just as a your_site.com , without 'www'
javascript doesn't work!!

Please advise.
Thanks in advance for your help.


Hi, Look here... http://www.presto-changeo.com/content/6-prestashopseotips?redirected=

Share this post


Link to post
Share on other sites

I've a problem with changing languages (translating Q&A;).
I've Swedish as standard, but when I click on the Swedish flag, to translate to other languages nothing happens!

According to Google Chrome there is something wrong with "showLanguages is not defined" index.php line 236

Any clues?

Thanks

Share this post


Link to post
Share on other sites

Thanks for this module, its working really great for me using 1.3.1

I do have one suggestion though. It would be really neat to change the order of the questions once entered so that more common ones can be moved nearer the top.

Thanks

Share this post


Link to post
Share on other sites

Joel,

The below only works for 1 title what about having 2-10 Titles?


Hello probe16,

I found a hack for display title if you want...

You need to do something like this in faq.tpl file :
{foreach from=$faqs item=faq name=loop}
   {if $smarty.foreach.loop.iteration == 2}{l s='My special title' mod='faq'}{/if}
{$faq.question}

       {$faq.answer}


 
{/foreach}



I test it and it works.

But it's better to define title in BO. Waiting in vain for help to enhance this module.

Regards,
Joel

Share this post


Link to post
Share on other sites

Hello,


Did anybody find the way on how to sort the questions ? Accorging to a previous post, one has to add "Order by name" request. Which file do we have to modify to do so? An example file would be great ....

Great module :)

Share this post


Link to post
Share on other sites

Sorry but I just realized that I forgot to ask if it is possible to remove the numbers before each question. On the latest release of the module, there's an automatic numbering. Can we disable this feature ?


Thanks

Share this post


Link to post
Share on other sites

Super module, it worked out of the box, thank you very much.

I only had to modify the .gif files to let them fit into the theme.


Oh BTW, I have a FAQ:

Where do I change the background color of the answer?

I would like to have a white background.

All the best,

ARhifi.dk

Share this post


Link to post
Share on other sites

Hi,
I'm using Matrice Template with a Top menu julien. I installed the module but content appeared in the left column.
I changed hook in the home page content position but it's the same. What is the solution.
For your information, if I configured the origin template prestashop all is ok.
Regards

Share this post


Link to post
Share on other sites

Hello,
I have quite similar problem: I wish I could put a new question somewhere in the middle of the list without being forced to delete some existing questions, and recreate them downer in the list.

Is there any way to modify a question ID or change the order of questions?

Thanks a lot for this very useful module![/i]

for this, the only thing u have to do is add and ORDER BY NAME on the Query



Hi Rommel Castro A (or anybody who knows),

please post an istruction where to add ORDER BY (which line).

Thanks.

Share this post


Link to post
Share on other sites

Hi there.

Thanks for this module. Very useful, nice and free module.

One bug (or limitation?) : ul, ol and li html tags are well displayed on BO but not in FO.

I would clone (make another special faq with another name). I tried to duplicate all files and change all faq names, but the clone is not recognized. How can I do it (if it is possible)?

Thanks in advance.

(PS 1.3.3.0 and faq 1.3.2)

Share this post


Link to post
Share on other sites

A propably easy fix, but how do I change language? I noticed all the language files but how do I change to other then english?

Share this post


Link to post
Share on other sites

Hi there,

How come this module does now want to show the tinymce editor ? I am using PS 1.3.4 and using FAQ 1.3.2. Usually Tinymce would take some time to load but this time it does not show up at all. But on my old PS 1.3.2 it seems ok ...

Please help

EDITED :

could it be because of the Prestateam upgraded the tinymce in version 1.3.4? if so ... how can I make it work for this module ... in other tinymce places it works just this module does not work ...


####################################

# v1.3.4.0 - 3941 (2010-12-22) #

####################################


Improved/changed features :


[*] FO : Added several with/height HTML values for delete.gif

[*] FO : Improved memory management for digital files downloads

[*] FO : Improved the way manufacturers product were counted


[*] BO : added new version of tinyMCE

[*] BO : (cf comment bug #6266) (1.3) - AdminPDF and AdminPreferences - Font PDF can now be changed in every language without changing the employee language

[*] BO : remove old version of tinyMCE

Share this post


Link to post
Share on other sites

Can anyone explain how the translation file works? Where do you change language for this module?

Share this post


Link to post
Share on other sites

This is the language file for romanian language.

My name is: Brînzariu Cristian
My e-mail adress is: info@ebeton.ro
My website is: www.ebeton.ro

ro.php

Share this post


Link to post
Share on other sites

Hello,
I have quite similar problem: I wish I could put a new question somewhere in the middle of the list without being forced to delete some existing questions, and recreate them downer in the list.

Is there any way to modify a question ID or change the order of questions?

Thanks a lot for this very useful module![/i]

for this, the only thing u have to do is add and ORDER BY NAME on the Query



Hi Rommel Castro A (or anybody who knows),

please post an istruction where to add ORDER BY (which line).

Thanks.


Hello,

For ordering of the FAQs, add ORDER BY question at the end of the sql request (in file "faqs.php") as shown below, it seems to work!

$sql = '
 SELECT f.`id_faq` AS id, fl.`question` AS question, fl.`answer` AS answer
 FROM `'._DB_PREFIX_.'faq` f
   JOIN `'._DB_PREFIX_.'faq_lang` fl ON (f.`id_faq` = fl.`id_faq` AND fl.`id_lang` = '.intval($cookie->id_lang).')
 WHERE fl.`question` <> \'\' ORDER BY question';



FAQs are now ordered by question name.
If sb wants to order them differently, just add a number before every question title, a kind of "false ID" actually :)

I hope the tip will helpful for some people, good luck!

Share this post


Link to post
Share on other sites

Wow Great advice .. thank you very much .. I have been trying to do this ... hahahaha ... thanks again

Share this post


Link to post
Share on other sites

Hi,

Is it possible to use the FAQ module like the following:

PRODUCT TITLE 1

QUESTION1
QUESTION2
QUESTION3
etc...

PRODUCT TITLE 2

QUESTION1
QUESTION2
QUESTION3
etc...

PRODUCT TITLE 3

QUESTION1
QUESTION2
QUESTION3
etc...


I have FAQ for multiple products and would just like to separate them a little to navigate easier?

Any help on this would be great!

Regards

Share this post


Link to post
Share on other sites

I'm also looking for this if anyone could help??

Great Module thank you!

Is there any way to make categories for more complex faq pages

Category 1 tittle
q1
q2
q3

Category 2 title
q1
q2
etc....

Thank you in advance for your reply and advice
Julien

Share this post


Link to post
Share on other sites

Hi there,

Thanks for the module.
I cannot seem to get it working using prestashop 1.4
The backend seems OK, but the frontend wont display: shows the left collumn, but not the central or right hand column.

Any advice / help?

Cheers, Nik

Share this post


Link to post
Share on other sites
Hi there,

Thanks for the module.
I cannot seem to get it working using prestashop 1.4
The backend seems OK, but the frontend wont display: shows the left collumn, but not the central or right hand column.

Any advice / help?

Cheers, Nik


Please, Can anybode edit it for 1.4? :) THX

Share this post


Link to post
Share on other sites

Great module!
But I have question about url. How to make it www.mysite.xx/faq instead of www.mysite.xx/modules/faq/faq?

Share this post


Link to post
Share on other sites
Great module!
But I have question about url. How to make it www.mysite.xx/faq instead of www.mysite.xx/modules/faq/faq?


If you are using CPANEL ... you can go to REDIRECT and create a redirect from www.yousite.com/faq to www.yoursite.com/modules/faq/faq.php heheheh that's what i did

Share this post


Link to post
Share on other sites
Great module!
But I have question about url. How to make it www.mysite.xx/faq instead of www.mysite.xx/modules/faq/faq?


If you are using CPANEL ... you can go to REDIRECT and create a redirect from www.yousite.com/faq to www.yoursite.com/modules/faq/faq.php heheheh that's what i did


ok, thanks. then thats mean that I can rewrite/redirect with htaccess too?

Share this post


Link to post
Share on other sites
Great module!
But I have question about url. How to make it www.mysite.xx/faq instead of www.mysite.xx/modules/faq/faq?


If you are using CPANEL ... you can go to REDIRECT and create a redirect from www.yousite.com/faq to www.yoursite.com/modules/faq/faq.php heheheh that's what i did


ok, thanks. then thats mean that I can rewrite/redirect with htaccess too?


YUP

Share this post


Link to post
Share on other sites

Is it possible for articles published through this module to be incorporated with the search module?

SAMPLE:
Q? How to return a product?
A? Please contact one of our sales coordinators @ 1800RETURNS

What I would like to do is, using the search box, end-users can type keywords, for example "Returns", now since the sample question's subject has a word "return" on it. This will be picked up and give them this as a valid search result. Or is the search module specifically designed to work with products only?

Thank you in advance.

Share this post


Link to post
Share on other sites