Jump to content
breizh

Problème transfert site hebergeur --> local

Recommended Posts

Bonjour,

 

A la suite d'un changement d'ordinateur, j'ai récupéré de mon serveur la totalité de mon site (prestashop 1.5.4.0).

J'ai également récupéré la bd avec phpmyadmin.

 

Installation des dossiers dans "www" de wamp.

Mise en place de la bd

modification de la table "ps_shop_url:

  • domain: localhost
  • domain_ssl: localhost
  • physical_uri: /nom du dossier/

Modification de config -->> settings.inc

  • define('_DB_SERVER_', 'localhost');
  • define('_DB_NAME_', 'nom de la bd');
  • define('_DB_USER_', 'root');
  • define('_DB_PASSWD_', '');

 

Voici mon problème:

Quand le lance le site à partir de wamp, voici la page qui s'affiche (pas de problème avec d'autre site):

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at admin@example.com to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Apache/2.4.9 (Win64) PHP/5.5.12 Server at localhost Port 80

Merci d'avance à tous pour vos réponses

Share this post


Link to post
Share on other sites

Vous avez le .htaccess de votre boutique qui correspond toujours à votre boutique en ligne.

Le plus simple est de le supprimer (ou renommer), pour le regénérer via Préférences > SEO&URLs.

Share this post


Link to post
Share on other sites

Bonjour,

 

Merci pour votre réponse rapide

Maintenant j'ai ce message:

J'ai l'impression que le problème vient de: physical_uri: /nom du dossier/

La barre d'adresse me marque pourtant bien: http://localhost/nom de dossier/fr/

 

Merci d'avance

 

Not Found

The requested URL /nom de dossier/fr/ was not found on this server.

Apache/2.4.9 (Win64) PHP/5.5.12 Server at localhost Port 80

Share this post


Link to post
Share on other sites

Avez vous régénérer le htaccess (en accédant directement à votre BO) ? 

Car la on a l'impression qu'il chercher le dossier /fr dans votre dossier de la boutique.

Sans htaccess, il ne comprendra pas.

Edited by Szed (see edit history)

Share this post


Link to post
Share on other sites

Effectivement, j'avais supprimé le .htaccess.

J'ai donc récupérer un ancien .htaccess, ce qui m'a permis d'ouvrir le site.

Toutefois, je ne trouve pas dans Préférences > SEO&URLs l'option me permettant de regénérer ce fichier.

 

A savoir: je possède le site principal mais aussi deux sites vitrines. Je suis donc en multi-boutique.

J'ai donc cherché comment regénérer ce fichier dans: "toutes les boutique", "par défaut", et chacune des boutique.

 

Rien à faire je ne trouve pas

 

En vous remerciant une nouvelle fois, vous m'avez beaucoup aidé et trouvé la solution à mon problème du premier coup. MERCI

 

Cordialement

Share this post


Link to post
Share on other sites

En fait je parviens à entrer dans le back-office, mais coté client ouverture sur la page 404 et c'est la seule page accessible.

Share this post


Link to post
Share on other sites

Re bonjour Monsieur,

 

Je reviens vers vous une  nouvelle fois.

 

En effet, comme expliqué ci-dessus, je charge bien le back-office par contre je suis toujours sur une erreur 404 coté client.

Dans le back-office je ne parviens pas à trouver comment régégérer le .htaccess.

Cependant, je me retrouve avec un message m'informant d'un problème sur les réécritures de liens:

 

Sur la ligne de "URL simplifié":

Le mode de réécriture d'URL (mod_rewrite) n'est pas activé sur votre serveur, ou il est impossible de vérifier la configuration. Pour utiliser les URLs réécrites, vous devez activer ce mode.

 

Alors que la case est sur "OUI"

 

Merci d'avance

Share this post


Link to post
Share on other sites

Il n'y a pas de bouton "Regénérer le htaccess", cela se fera automatique lorsque vous modifié une option de SEO&URL.

Donc commencais par désactiver la ré-écriture d'URL.

Vous devriez retrouver votre front office.

Puis réactivez la pour tester.

Ne faites pas trop gaffe au message "Le mode n'est pas activé sur le server", PS à des fois du mal à le détecter. Et ca doit être activé par défaut sous WAMP

Edited by Szed (see edit history)

Share this post


Link to post
Share on other sites

Effectivement j'ai fini par comprendre que le fichier se régénérait en faisant un enregistrement.

 

Sous wamp le module n'était pas activé, je l'ai donc fait.

Conséquence: plus de message: "Le mode n'est pas activé sur le server" dans le back office.

 

Quand url simplifié "non activé" j'ouvre très bien le front-office.

 

J'ai activé, désactivé, ré-activé, ........ etc ......

mais quand activé, impossible de charger le front office.

Ce qui est surprenant c'est dans dans le message d'erreur il me réclame l'url d'une des mes boutiques vitrines (multi boutique)

_____________________________

Not Found

The requested URL /dossier boutique vitrine/index.php was not found on this server.

 

_______________________________

 

 

C'est surprenant car j'ai actualisé l'url simplifié sur toute les boutique (3).

Dans le .htaccess elles sont bien prisent en compte toutes les 3 aussi

 

Je ne comprend pas

 

Encore merci pour l'attention que vous portez à mon problème

Cordialement

Share this post


Link to post
Share on other sites

Bonjour

 

Ne vous cassez pas la tête avec le .htaccess en local sous wamp et cie

 

En local vous n'avez pas besoin de l'url rewriting, vous n'avez pas de visiteur qui passe sur votre poste et voir s'il y a des belles url's ou des url's moche :)

Vous ne perdez pas les liens en url rewriting.

Désactivé l'url rewriting et renommer ou supprimer le .htaccess

Share this post


Link to post
Share on other sites

Oui, merci Oron,

 

C'est ce que j'ai fini par faire car c'est vrai qu'en local de belles url sont inutiles.

 

Merci à tous pour votre aide, c'est sympa !!!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More