Jump to content
Sign in to follow this  
Robbyn

2 Erreurs PHP sur WampServer 2.0

Recommended Posts

Bonjour,

 

Je viens d'installer la toute dernière version 0.9.2 sur WampServer, tout fonctionne comme je le souhaite mais je rencontre 2 problèmes php que je n'arrive pas à résoudre  :-:

 

Mes 2 log erreur:

 

1- HP Warning:  mail() [<a href='function.mail'>function.mail</a>]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:wampwwwboutiquetoolsswiftSwiftPluginMailSend.php on line 160

 

Pourtant mon php.ini comporte bien smtp.orange.fr (mon FAI) et port 25... impossible d'envoyer un mail depuis le contact-form

 

2 - PHP Warning:  Missing argument 2 for Product::isAvailableWhenOutOfStock(), called in C:wampwwwboutiqueclassesProduct.php on line 1356 and defined in C:wampwwwboutiqueclassesProduct.php on line 1018

 

Impossible à résoudre...  ???

 

Merci de vos coups de pouces à l'avance  ;)

Share this post


Link to post
Share on other sites

Bonjour,

 

Pour le premier point, nous ne faisons qu'appeler la fonction mail, de toute évidence il y a un problème dans la configuration de votre serveur, je ne peux pas vous aider plus...

 

Pour le deuxième point, c'est la première fois je vois cette erreur plutôt critique :o

Je viens de vérifier dans le code source, tout est correct, l'argument est pourtant bien passé à la fonction, et il y a une valeur par défaut dans la structure de la base de données, fixée à 2, donc l'argument ne peux jamais être absent de l'appel de la fonction...

 

Pouvez-vous vérifier si la table ps_product de votre base contient bien une colonne 'out_of_stock' ?

Et voir par la même occasion si elle a une valeur par défaut.

 

J'attends votre réponse :)

Share this post


Link to post
Share on other sites

Merci,

 

Pour la fonction mail, il semble que ce soit Wamp qui bloque, je vais me renseigner, beaucoup de forums Wamp parlent de cette fonction bloquée, dommage.

 

Concernant l'autre erreur j'ai bien la colonne 'out of stock' avec par défaut 2 dans mysql

 

 

 

Share this post


Link to post
Share on other sites

Merci,

 

Pour la fonction mail, il semble que ce soit Wamp qui bloque, je vais me renseigner, beaucoup de forums Wamp parlent de cette fonction bloquée, dommage.

 

 

As-tu mis Wamp Online ?

Share this post


Link to post
Share on other sites

oui biensûr qu'il est on line, lol...

 

Mais j'ai résolu la partie email. Je suis sur une piste concernant la raison du problème. J'ai remplacé le httpd d'install Wamp par un httpd d'une ancienne install d'Apache 2 à mon boulot, là je le configure et là BOUM ça remarche... on peut enfin envoyer des emails à travers le contact-form. Je vous dirais prochainement les lignes causant ce problème.

 

Pour l'autre problème, toujours en recherche.

 

Merci de vos réponses

Share this post


Link to post
Share on other sites

Bonjour tout le monde

 

Pourriez vous nous dire si la derniere release a bien corrige votre deuxieme bug Robbyn.

Merci d'avance.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More