Jump to content

1 Click Update :( help needed


Recommended Posts

well just as I thought that 1 click was all fixed and that life was going to be a breeze

 

I get this

 

 

All files upgraded. Now upgrading database

 

[Ajax / Server Error for action upgradeDb] textStatus: "error " errorThrown:"Service Unavailable " jqXHR: " "

 

 

 

/---- Cheers Paul

Share this post


Link to post
Share on other sites

check this forge input;

http://forge.prestashop.com/browse/PSCFV-7608

 

you can find there post by Gregory:

 

Hi Pablo,

After investigation on your host :

Safe mode is enabled on your host and there are a right issues between user 10000:1004 and Apache 33:33, that makes http 500 errors.

The upgrade module is run by Apache and your host does not let files owned by Apache to be used by...Apache.

This configuration of your host does not let you tu use the module, and I guess you will have other troubles with htacess generating for instance.

You need to ask your host to remove safe_mode or configure the host to let files owned by Apache to be used.

Best regards

Share this post


Link to post
Share on other sites

  • 3 weeks later...

Hi Vekia,

 

I have exactly the same error message, except that everything has a green check mark. Still, the upgrade goes to the download stage, and will then keep reloading the page for 10-15 minutes before generating this error (exactly the same as OP).

 

The thing is, I have previously made a successfull test upgrade on the same server, just this time, it fails, no matter what I try. Could htaccess or php.ini be the cause?

 

Kind regards,

 

Dan

Share this post


Link to post
Share on other sites

I think i have the same issue :S

 

 

All files saved. Now backup Database

 

database backup : 211 table(s) left ...

 

[Ajax / Server Error for action backupDb] textStatus: "error " errorThrown:"Forbidden " jqXHR: "

Forbidden

You don't have permission to access /shop/admin***/autoupgrade/ajax-upgradetab.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

"

Share this post


Link to post
Share on other sites

Hi, I found a trick to make it work. I deleted all folders from my installation, with the exception of images, theme and the admin folder, and replaced them with fresh and clean folders from the current PS version I was using.

 

After that, 1-click upgrade did work just fine.

Share this post


Link to post
Share on other sites

No, I refer to all folders of your Prestashop installation. I removed all PS files and folders from my server, with the exception of the /img, /config and /admin folders and then uploaded and replaced the files with files from the PS zip file (important: same version as you are currently using).

 

After that, the 1-click upgrade worked.

 

Please, before you try something like this, be sure to have full backups of both your files and DB.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More