Jump to content
mowax

[Solved] Category tree missing from product associations tab

Recommended Posts

The category tree is missing from the Associations tab on all products in the back-office, so I can't change a product's category. I urgently need to fix this.

 

Can anyone help?

post-27482-0-42838100-1398905438_thumb.jpg

Edited by mowax (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

hello

this issue started to apear without any reason?

or you changed something? updated shop? installed some module? etc. ?

  • Like 1

Share this post


Link to post
Share on other sites

Hi,

 

It was working recently, but I have installed some new modules and also updated existing modules recently, so it's hard to identify the cause.

 

I also notice when I got to Catalogue > Categories, there are no categories listed ('no items found'). Then if I click the 'Reset' button, all the categories appear. But if I then refresh the page, all the categories dissappear again. This seems like it is related.

 

Recently I installed these modules

 

- Page cache

- Supplier alerts

- Unit Quantity Calculator

- Customized Quote

 

and probably a few more that I can't remember

 

I also updated the following modules

- Layered navigation

- Ebay

- Gsitemap

 

@Starboard, did you install/update any of the above?

 

Also multi-store is disabled. I enabled it in the past for testing, but I remember clearly that the categories were working when it was enabled. Enabling/disabling multi-store has no effect.

 

Thanks for any thoughts!

Edited by mowax (see edit history)

Share this post


Link to post
Share on other sites

Didn't install any of above modules, and all that I have installed have been updated.  It doesn't work whether multi-store is enabled or disabled.  The tree just doesn't appear.  I can only create a new Root Category but not a child.  Strangely enough, the existing categories don't export either to csv.  My feeling is there's a bug here in 1.6.0.5 but I don't want to upgrade to 1.6.0.6 yet as I am not sure it will fix this and I need to re-apply my theme and all my theme settings will be lost etc.  www.flemishlinen.com is our store. Cheers 

Share this post


Link to post
Share on other sites

I'm using 1.5.4.1. In my case at least, I think it's a conflict with a module because it was working not so long ago.

 

I have tried deleting cookies, and tested in 3 different browsers.

 

Now will try disabling modules one by one to see if any of them are the culprit.

Share this post


Link to post
Share on other sites

It was the Customized Quote module. And it doesn't even work!!! :angry:

Edited by mowax (see edit history)

Share this post


Link to post
Share on other sites

We don't use the customised quote module, we have had this problem since we upgraded to 1.6 and believe there's a bug with the category creation/tree.  We tried different browsers and both Mac and Windows but the problem persists.  We hope it will be fixed soon.

Share this post


Link to post
Share on other sites

Me too have a category tree problem.
My is in catalog/category/any_category_name/edit.
Buttons collapse all and expand all are there, but no category tree.
Multishop enabled, and same result in all shops. Category tree is working in catalog/Products/associations.

Tnx for all help!

/anders
 

Share this post


Link to post
Share on other sites

Hello! this topic is marked as Solved but... did anyone really solve it? I'm having this problem with the new v1.6.0.8

 

Thanks!

Share this post


Link to post
Share on other sites

@Susi you are right it shows Solved but it hasn't been solved, I still have the same issue though we haven't upgraded yet to the very latest PS but from what you report the issue is still there.

 

It really impacts our business we can't make the top line menu of our shop include the categories we want so it would be nice to have somebody at PS look into this?

 

We've mentioned this 1 May and almost 3 months later this still isn't solved....

Share this post


Link to post
Share on other sites

i this case problem was with

 

 

It was the Customized Quote module. And it doesn't even work!!!  :angry:

and for author of topic problem is solved.

in your case problem may be different...

 

do you use this module?

Share this post


Link to post
Share on other sites

Sorry if I bump such an old thread but... I have NO module installed at all (fresh install) but I have the same issue with NO category tree at all :(

 

Any help pls?

 

PS 1.6.1.4

Share this post


Link to post
Share on other sites

That weird bug pops up all the time... Still not sure what's causing it.

Anyways, I was able to solve it every single time with this little gem: https://www.prestashop.com/forums/topic/93231-ps-v14-category-table-what-is-nleft-et-nright-for/?p=1416856

Thanks mdekker but i can't install this module in my prestashop version. 1.6.1.5

Somebody has other solution?

Share this post


Link to post
Share on other sites

Hi!

 

We have the same bug now in PS 1.6.1.4.

We don't use any module what mentioned before.

 

BTW: To export all data and reinstall the shop solve the problem or I will remake it when I import?

 

Thanks!

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More