Jump to content

Producto con atributos no muestra precio PS1.6


cggfoto
 Share

Recommended Posts

He actualizado PS 1.6.0.5 a PS1.6.0.6 quizas pueda venir por ahi los tiros del problema, el caso es que me he fijado a la hora de incluir articulos con atributos (varios colores en mi caso), que al ver el producto en vista rapida o dentro del producto, el precio que marca es 0.00eur, aunque si lo añades al carrito marca el precio normal que es. Tambien marca el precio normal fuera en la lista de categorias.

 

¿A que puede ser debido? Solo pasa con los productos con atributos.

 

Tambien comentar que nose porque el botón de Añadir a carrito se ha movido hacia abajo él solo.

post-773897-0-80948300-1398348695_thumb.jpg

Share this post


Link to post
Share on other sites

A mi me ocurría lo mismo con la plantilla que usaba en 1.6.0.5, pero con la default funcionaba bien. Cree una plantilla nueva desde el BO con los archivos de la default y luego le copie los css que había modificado de la anterior .

  • Sad 1

Share this post


Link to post
Share on other sites

Copiaste via ftp toda la carpeta defalut bootstrap y metiste los css de la vieja?. Yo es que nose a que puede ser debido. He solucionado el tema de añadir al carro, metiendo el css de la version 1.6.0.6 original y se ha solucionado, pero sigue sin marcar precio, nose que tpl o que archivo es el que se encarga de los atributos y de mostrar precios con los atributos.

Share this post


Link to post
Share on other sites

Primero prueba si te funciona bien activando el tema default bootstrap, si es asi en el Backoffice de Prestashop vas a preferencias-->temas-->añadir tema y eliges la opción "Cree una nueva plantilla" y en la opción "usar este tema como modelo eliges default bootstrap. Las otras opciones las configuras a tu gusto. Después puedes sustituir los archivos css que modificaste de tu tema anterior a este.

Share this post


Link to post
Share on other sites

Hize las modificaciones del parche y si, aparece el precio en los atributos, pero me pasa como a ti, desaparece el boton de añadir al carrito y dice que no hay stock, en los productos con atributos, y sale el precio, pero no se puede desplazaar entre las opcioens de los atributos

Share this post


Link to post
Share on other sites

Primero prueba si te funciona bien activando el tema default bootstrap, si es asi en el Backoffice de Prestashop vas a preferencias-->temas-->añadir tema y eliges la opción "Cree una nueva plantilla" y en la opción "usar este tema como modelo eliges default bootstrap. Las otras opciones las configuras a tu gusto. Después puedes sustituir los archivos css que modificaste de tu tema anterior a este.

¿Has probado ha hacer esto? A mi me funciono bien

Share this post


Link to post
Share on other sites

Hay gente que le ha funcionado aplicando este parche. https://github.com/PrestaShop. A mi se me soluciono lo del precio pero dejaron de funcionarme varias cosas y ademas no desaparecía el botón de añadir al carrito cuando no hay stock.

Antes de modificar nada recuerda guardar una copia del original

Me podrías explicar como se aplica el parche.

 

Gracias  B)

 

Ya he visto como hacerlo. Veo que encima del código pone los archivos que tienes que modificar.

 

:D

Edited by homer74 (see edit history)

Share this post


Link to post
Share on other sites

Me podrías explicar como se aplica el parche.

 

Gracias  B)

 

Ya he visto como hacerlo. Veo que encima del código pone los archivos que tienes que modificar.

 

:D

A mi ni con el parche me funciona :(

 

thump_8904120captura-de-pantalla.png

 

¿Alguién se le ocurre otra idea?

 

Gracias

Edited by homer74 (see edit history)

Share this post


Link to post
Share on other sites

Yo cogi y cargue el tema original del nuevo y le copié los css del antiguo y alguna cosa mas (los mails...y alguna modificacion de algun tpl) y se solucionó. Lo mio habia venido el problema al actualizar de 1.6.0.5 a 1.6.0.6

Share this post


Link to post
Share on other sites

  • 1 month later...

Buenas, yo tenía el mismo problema y lo he solucionado así.

 

You need to edit the file "themes/tutema/product.tpl"

search for
{$group_reduction}

replace it with
{1-$group_reduction}

 

 

Saludos!

  • Like 4

Share this post


Link to post
Share on other sites

Buenas, yo tenía el mismo problema y lo he solucionado así.

 

You need to edit the file "themes/tutema/product.tpl"

 

search for

{$group_reduction}

 

replace it with

{1-$group_reduction}

 

 

Saludos!

 

Gracias compañero, solucionado como has comentado y perfecto todo, incluso un error en lo más vendido sobre tal producto.

Se agradece de verdad, saludos.

  • Like 2

Share this post


Link to post
Share on other sites

  • 2 months later...

Saludos

 

He seguido varios hilos con este mismo problema o muy similares. estoy terminando de montar mi tienda, ingreso ya casi todos los productos y lo tengo al 95%.

Entre los productos que vendo, algunos deben de llevar combinaciones (tallas por ejemplo), creo las combinaciones, se las asocio al producto y contrario a los errores que he leido, a mi me pasa el precio del articulo de 1500 a 8,922,000.00.

Igual que los anteriores hilos, cuando agrego al carrito me sale el precio correcto.

Uso la version 1.6.0.9. Aqui viene el asunto..

Bajo el archivo product.tpl del tema y busco la linea {$group_reduction} y no aparece por ningun lado.. Simplemente no existe..

Asi que no puedo aplicar esta solucion..

 

Alguien tendra alguna idea.. Gracias

  • Like 1

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Saludos

 

He seguido varios hilos con este mismo problema o muy similares. estoy terminando de montar mi tienda, ingreso ya casi todos los productos y lo tengo al 95%.

Entre los productos que vendo, algunos deben de llevar combinaciones (tallas por ejemplo), creo las combinaciones, se las asocio al producto y contrario a los errores que he leido, a mi me pasa el precio del articulo de 1500 a 8,922,000.00.

Igual que los anteriores hilos, cuando agrego al carrito me sale el precio correcto.

Uso la version 1.6.0.9. Aqui viene el asunto..

Bajo el archivo product.tpl del tema y busco la linea {$group_reduction} y no aparece por ningun lado.. Simplemente no existe..

Asi que no puedo aplicar esta solucion..

 

Alguien tendra alguna idea.. Gracias

Hola que tal amigo impactocolor.

 

estoy trabajando con la misma version 1.6.0.9 y trato de solucionar el problema que muestra en 0.00 los precios de los productos con combinaciones...

igual que tu he buscado en el archivo /themes/mitema/product.tpl la linea {$group_reduction} y no la encuentro asi que no puedo realizar el cambio...

 

tu ya lo solucionaste?

 

Algun companero del foro que pueda ayudarnos con la solucion...

 

gracias..

Edited by santysos (see edit history)

Share this post


Link to post
Share on other sites

Hola que tal amigo impactocolor.

 

estoy trabajando con la misma version 1.6.0.9 y trato de solucionar el problema que muestra en 0.00 los precios de los productos con combinaciones...

igual que tu he buscado en el archivo /themes/mitema/product.tpl la linea {$group_reduction} y no la encuentro asi que no puedo realizar el cambio...

 

tu ya lo solucionaste?

 

Algun companero del foro que pueda ayudarnos con la solucion...

 

gracias..

Ya los Solucione aplicando el Parche de esta direccion https://github.com/PrestaShop/PrestaShop/commit/75692e60d3ed91f7fa9fffaa89c668de5f81db81

 

Realice los cambios que ahi explica y se soluciono... 

Se modifican pocas lineas en 4 archivos diferentes...  si desean me piden los 4 archivos modificados para subirlos..

Share this post


Link to post
Share on other sites

  • 1 month later...

Tengo el mismo problema con instalación limpia 1.6.0.9. En productos con atributos, el precio es 0. He probado la solución indicada, que en mi caso solamente modifica products.js y no funciona.¿Alguna solución?

Share this post


Link to post
Share on other sites

  • 1 month later...

Hola amigos,

 

lo primero dar las gracias por la información, ya que he podido solucionar el problema de los precios en productos con combinaciones.

 

Para ello he seguido los pasos que se indican en https://github.com/PrestaShop/PrestaShop/commit/75692e60d3ed91f7fa9fffaa89c668de5f81db81 pero sólo he modificado product.js y product.tpl.

 

Después de modificar los ficheros tenemos que activar "Forzar compilación" en PARAMETROS AVANZADOS/Rendimiento,  cargar la página y volver a dejar la opción por defecto.

 

Mi versión de prestashop es la 1.6.0.9

 

Muchas gracias

Edited by informat (see edit history)

Share this post


Link to post
Share on other sites

  • 1 year later...
  • 1 year later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More