Jump to content
  • 0
juaroal

JavaScript problems in 1.6.0.6?

Question

Hi everyone!

I have a problem with my store and I don't know if it's a particular problem or it's a general problem instead.

The issue is that I'm working in a new store in prestashop 1.6.0.6 with default-bootstrap and suddenly, from one day to another, the JavaScript doesn't work. The image slider doesn't move, the Facebook block doesn't show de Facebook account, the horizontal top menu doesn't show the subcategories, and the theme editor doesn't work also.

After thinking about it I decided to replace the theme's javascript for the javascript of the previous release, the 1.6.0.5.

It worked out apparently, but the price of the combinated products does not work well. All these products have an 0.0€ as price and it doesn't change if I select another color or size, it is always 0.0€, but if I add the product to the cart the price is correct.

What the hell is going on? Is it my problem? Is it a bug?

Thanks in advance!

Regards.

Edited by juaroal

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

It says that the problem is fixed, but if I replace my product.js for that product.js, the product's price is correct but appears a text saying "There isn't stock for that model" and the price doesn't change when I select another size.

 

Thanks!

Share this post


Link to post
Share on other sites
  • 0

It is not fixed from what i can tell, iam not sure why the tracker says so, because otherwise a developer will post a link to the fixed file. The person who has posted some github commit is not a developer. I dont have this problem on a fresh install of prestashop using the default theme, so i think there might be another file which is causing the problem.

Edited by indus

Share this post


Link to post
Share on other sites
  • 0

But I have a fresh instalation with the default theme, default-bootstrap, and I have the problem. Do you have product combinations in your store? Because the problem is with this kind of products.

Share this post


Link to post
Share on other sites
  • 0

Well, i had a fresh install, but only demo products. I edited one of the products and added combinations just to test this bug and it worked fine with different prices showing. You have added more products to the installation? Maybe it happens after that is done.

Edited by indus

Share this post


Link to post
Share on other sites
  • 0

I have in the store more than 300 products and a lot of them have combinations of color and size, so this bug is a big problem before inaugurate the store :(

Share this post


Link to post
Share on other sites
  • 0

You can try replacing the files from the previous version if you need to launch the store, then wait till it is fixed. Have you tried that?

Share this post


Link to post
Share on other sites
  • 0

I have replaced all the javascript files for the javascript files of the previous release, the 1.6.0.5. and the problem is still there and it says that I don't have the product in stock in spite of I have it.

Share this post


Link to post
Share on other sites
  • 0

You should comment on that but tracker, they will usually help you out. Probably will ask for your ftp details etc.

Edited by indus

Share this post


Link to post
Share on other sites
  • 0

 

Thanks, I solved the problem using the javaScript files of the release 1.6.0.5 and following that topic! Yeah!

 

Thank you very much!

 

Regards!

Share this post


Link to post
Share on other sites

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More