Jump to content
ceimedia

migration 1.4 > 1.6 information de paiement non reprises sur les commandes

Recommended Posts

Lors de la migration 1.4 > 1.6.0.6 les informations de paiement n'apparaissent plus dans les fiches commandes...

 

Je crois qu'il y a un une  requête SQL pour régler ce problème mais je ne me rappelle plus laquelle...

 

Quelqu'un peut il me rafraîchir la mémoire ?

 

Merci

  • Like 1

Share this post


Link to post
Share on other sites

Bonjour :-) ,

 

As tu résolu le probleme ? Je rencontre le meme :-(

 

Merci

Bonne journée.

Steph

Share this post


Link to post
Share on other sites

OUI !

 

UPDATE `ps_order_payment` INNER JOIN (
SELECT ps_order_invoice_payment.id_order_payment,ps_orders.reference 
FROM ps_order_invoice_payment LEFT JOIN ps_orders 
ON(ps_order_invoice_payment.id_order = ps_orders.id_order)
) as b
ON(ps_order_payment.id_order_payment = b.id_order_payment)
SET ps_order_payment.order_reference = b.reference
 
source Github prestashop

Share this post


Link to post
Share on other sites

Avec un peu de retard, meci beaucoup ;-)

Je vais pouvoir m'en occupé ce week-end .

Bonne journée,

Steph

Share this post


Link to post
Share on other sites

Oups !! :-) j'ai le message " formulaire incomplet " concernant la requete sql . Il doit y avoir quelques choses que le forum n'a pas gardé lors de l'enregistrement :-)

 

Tu peu me donner le lien direct sur github ? C'est en anglais et je n'arrive pas à le retrouver.

 

Merci beaucoup .

 

Bonne fin de journée :-)

Steph

Share this post


Link to post
Share on other sites

stephforum, le script est complet : si je le copie dans phpmyadmin->sql je peux exécuter cette requette...

 

UPDATE `ps_order_payment` INNER JOIN (
SELECT ps_order_invoice_payment.id_order_payment,ps_orders.reference 
FROM ps_order_invoice_payment LEFT JOIN ps_orders 
ON(ps_order_invoice_payment.id_order = ps_orders.id_order)
) as b
ON(ps_order_payment.id_order_payment = b.id_order_payment)
SET ps_order_payment.order_reference = b.reference

Share this post


Link to post
Share on other sites

Bonjour :-) ,

 

Je viens de refaire plusieurs essais et j'ai toujours cette meme réponse : formulaire incomplet :-( voir piece jointe .

Je ne sais pas ce qu'il se passe .

Merci d'avance poutr ton oeil d'expert ;-)

post-34117-0-65449000-1400180482_thumb.jpg

Edited by stephforum (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More