Jump to content

[SOLVED] Translation tool problem (update doesn’t work)!


Recommended Posts

Hello :-P

When i try to translate something in admin section with translation tool and when i press the update translation button, nothing happens. It doesn't save what i just entered into a field.

Why is that, where is the problem?

Thank you,
Housy

Share this post


Link to post
Share on other sites
  • 3 weeks later...

I have exactly the same problem. Updating a few strings, pressing update, and - quite a lot of the translation is erased! Imported a 164kb language pack, after "editing" the modules once the export was now 115kb.

Share this post


Link to post
Share on other sites

Are you sure you set the permission for the language directories properly?
If Prestashop can't write to the local files, the changes won't be saved.

See if you can translate something that is saved in the Database (like product name or description)

Share this post


Link to post
Share on other sites

You mean directories inside translation map? English, French an my language (Slovenian) they all have 755 permissions, should i set all that to 777 or what exactly should i do?

Thank you,
Housy

Share this post


Link to post
Share on other sites
You mean directories inside translation map? English, French an my language (Slovenian) they all have 755 permissions, should i set all that to 777 or what exactly should i do?

Thank you,
Housy


Different hosts require different permissions, try setting /themes/prestashop/lang (including the files) to 777 and see if it works.

Share this post


Link to post
Share on other sites
You mean directories inside translation map? English, French an my language (Slovenian) they all have 755 permissions, should i set all that to 777 or what exactly should i do?

Thank you,
Housy


Different hosts require different permissions, try setting /themes/prestashop/lang (including the files) to 777 and see if it works.


I tryed to chmod lang directory to 777, including all files within lang directory, but still, when i change some words with translation tool and then i press the update button and again almost all fields are blank.

I also tryed to chmod translations directory, including all subdirectories and files to 777 but still no result.

This problem is killing me, it's really annoying, i have no idea where is the problem.

Housy

Share this post


Link to post
Share on other sites

RESOLVED!!!

Error in log Apache: ALERT – configured POST variable limit exceeded – dropped variable.

Answer: find suhosin.ini (according to system - I got it /etc/php5/conf.d/suhosin.ini and change the values.

from:
suhosin.request.max_vars 200
suhosin.post_vars 200

to (eg.):
suhosin.request.max_vars 3000
suhosin.post_vars 3000

Share this post


Link to post
Share on other sites

Hello to all,

my solution for this problems - when translations don't stick is as follows:

- Like was mentioned in one other post it's problem with Suhosin module, which doesn't allow to post enough variables in one form
- In new file called php.ini you must write this two lines and put php.ini in yoursite/prestashop/admin directory:

suhosin.request.max_vars = 2048
suhosin.post.max_vars = 2048


And that should fix problems with translations not sticking/update not working.

  • Like 1

Share this post


Link to post
Share on other sites
  • 4 weeks later...
  • 3 weeks later...
  • 2 weeks later...

Hi all!

I got exact the same problem, but i can't revolve the problem. Hope someone can help me asap :-/

The following is now the config on our server:
php_admin_value suhosin.post.max_vars 3000
php_admin_value suhosin.request.max_vars 3000
php_admin_value suhosin.post.max_array_depth 3000
php_admin_value suhosin.post.max_array_index_length 3000

I have also tried to put the php.ini file on the admin directory, but this is not working.

Are there maybe a Suhosin restriction somewhere in the system which can adjust? I am looking forward to hearing from you.

Share this post


Link to post
Share on other sites
  • 2 months later...
  • 4 months later...
  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More