Jump to content

Product Pages not showing until page 'refresh'

Recommended Posts

When I get to product level pages, they report this error: (I turned on error reporting and put the site in development mode in the config/defines.inc file)


 Undefined index: unifunc (/public_html/tools/smarty/sysplugins/smarty_internal_templatebase.php, line 561)


This is what I have in line 561: 


I did install the ganalytics module in the last week, which is about when this issue came up.  I don't know if that has anything to do with it.  


Should I replace the tools/smarty/sysplugins/smarty_internal_templatebase file with a new copy from 1.5.4 (version I'm using now)?


Any ideas for how to handle this would be very much appreciated!

Link to comment
Share on other sites

I got the error to go away by deleting a third party googlebase import module I had uploaded and installed last week. I think the module came from a forum posting that started in 2011, so maybe the module caused problems for version 1.5.4.  


I just tried removing the few google oriented modules I had installed recently to see if one of them was causing the problem.  


Thank you for the help, Milos!

Link to comment
Share on other sites

The error came back after I turned the cache back on and changed the template cache from 'force compilation' to 'recompile templates if the files have been updated.'.  Right now products and categories are showing up alright, but that is based on having the cache off and forced compilation.  When I turn change those two settings, I get  


Undefined index: unifunc in /public_html/tools/smarty/sysplugins/smarty_internal_templatebase.php on line 561 Fatal error: Function name must be a string in /public_html/tools/smarty/sysplugins/smarty_internal_templatebase.php on line 561


(I did take my login name out of that since it is in there in the error message right before public_html)  The error goes away and the page shows when you hit 'refresh.'


That doesn't seem right.  For now I can just keep the cache off and force compilation, but I suspect that will slow up the site.

Edited by preserver (see edit history)
Link to comment
Share on other sites

I tried taking down the ganalytics and google sitemap module (those were both in-house prestashop modules), as well as a 3rd party Prestashop XML Exporter, but I still get the same error message.  The error message doesn't show up when the cache is off.  I also emptied 'cache' and 'compile' in cache/smarty.  


I think the only other thing I have uploaded recently is google's code file to verify ownership for either google analytics or merchant/ base. 


Any idea what might be causing the error? 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...