Jump to content

Dominio con www y SSL habilitado, error en acceso a cuenta y links CMS


Go to solution Solved by v116v,

Recommended Posts

Hola a todos, tengo instalada una versión 1.5.6.2 en la que con el dominio con www no deja acceder a la cuenta de cliente, da errores de acceso. Además también he habilitado SSL y en el carro no se muestran los términos del servicio, aparece la ventana facybox con error 404, lo mismo ocurre con cualquier enlace del CMS.

 

Alguien sabe como hacer que funcione todo correctamente con URL amigables, SSL y www???

 

Muchas gracias a todos, un saludo.

Share this post


Link to post
Share on other sites
  • Solution

Hola a todos, tengo instalada una versión 1.5.6.2 en la que con el dominio con www no deja acceder a la cuenta de cliente, da errores de acceso. Además también he habilitado SSL y en el carro no se muestran los términos del servicio, aparece la ventana facybox con error 404, lo mismo ocurre con cualquier enlace del CMS.

 

Alguien sabe como hacer que funcione todo correctamente con URL amigables, SSL y www???

 

Muchas gracias a todos, un saludo.

Este error es producido si se elimina del menu "Preferencias->Seo y Urls->Formato de los enlaces" la palabra content/ en el formato de url del CMS, añadiendo un formato de subdirectorio aun que no sea con "content/" soluciona el problema de error 404 con urls amigables en los enlaces CMS.

Un saludo.

Edited by v116v (see edit history)

Share this post


Link to post
Share on other sites
  • 3 months later...

prestashop 1.6.0.8

 

I Found the solution without modify anything in the presta files.

 

enable ssl and force the ssl on all pages but uncheck html purifier library (very important). you could enable it after insert the image.

 

then go on CMS (exemple: about us) the image who's already there when you install prestashop work well even in ssl so you have to copy how they wrote the code. 

 

<img title="cms-img" src="../img/cms/cms-img.jpg" alt="cms-img" width="370" height="192" />

 

replace by your name image 

 

<img title="your name image" src="../img/cms/your name image.jpg" alt="your name image" width="370" height="192" />

 

write this way on the little popup window [insert/edit image] right after uploaded and chose the image from your file manager.

 

 source             ../img/cms/your name image.jpg

 image description   ....

 dimensions             ...

 

Save it and go to enable the html filter purifier if you done to put new images.

Now it should work. your image is here and your page is still SSL.

 

ps: you'll have to disable html purifier library every time you need to add a new picture from your file manager otherwise it will appear this famous question mark instead of the image and your page won't be SSL

 

It tooks 2weeks to found that, I hope you'll appreciate this post. That's the most annoying bug on prestashop, I don't even know why the Presta team didn't fix that so far!!!!????

 

 

I still have a problem with the homeslider who's disappear when running on Safari, need to refresh the page every time I come back on the home page!!! if somebody have the Solution I'll appreciate to know it ;) thanks

 

vince

Share this post


Link to post
Share on other sites
  • nadie locked this topic
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More