Jump to content
Ago

Prestashop 1.6.0.5 čeština

Recommended Posts

Ahoj,  mám problám s diakritikou, 1.6.0.5

Při najetí na Kategorie v patičce stránky se špatně zobrazuje čeština v popisu (viz foto)

Také při použití Modulu pro export zboží do služby zbozi.cz (Zboži v2.02 - by PrestaHost.eu)

se vytvoří feed se špatnou diakritikou v popisu zboří:

                          ""Chyba parsování XML: Dokument není dobře zformátován
                          Adresa: http://obchod.zlatnictvi-aa.cz/xml/zbozi_heureka.xml
                          Řádek 7, sloupec 20: Stř�brn� prsten lebka ."""

Diky za každou radu.

diakritika.jpg

Share this post


Link to post
Share on other sites

Nepřišel někdo na to kde to opravit?

Další kde je špatně zobrazovaná čeština  je  v editorech po přepnutí na "source code".

Děkuji za radu.

 

editor.jpg

Share this post


Link to post
Share on other sites

Po daních se tím začnu zabývat a hledat řešení ( Možná Pavel jestli už na nějaké nepřišel .. ale tohle není chyba presty , hold to je daň za náš jazyk a jeho možností )

Share this post


Link to post
Share on other sites

Řešil jste někdo Font v FO? Naše znaky Ú, Ů, É, Š, Č, Ř vypadají tučněji než okolní znaky :blink:

Share this post


Link to post
Share on other sites

to je obecně problém s češtinou ... dej si třeba toto zobrazit v androidu a nebudeš už tam mít žádný znaky.

Možná změna fontu by pomohla, nebo jiné řešení. Uvidíme...   

Share this post


Link to post
Share on other sites

Řešil jste někdo Font v FO? Naše znaky Ú, Ů, É, Š, Č, Ř vypadají tučněji než okolní znaky :blink:

zhruba na 52. řádku v themes/default-bootstrap/header.tpl najdete tento kód:

nejde mi sem ten kód vložit a nevím proč, prostě je to řádek s odkazem na font na google

nahraďte jej tímto:

<link href="http://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,400,300,600,700&subset=latin,latin-ext" rel="stylesheet" type="text/css">

A odstraníte tak špatně zobrazenou diakritiku ve front-office (tučně zobrazené znaky s diakritikou).

Edited by vybornak (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Toto je částečné řešení ... ale velice pomohlo .  Přesto na goglle chrome má (bych řekl) jiný font a formátovaný text nejde ( ale alespoň jede již na mobilních zařízení. ) 

 

je to posun kus vpřed ...  děkujeme vybornaku .

Share this post


Link to post
Share on other sites
administrace\themes\default\css\admin-theme.css
@import url("//fonts.googleapis.com/css?family=Open+Sans:400,300,600&subset=latin,latin-ext");
@import url("//fonts.googleapis.com/css?family=Ubuntu+Condensed&subset=latin,latin-ext");

Zatím jsem to moc nezkoušel ale vypadá to OK.

 

BTW některé řetězce nejsou přeložené, nevíte někdo o kompletním překladu??

Edited by haunter (see edit history)

Share this post


Link to post
Share on other sites

1.6 ale nemá v themes slozku default paklize jsem si ji tam neprinesl z 1.5 

Share this post


Link to post
Share on other sites

Editor tinyMCE špatně ukládá do databáze (diakritiku).

Pokud naexportuji zboží přes importCSV je popis a krátký popis uložen v databázi dobře , ale pokud ho znovu edituji a uložím, je již v databázi uložen špatně. Stejné je to u popisu kategorií.

Má někdo stejný problém?

Pokud někdo ví,co s tím, moc děkuji za radu.

Share this post


Link to post
Share on other sites

zhruba na 52. řádku v themes/default-bootstrap/header.tpl najdete tento kód:



nejde mi sem ten kód vložit a nevím proč, prostě je to řádek s odkazem na font na google

nahraďte jej tímto:



<link href="http://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,400,300,600,700&subset=latin,latin-ext" rel="stylesheet" type="text/css">

A odstraníte tak špatně zobrazenou diakritiku ve front-office (tučně zobrazené znaky s diakritikou).

Je podobnym sposobom mozne opravit spatnu diakritiku aj v BO?

Share this post


Link to post
Share on other sites

Ano, stačí si v rootu najít složku admin(číslo)/themes/default/template/header.tpl a tam vložit stejný kód. :)

Share this post


Link to post
Share on other sites

Editor tinyMCE špatně ukládá do databáze (diakritiku).

Pokud naexportuji zboží přes importCSV je popis a krátký popis uložen v databázi dobře , ale pokud ho znovu edituji a uložím, je již v databázi uložen špatně. Stejné je to u popisu kategorií.

Má někdo stejný problém?

Pokud někdo ví,co s tím, moc děkuji za radu.

 

Zde je odkaz na opravu http://forum.c4.cz/prestashop-1-6-0-5-diakritika-v-textech-popisech-t4833.html

Share this post


Link to post
Share on other sites

 v souboru js/tinymce.inc.js přidejte např. za řádek:
 

Kód:
extended_valid_elements : "em[class|name|id]",

následující řádek:

Kód:
entity_encoding : "raw",
 
To to jsem zkoušel ale nechce mi toto fungovat... dal jsem to hned pod horní řádek ... možná to mám špatně ..

Share this post


Link to post
Share on other sites

Zkus dát kurzor na konec řádku 25 (v souboru js/tinymce.inc.js) ,odentruj a nakopíruj tu opravu  entity_encoding : "raw", ulož to a v BO  pak znova přepiš špatně zobrazovanou Kategorii a mělo by to být OK
 

Share this post


Link to post
Share on other sites

Zkusím, ale je pravda ze jsem to testoval ne na kategorii ale primo v info o produktech (krátký popis tuším)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More