Jump to content

[solved] addon's suggesting incompatiable native module upgrades


PrestaHeroes.com
 Share

Recommended Posts

for the last several months we have seen on the forum multitudes of shop owners who have made the mistake of clicking the suggested module upgrade from their back office.

 

this has resulted in unpredictable results..

 

for example blocksearch upgrade is using 1.6 media functions that do not exist in 1.5.

 

I do not want to tell ps their business but if users have troubles like this they will lose all trust in purchasing paid solutions.

 

There must be refinement of the suggested upgrades to ensure that the suggestion will actually work for their ps version.

 

 

SOLVED:

http://forge.prestashop.com/browse/PSCFV-11886

  • Like 4

Share this post


Link to post
Share on other sites

I just visited my admin and saw a load of updates available for all sorts of modules. Obviously I thought they wouldn't be recommending updates that didn't work with my version, how wrong I was. I'm now going through errors fixing them one by one, what a pain in the ass.

It's truly unbelievable that a professional shopping cart provider would do something like this, it's broken my live shop and put me out of business until I get it fixed, thanks prestashop.

I'm really going to have to look at a different solution, this sort of thing is so easy to avoid but they obviously just don't care about their users.

  • Like 3

Share this post


Link to post
Share on other sites

I just visited my admin and saw a load of updates available for all sorts of modules. Obviously I thought they wouldn't be recommending updates that didn't work with my version, how wrong I was. I'm now going through errors fixing them one by one, what a pain in the ass.

It's truly unbelievable that a professional shopping cart provider would do something like this, it's broken my live shop and put me out of business until I get it fixed, thanks prestashop.

I'm really going to have to look at a different solution, this sort of thing is so easy to avoid but they obviously just don't care about their users.

 

 

yes prestashop, that sucks. You bricked my shop which normally gets about 1000 visits a day.

to offer software upgrade without even checking if this work on the customer software or without any warning mesage about modules compatibility is more than outrageous.

I got the backup. Many others dont....

 

 
  • Like 2

Share this post


Link to post
Share on other sites

Hi,

 

you are right, i made all updates in a Prestashop 1.5.6.2 test site and now i have an error on the home page :

 

 

Fatal error: Call to undefined method Media::addJsDef() in /homepages/xx/xxxxxxx/htdocs/xxxxx/1562/modules/blocksearch/blocksearch.php on line 77

Share this post


Link to post
Share on other sites

That was absolutely unacceptable, you click on a "recommended update" and your site was bricked.

 

Prestashop guys, you HAVE to fix that, version control exists till 10 years......its unbelievable that the "auto updater" doesn't check for versions and compatibilites...this is a terrible bug and i think many prestashop sites will be down in the next days....with people crying on this forum..

 

Im evaluating Prestashop versus Magento in the last weeks, and i'm happy with prestashop till yesterday, very easy to use (too easy maybe)

Now this is +100 points for Magento....

 

I Think one of "official" accounts MUST GIVE some apologies and explaination here.

  • Like 2

Share this post


Link to post
Share on other sites

That was absolutely unacceptable, you click on a "recommended update" and your site was bricked.

 

Prestashop guys, you HAVE to fix that, version control exists till 10 years......its unbelievable that the "auto updater" doesn't check for versions and compatibilites...this is a terrible bug and i think many prestashop sites will be down in the next days....with people crying on this forum..

 

Im evaluating Prestashop versus Magento in the last weeks, and i'm happy with prestashop till yesterday, very easy to use (too easy maybe)

Now this is +100 points for Magento....

 

I Think one of "official" accounts MUST GIVE some apologies and explaination here.

 

 

I apologize for not addressing this issue sooner.  We as moderators started seeing this issue a couple months ago and  failed  to properly bring to attention of the ps team who I'm sure if made aware sooner would have resolved.  Sorry.

  • Like 2

Share this post


Link to post
Share on other sites

glad to read this :)

so, modules  for prestashop 1.5 will not be developed anymore, and 1.5 goes into oblivion - sad, but true ;)

it's time to 1.6 !!!

 

Yes prestashop 1.5.x.x goes into oblivion soon, as prestashop team and devs will not update and support it anymore -_-

All attention now is turned to the new born prestashop 1.6, but that doesn't mean  prestashop 1.5 is dead yet

a great number of merchants are still using prestashop 1.5 for a big number of reasons, the transition must  be smooth

we cannot rush and force users/merchants to drop everything (modules, themes that are now incompatible with 1.6)

in my personal opinion, prestashop 1.6 has a great design and features, but needs to be more mature and stable,

and most of the problems that I have in my prestashop 1.5.x.x are now solved, thanks to the community.

In prestashop 1.6 I'm sure that I will encounter new problems to be solved, and new configurations and customizations do be made :wacko:

 

So for now lets fix the problems one by one, no rush to jump  B)

 

PS: by the way, for everyone that are getting incompatible modules updates suggestions

make sure to follow this updated topic with the last info: http://www.prestashop.com/forums/topic/317315-updated-26-03-2014-new-suggested-modules-updates-for-15xx-are-broken/

 

 

regards

Edited by ALMAJ (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Yes prestashop 1.5.x.x goes into oblivion soon, as prestashop team and devs will not update and support it anymore -_-

For our 50 PrestaShop customers, there is currently no reason to update to 1.6. And (unfortunately) if it breaks their current 1.5 template, they will never update as long as their shop runs. In my view this situation is comparable to Windows XP :)

  • Like 1

Share this post


Link to post
Share on other sites

And I have to add: Think about it, there were some very good reasons why Microsoft supported and updated Windows XP for over 10 years. The same reasons can be valid for PS 1.5.x too

Well in this case 10 years is way too much time to support prestashop 1.5.x.x

I completely understand that the devs must have time to focus primarily on their new baby

but again they must not forget and abandon prestashop 1.5.x.x completely, they must support as good and long as they can.

And... who in the world still using windows XP? :huh:  

ok, ok, I admit I have an old machine that still runs windows XP :rolleyes:

Edited by ALMAJ (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

1.5 is not going anywhere...much like 1.4 shops...so no need to mourn just yet.

 

True, I have a 1.3 shop that is finally going to 1.5 this weekend and no immediate plans to go to 1.6.

  • Like 1

Share this post


Link to post
Share on other sites

a great number of merchants are still using prestashop 1.5 for a big number of reasons, the transition must  be smooth

we cannot rush and force users/merchants to drop everything (modules, themes that are now incompatible with 1.6)

 

wow, wow, wow.... one second please.... why you says that 1.5 modules and themes are no longer compatibile with 1.6...? :lol:

 

Let me quote a few lines from Prestashop official newsletter sent a few days to ENTIRE community and still available online here:

http://www.prestashop.com/blog/en/answers-to-your-questions-about-prestashop-1-6/?utm_source=newsletter&utm_medium=e-mail&utm_campaign=newsletter-EN&utm_content=questions-1-6

 

 

1. I want to convince my clients to upgrade to 1.6 but they are hesitant about upgrade problems. How can I convince them that it will be safe?

The main idea you want to tell your clients is that 1.6 has minimal changes to the files and database. This means that the core code between 1.5 and 1.6 is virtually the same. Upgrades from 1.5 to 1.6 are smooth.

 

 

rubbish.... the only word with which I agree is: virtually  :lol:

 

 

1. How can I tell if my theme and modules are compatible with 1.6?

a) Modules: All PrestaShop developed modules are compatible. Simply by installing the module, if no error appears then the module is compatible

 

two times rubbish.... Prestashop developed modules just bricked hundreds of stores

 

1. How can I tell if my theme and modules are compatible with 1.6?

Themes: All 1.5 themes are compatible with version 1.6 (....)

 

 

even more rubbish

I wonder why all of my 5 shops each using different 1.5 theme are not compatibile with 1.6... why others got the same problem and why @ALMAJ (PS team member) said here that 1.5 themes are not compatibile with 1.6 :-) ??

 

 

What a mess.

Edited by a_smith (see edit history)

Share this post


Link to post
Share on other sites

Hello, 

One week ago, in order to be able to have modules both in the ZIP and updated via the Addons API, we decided to move the modules from the main repository on Github to separate repositories, 

Unfortunately, the default compatibility version for these modules was 1.5, even if the modules were not compatible. We changed this compatibility on Addons on Monday. But reverted this compatibility restriction again the next day on an automatic CRON job on the xml file.

 

We are extremely sorry failing to update the comparability properly, and for failing to communicate with all of you that the notifications to update was made in error. We know that this failure led to many stores having incompatible modules.

Now, we are including a compatibility check directly in the module code so that this problem will not happen again., so Addons will not be able to change the compatibility by itself.

 

If you upgraded a module during this time and are having issues with your store, download the 1.5.x zip on PrestaShop.com, copy the content of the module from the zip and overwrite the existing folder, do not delete the broken module or you will lose the configuraiton that you have.

 

Also, to fix the faulty update notifications, pleases remove the XML files in /config/xml/. The new files that will be generated will be clean.

 

Again, we are sincerely sorry for this mistake and have taken steps to ensure that this never happens again. Please let me know via PM if you have any trouble getting your store running after upgrading your core modules, I'll do my best to help.

Regards,

  • Like 2

Share this post


Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More