Jump to content

[EU Legal] Modul zur Verbesserung der Rechtssicherheit für PrestaShop 1.6.0.6 - 1.6.0.14


Recommended Posts

  • Replies 865
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Das war wirklich nicht sarkastisch gemeint, sondern als eine freundliche (na ja, vielleicht etwas ironische  )  Aufforderung, zunächst einmal die Forenregeln zu beherzigen und nicht vorschnell zuvor b

Hallo,   ich finde es verwunderlich, dass PrestaSchlumpf hier eine Situation verallgemeinert, die womöglich nur ihn und einen Koleggen betrifft, die erfolglos alleine einen Shop aufgesetzt haben. Da

Hallo zusammen,   vielen Dank für Ihr Interesse an dem Modul. Ich versuche hier, einige Fragen zu beantworten.    "Das EU-Legal- Modul ist der Nachfogler von germaNext?"   Nein. Das ist ein ganz

Posted Images

Hi Julia,
es war eine Erstinstallation der aktuellen Version. Um das mit den rechten noch einmal nachvollziehbar zu machen, setze ich jetzt alles komplett noch einmal neu auf.

Liege ich da richtig: PS Installation wie üblich, dann EU-Legal- und alle gewünschten Bezahlmodule (bei mir Banküberweisung und PayPal) aus dem Github manuell ungezippt in den Ordner Module hochladen, dann übers Backend aktivieren/konfigurieren, oder?

Danke und Gruß

 

 

Share this post


Link to post
Share on other sites

Hi Julia,

es war eine Erstinstallation der aktuellen Version. Um das mit den rechten noch einmal nachvollziehbar zu machen, setze ich jetzt alles komplett noch einmal neu auf.

 

Liege ich da richtig: PS Installation wie üblich, dann EU-Legal- und alle gewünschten Bezahlmodule (bei mir Banküberweisung und PayPal) aus dem Github manuell ungezippt in den Ordner Module hochladen, dann übers Backend aktivieren/konfigurieren, oder?

 

Danke und Gruß

Ja, alles richtig. Die Paymentmodule müssten reinstalliert werden, falls diese vorher installiert wurden. Das trifft bei einer frischen Installation eigentlich nur auf bankwire zu.

Share this post


Link to post
Share on other sites

Also ich schaffe es auch nicht, hab den ganzen ordner mit override auf 777 gesetzt und kommt immer noch die meldung: Das folgende Modul konnte nicht installiert werden:

  • eu_legal :
        The method getLegalInstance in the class ParentOrderController is already overriden.

Habe jetzt die version 1.6.0.8 von PS. Wollte die neue 1.0.0.0 version probieren, habe den modul wie üblich hochgeladan (FTP) und den modul reinitialisiert, danach kamm diese fehler meldung. Denke gerade ob ich alles neu installieren soll? Was meint Ihr, wie man sonst den ParentOrdnerController wieder beschreibbar machen kann?

Share this post


Link to post
Share on other sites

versuchs mal damit:

den override-ordner auf dem server löschen und dann

den original-ordner override aus dem installationspaket hochladen

 

gruss

Share this post


Link to post
Share on other sites

Also ich schaffe es auch nicht, hab den ganzen ordner mit override auf 777 gesetzt und kommt immer noch die meldung: Das folgende Modul konnte nicht installiert werden:

  • eu_legal :

        The method getLegalInstance in the class ParentOrderController is already overriden.

Habe jetzt die version 1.6.0.8 von PS. Wollte die neue 1.0.0.0 version probieren, habe den modul wie üblich hochgeladan (FTP) und den modul reinitialisiert, danach kamm diese fehler meldung. Denke gerade ob ich alles neu installieren soll? Was meint Ihr, wie man sonst den ParentOrdnerController wieder beschreibbar machen kann?

 

 

Das liegt daran, dass das Modul leider immer noch nicht bei der Deinstalltion sauber seine eigenen Overrides löscht und daher bei einer Neuinstallation an den eigenen Restbeständen scheitert.

 

In deinem Fall musst du jetzt erst mal folgende Datei löschen: /override/controllers/front/ParentOrderController.php

 

Den kompletten Inhalt des Verzeichnisses Override solltest du nur dann löschen, wenn du dir ganz sicher bist, dass nicht irgend ein anderes Modul hier etwas abgelegt hat!

Share this post


Link to post
Share on other sites

Ich habs anders gemacht. Habe in den ordner /override/controllers/front/ der datei ParentOrderController.php die schreib rechte 777 gegeben und dan in der selben datei alles gelöscht was mit dem eu legal zu tun gehabt.. Dann den EU-Legal auf installieren geklickt und das modul zu installieren. Dann die schreibrechte auf dem stardard wert gesetzt (664).

 

Saludos

Share this post


Link to post
Share on other sites

Sorry, hab da ein wenig den Überblick verloren, was gibt es noch für Probleme mit dem EU- Legal Modul? Ist es jetzt für den offiziellen Gebrauch bereit? Werden es morgen noch durch den Anwalt laufen lassen, mal schauen, was er dazu sagt?

Share this post


Link to post
Share on other sites

Habe leider auch mit der neuesten Version, die ich eben runtergeladen habe, noch das gleiche Problem wie bereits hier beschrieben:

http://www.prestashop.com/forums/topic/316947-eu-legal-neues-modul-zur-verbesserung-der-rechtssicherheit-f%C3%BCr-prestashop-16/page-13?do=findComment&comment=1724430.

 

Im 5-Step-Checkout wird eine andere Zusammenfassung (ohne AGB und Widerruf!) angezeigt mit merkwürdigem Verhalten bei Auswahl des Versanddienstes als im OPC (s. Post):

 

5-Step-Checkout:post-452242-0-77169000-1405341528_thumb.jpg

 

One-page-checkout: post-452242-0-18293800-1405341539_thumb.jpg

 

Ist das jetzt ein Versehen oder ein zarter Hinweis, dass EU-legal zwingend den OPC verlangt?

Share this post


Link to post
Share on other sites

Habe leider auch mit der neuesten Version, die ich eben runtergeladen habe, noch das gleiche Problem wie bereits hier beschrieben:

http://www.prestashop.com/forums/topic/316947-eu-legal-neues-modul-zur-verbesserung-der-rechtssicherheit-f%C3%BCr-prestashop-16/page-13?do=findComment&comment=1724430.

 

Im 5-Step-Checkout wird eine andere Zusammenfassung (ohne AGB und Widerruf!) angezeigt mit merkwürdigem Verhalten bei Auswahl des Versanddienstes als im OPC (s. Post):

 

5-Step-Checkout:attachicon.gif5-step-checkout.jpg

 

One-page-checkout: attachicon.gifOne-page-checkout.jpg

 

Ist das jetzt ein Versehen oder ein zarter Hinweis, dass EU-legal zwingend den OPC verlangt?

Hallo Rainer,

 

ich kann die beschriebenen Probleme leider nicht reproduzieren. Kann ich mir das bei dir direkt anschauen? Das wäre ganz toll!

Share this post


Link to post
Share on other sites

Hallo Julia,

 

klar, kannst du. Ruf mich einfach an. Teamviewer wartet schon. 

 

EDIT: Wie mit Julia bereits besprochen - nach Übertragung eines frischen 1.6.0.8-Templates ist alles ok; das Template war nicht aktualisiert worden, weil ich die Option nicht angeklickt hatte. Die Radiobuttons werden nun korrekt angezeigt, die AGB-Bestätigung ist aktiv. Das Anklicken der AGB aktiviert den Kaufen-Button, der auf die Bestätigungsseite weiterleitet!

Also mit 1.6.0.8 und EU-legal ist alles im grünen Bereich. :)

Edited by eleazar (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Hab noch was für die interne Feature / bug Liste.

 

Wenn man den Grundpreis einstellt und der artikel varianten hat, darf der Grundpreis nicht einfach der grundpreis des Basis artikels sein er muss sich dynamisch je nach variante und auswirkung auf das gewicht errechnet werden ;).

 

Oder irre ich mich hier ?  Ist mir gerade aufgefallen wegen eines anderen Eintrags hier im Forum.

Share this post


Link to post
Share on other sites

Nur zur Sicherheit: Ich habe alles installiert, PS 1.6.0.8 frisch und EU-legal etc. aus dem Github. alles da.
Nun werden aber die EU-Legal-spezifischen Inhalte nicht angezeigt und ich bekomme bei der Konfig des Moduls EU-Legal folgende Fehler:

 

Es gibt einige fehlende Hooks!
Theme biosanysix:

  • Template product.tpl:
    • Hook displayProductDeliveryTime
    • Hook displayProductPriceBlock
  • Template product-list.tpl:
    • Hook displayProductDeliveryTime
    • Hook displayProductPriceBlock
  • Template products-comparison.tpl:
    • Hook displayProductDeliveryTime
    • Hook displayProductPriceBlock
  • Template shopping-cart-product-line.tpl:
    • Hook displayProductDeliveryTime

Ich gehe davon aus, dass ich jetzt die Hook-Elemente aus der Default-Bootstrap product.tpl in die product.tpl meines Themes einsetzen und ggfls die IDs und Classes anpassen muss, richtig?

EDIT: ja so geht es. Ist zwar richtig mühsam, aber ne andere Möglichkeit gibt e wohl nicht.

Edited by cagoo (see edit history)

Share this post


Link to post
Share on other sites

Hi,

 

ich habe ein Problem in der Kategorie auf weiteren Seiten was wohl mit der "Facettennavigation/blocklayered" zutun hat.

 

Gehe ich auf eine Kategorie, zeigt er wie gewollt beim mouseover die Lieferzeit an. Klicke ich aber auf Seite 2 (oder danach wieder auf Seite 1) wird oben in der Adressleiste ein "#" hinzugefügt. Ab jetzt ignoriert er gekonnt '<span class="delivery-info">'. Somit wird die Lieferzeit und alles was noch da drinnen steht nicht angezeigt.

 

Switche ich dagegen auf List-view (oder auch wieder zurück zum Grid) funktioniert es.

 

 

Hat jmd eine Idee?

Share this post


Link to post
Share on other sites

Hallo. Habe das modu geladen.

Bin im Adminbereich auf module-module hinzufügen

Dann war es fertig.

Wo finde ich dann alles.

War die installation richtig?

Share this post


Link to post
Share on other sites

Ich würde gerne nen kleinen Shop in Zukunft irgendwann mal auf PS1.6 mit EULegal umstellen, wie istn da so der aktuelle Stand? Kann man das schon soweit alles einsetzen oder gibts momentan noch zuviele Kinderkrankheiten, die erst ausgebessert werden müssen? Hier liest man ja noch so einiges, was noch nicht richtig funktioniert oder dass erst noch auf irgendn weiteres PS-Update gewartet wird. ^^

 

Gibts eigentlich schon irgendwo ne Anleitung, was man bei der Installation alles beachten muss?

Share this post


Link to post
Share on other sites

Hallo zuammen,

 

auch ich bin neu hier und will mit meinem Online Shop im September starten. 

 

Mir gefällt prestashop sehr gut aber leider habe auch ich etwas Bauchschmerzen was EU Legal angeht. 

 

Ich habe das Modul installiert und bekomme auch eine positive Meldung. Nur leider ist danach das Modul in der Modul-List nicht auffindbar. (Filter aktiv und installiert etc. wurde getestet). Ich nutze Version 1.6.0.8 und bisher das default-bootstrapTemplate.

 

Gibt es eine Anleitung? Oder wird das offizielle Modul bis September fertig sein?

 

Mit der Suchfunktion im Forum habe ich dazu nichts gefunden.

 

Vielen Dank im Voraus. 

 

Stefan

Share this post


Link to post
Share on other sites

Hallo zuammen,

 

auch ich bin neu hier und will mit meinem Online Shop im September starten. 

 

Mir gefällt prestashop sehr gut aber leider habe auch ich etwas Bauchschmerzen was EU Legal angeht. 

 

Ich habe das Modul installiert und bekomme auch eine positive Meldung. Nur leider ist danach das Modul in der Modul-List nicht auffindbar. (Filter aktiv und installiert etc. wurde getestet). Ich nutze Version 1.6.0.8 und bisher das default-bootstrapTemplate.

 

Gibt es eine Anleitung? Oder wird das offizielle Modul bis September fertig sein?

 

Mit der Suchfunktion im Forum habe ich dazu nichts gefunden.

 

Vielen Dank im Voraus. 

 

Stefan

Ja das geht mir ähnlich wo finde ich das Modul ? 

 

Danke 

 

Björn 

Share this post


Link to post
Share on other sites

Das Modul ist fertig und kann hier geladen werden https://github.com/EU-Legal/modules

 

Eine Anleitung gibt es noch nicht, wird aber derzeit vorbereitet. 

 

Warum es nicht mehr in der Liste ist, kann man pauschal nicht beantworten. Ein installiertes Modul kann nicht einfach so verschwinden. Es muss ein Grund haben und dieser liegt ganz bestimmt nicht an dem Modul. 

 

Viele Grüße

Share this post


Link to post
Share on other sites

Hallo Julia,

 

vielen Dank für deine Antwort. 

 

Ich habe jetzt folgendes getestet.

 

Auf einer ungenutzten Domain habe ich die aktuelle Prestashop Software 1.6.0.8 (download heute) neu installiert.

Danach habe ich mit dem Modul cleaner die Produktdaten etc. gelöscht. Sonst wurde nicht geändert oder bearbeitet.

Direkt im Anschluss habe ich das Moduls_Master unter "Module" hinzugefügt. Der Modul Counter (oben:Installierte Module, Module deaktiviert, Modul-Updates verfügbar) ist von 67 auf 68 gestiegen. 

 

Nur ist auch bei diesem Shop in der Modul Liste (unterer Bereich) nichts zu finden. Egal welchen Filter man einstellt. Bin auch alle Kategorien (Alle, Bestellvorgang,etc) durch gegangen. Ich habe mit firefox und chrome getestet. 

 

Könnte es nicht doch ein Bug sein? Oder muss ich vorher irgendwas einstellen? Ich hoffe ihr könnt mir helfen. 

 

Viele Grüße

 

Stefan 

Share this post


Link to post
Share on other sites

Hallo Julia,

 

vielen Dank für deine Antwort. 

 

Ich habe jetzt folgendes getestet.

 

Auf einer ungenutzten Domain habe ich die aktuelle Prestashop Software 1.6.0.8 (download heute) neu installiert.

Danach habe ich mit dem Modul cleaner die Produktdaten etc. gelöscht. Sonst wurde nicht geändert oder bearbeitet.

Direkt im Anschluss habe ich das Moduls_Master unter "Module" hinzugefügt. Der Modul Counter (oben:Installierte Module, Module deaktiviert, Modul-Updates verfügbar) ist von 67 auf 68 gestiegen. 

 

Nur ist auch bei diesem Shop in der Modul Liste (unterer Bereich) nichts zu finden. Egal welchen Filter man einstellt. Bin auch alle Kategorien (Alle, Bestellvorgang,etc) durch gegangen. Ich habe mit firefox und chrome getestet. 

 

Könnte es nicht doch ein Bug sein? Oder muss ich vorher irgendwas einstellen? Ich hoffe ihr könnt mir helfen. 

 

Viele Grüße

 

Stefan 

Hallo,

 

Moduls_Master ist eine Sammlung von Modulen: EU Legal und kompatible Payment Module. Nun muss natürlich jedes Modul einzeln gepackt und hochgeladen werden. Also eu_legal.zip, bankwire.zip u s.w.

 

Gruß

Share this post


Link to post
Share on other sites

Hallo,

 

Moduls_Master ist eine Sammlung von Modulen: EU Legal und kompatible Payment Module. Nun muss natürlich jedes Modul einzeln gepackt und hochgeladen werden. Also eu_legal.zip, bankwire.zip u s.w.

 

Gruß

 Vielen Dank für die schnelle Antwort. 

 

Gruß

 

Stefan

Share this post


Link to post
Share on other sites

Habe im Modul Eu-Legal die Mail-Designs angepasst. Dennoch bekommen die Kunden bei der Bestellbestätigung die Basis Mail von Prestashop. Was kann ich tun, dass sich das ändert? Wie gesagt ist alles überschrieben und vom Text her und den Bildern ausgetauscht.

 

Würde mich über Lösungen freuen ;)

Share this post


Link to post
Share on other sites

Hier eine Video Anleitung

 

https://www.youtube.com/watch?v=ANHDJO532Hs

 

Das mag ja gut gemeint sein, ist aber total irreführend, da weder die EU Payment API aktiviert wird, noch die angepassten Payment Module installiert und aktiviert werden (stattdessen werden offenbar lediglich die regulären Payment Module erst deinstalliert und anschließend erneut installiert).

Share this post


Link to post
Share on other sites

Shop endlich wieder online und eingerichtet

aber:

Die Lieferzeit wird mal wieder nicht angezeit

 

eu-legal und zahlmodule sind resettet

lagerverwaltung aktiv und lieferzeiten eingetragen

 

was hab ich in der hektik übersehen?

 

gruss

kulli

Share this post


Link to post
Share on other sites

Die Ordnerstruktur ist wirklich so verworren und aufgeblasen, dass es nach einem Problem mittlerweile mehrere Stunden dauert den Cache per FTP zu löschen.

Wegen der Lieferzeitangabe:

Die lässt sich im Nachhinein leider nicht mehr ändern.
Wenn man einen Artikel wieder auf lieferbar setzt, steht trotzdem `Nicht lieferbar` da (Nicht der Button, der funktioniert) und wenn man eine Artikel auf Ausverkauft setzt, steht dementsprechend immer noch `Lieferzeit 1-3 Werktage` da. Erst wenn man den Artikel kopiert, lässt sich das ändern.

Unter `Neue Produkte` und den Suchergebnissen wird die Lieferzeit gar nicht angezeigt.

_______

Mittlerweile lässt sich das EU-Legal auch nicht mehr installieren, trotz geleertem Cache.

Das folgende Modul konnte nicht installiert werden:

  • eu_legal :
        The method getTaxesRate in the class Carrier is already overriden.
        The method getProducts in the class Cart is already overriden.
        The method getContentFromId in the class CMS is already overriden.
        The method Send in the class Mail is already overriden.
        The method getProducts in the class Manufacturer is already overriden.
        The method saveTaxCalculator in the class OrderDetail is already overriden.
        The method __construct in the class Product is already overriden.
        The method getBestSales in the class ProductSale is already overriden.
        The method getProducts in the class Supplier is already overriden.
        The method sendConfirmationMail in the class AuthController is already overriden.
Edited by alvin1978 (see edit history)

Share this post


Link to post
Share on other sites

Bei mir wird nach der installation der warenkorb nicht mehr angezeigt.

module master hab ich heute heruntergeladen und installiert

welche version, welches template, auch cache geleert, anderen Browser zum testen genommen? stimmen die Systemvorraussetzungen?

eventuell nochmal resettet undsoweiter

gruss

Share this post


Link to post
Share on other sites

Prestashop version 1.6.0.8 - von eu legal hab ich die letzten von github mit dem ganzen paket geladen

cache geleert in verschiedenen browsern getestet, immer noch das selbe resultat.

ich hab sogar einen komplett nackten shop aufgesetzt und eu legal als erstes modul geladen, gleiches ergebniss.

 

ich habe unter config/defines.inc.php

define('_PS_MODE_DEV_', false); auf true gesetzt und folgende meldungh bekommen

 

Parse error: syntax error, unexpected T_STRING, expecting T_FUNCTION in /override/controllers/front/ParentOrderController.php on line 56

die systemvoraussetzungen müssen passen, da es ja ohne eu legal auch funktioniert hat

Edited by papa_chicco (see edit history)

Share this post


Link to post
Share on other sites

Hallo zusammen, 

 

bei mir das gleiche Problem: Nach Aktivierung des Plugins geht der Klick in den Warenkorb ins Leere bzw. einfach nur eine weiße Seite. Prestashop und EU-Legal-Modul jeweils in der neusten Version, getestet mit Google Chrome.

 

Ich wollte eigentlich überlegen von Shopware auf Prestashop umzusteigen, aber ohne das Rechtliche besteht natürlich keine Chance. Schade, dass das Modul nicht funktioniert. Gibt es schon einen Fix?

 

Viele Grüße

Share this post


Link to post
Share on other sites

Willkommen im Forum,

 

bei vielen anderen funktionierts, Du solltest nicht so schnell aufgeben;

was hast Du denn zur Problembehebung schon alles probiert?

eine weise Seite deutet ja eher auf ein anderes Problem als die hier geschilderten eu-legal-problemchen.

 

gruss

Share this post


Link to post
Share on other sites

Hallo, danke sehr. Du hast Recht, so schnell will ich nicht aufgeben, im Gegenteil. Ich finde das Shopsystem sehr schön und würde es gerne erstmal für ein kleines Projekt einsetzen, solange ich nicht riskiere ganz großen Ärger zu bekommen  :)

 

Ich habe jetzt dem Ordner "override" die Rechte 777 verpasst, und siehe da: es klappt. Aber im Checkout (letzter Schritt) siehts bei mir so aus:

presta.jpg

  

Ist das so eigentlich rechtssicher? Ich kenne mich nicht aus, daher Frage ich, aber ich dachte man muss NACH der Zahlungsauswahl noch alles andere ändern können, und außerdem muss vor dem letzten Kauf-Button doch eine Gesamtübersicht aller gekauften Artikel nochmal angezeigt werden, oder? Vermutlich irre ich mich darin, ich war es bisher von Shopware nur so gewohnt.

Das Standard-Design von Prestashop finde ich übrigens klasse, genau das richtige für den Einstieg bis man sich was individuelleres leisten kann :)

Danke sehr!

Share this post


Link to post
Share on other sites

Ist das so eigentlich rechtssicher? Ich kenne mich nicht aus, daher Frage ich, aber ich dachte man muss NACH der Zahlungsauswahl noch alles andere ändern können, und außerdem muss vor dem letzten Kauf-Button doch eine Gesamtübersicht aller gekauften Artikel nochmal angezeigt werden, oder? Vermutlich irre ich mich darin, ich war es bisher von Shopware nur so gewohnt.

 

interessante frage;

vor der Zahlungsauswahl kann man ja noch alles ändern

wäre ein tip für die mitlesenden Entwickler das vielleicht in den one-page checkup so mit aufzunehmen für künftige Versionen.

(wenigstens eine Bestellübersicht.)

 

bei den Gambio-shops kriegt man am Schluss zwar auch noch eine Artikelübersicht, aber ändern kann man da auch nichts mehr.

 

gruss

Share this post


Link to post
Share on other sites

Hallo, danke sehr. Du hast Recht, so schnell will ich nicht aufgeben, im Gegenteil. Ich finde das Shopsystem sehr schön und würde es gerne erstmal für ein kleines Projekt einsetzen, solange ich nicht riskiere ganz großen Ärger zu bekommen  :)

 

Ich habe jetzt dem Ordner "override" die Rechte 777 verpasst, und siehe da: es klappt. Aber im Checkout (letzter Schritt) siehts bei mir so aus:

presta.jpg

  

Ist das so eigentlich rechtssicher? I

Hallo,

 

die Darstellung auf dem Screenshot ist selbstverständlich nicht rechtssicher. Zeigt aber nur, dass das Modul an der Stelle nicht greift. Ich nehme an, dass die Einstellung "EU Payment API" ausgeschaltet ist. 

 

Gruß

Share this post


Link to post
Share on other sites

Hallo,

 

die Darstellung auf dem Screenshot ist selbstverständlich nicht rechtssicher. Zeigt aber nur, dass das Modul an der Stelle nicht greift. Ich nehme an, dass die Einstellung "EU Payment API" ausgeschaltet ist. 

 

Gruß

 

 

Sofern du die oberste Einstellung meinst, dann ist diese aktiviert. Muss noch etwas anderes getan werden?

 

Grüße

Weil dadrunter steht ja auch "Aktivieren Sie diesen Modus für EU Payment Module. Beachten Sie, dass hierzu spezielle Bezahlmodule erforderlich sind." 

 

Muss also noch irgendwas anderes eingestellt werden zur Aktivierung der vollen Rechtssicherheit?

Share this post


Link to post
Share on other sites

Zusatz: Auch im One-Page-Checkout muss ja trotzdem die Zahlungsmethode viel weiter oben kommen, denn sie könnte ja auch zusätzliche Kostenenthalten (Nachnahme oder so). Standard sollte sein, dass die Reihenfolge geändert wird, die Zahlungsart und Versandart oben und dann die endgültige Auflistung aller Artikel und Kosten ganz unten unmittelbar vor "Kaufen". 

Share this post


Link to post
Share on other sites

Zusatz: Auch im One-Page-Checkout muss ja trotzdem die Zahlungsmethode viel weiter oben kommen, denn sie könnte ja auch zusätzliche Kostenenthalten (Nachnahme oder so). Standard sollte sein, dass die Reihenfolge geändert wird, die Zahlungsart und Versandart oben und dann die endgültige Auflistung aller Artikel und Kosten ganz unten unmittelbar vor "Kaufen". 

So ist es auch. Wenn das bei dir anders ist, dann funktioniert das Modul aus irgendeinem Grund nicht richtig. 

Share this post


Link to post
Share on other sites

Tja, ich habe mal bei dem Modul "Reset" durchgeführt, und siehe da: Nichts funktioniert mehr. Will sagen: Klick auf den Warenkorb führt wieder auf eine weiße Seite. Was mache ich nur falsch? Habe ich eine falsche Version des Moduls installiert? Wo kriege ich eine richtige Version her?
 

Die Prestashop-Installation ist völlig nackt und unbeeinflusst gewesen. Muss vor der Installation des Moduls vielleicht noch irgendwas anderes eingestellt werden?

Share this post


Link to post
Share on other sites

Deaktiviere mal alle cache optionen und lad die seite mit  STRG+F5.

Wie sieht es den mit der Dokumentation aus? Ist halt wirklich schwer hier im Thread die richtigen Informationen raus zufinden um das Modul und die Payment Module richtig zuinstallieren.

Wuerde ja selber eine gute Anleitung schreiben wenn ich wuesste was genau gemacht werden muss.

Und dann natuerlich eine detailierte Liste was alles genau wie geandert wird wenn man das Modul installiert damit man auch nachvollziehen kann ob alles richtig installiert ist.

Bin gerne bereit daran mit zuarbeiten.

Edited by thepan (see edit history)

Share this post


Link to post
Share on other sites

ich habe jetzt versand, bezahlung und einige artikel angelegt, wenn ich mich nun als kunde registriere sehe ich nur noch den kundenbereich. wenn ich auf den shop gehen will kommt eine weisse seite mit mienem log, das wars.

man kann auch nichts mehr in den warenkorb legen.

cache ist aus

Share this post


Link to post
Share on other sites

Hallo,

bei mir kommt nach der installation des EU Legal Moduls auch nur eine weisse Seite nach klick auf den Warenkorb.

Hab schon den Cache geleert und den Ordner override auf 777 gesetzt aber nicht hilft.

Auch nach deaktivieren des Moduls ist kein Warenkorb mehr vorhanden egal ob was drin ist oder nicht.

Weiß echt nicht mehr weiter. Kennt jemand die Lösung?

 

Firebug meldet folgendes

GET bestellung
500 Internal Server Error
 

 

Prestashop 1.6.0.8 Standard Template

 

Grüße

Share this post


Link to post
Share on other sites

Ich habe auch mal wieder alles platt gemacht und dann komplett neu. Diesmal klappt alles, der checkout ist jetzt mit Buttonlösung, alles wie es sein soll.

 

Naja, fast alles, siehe dieser Ausschnitt eines Screenshots:

 

agbsatz.jpg

 

Da stimmt doch etwas mit dem Satz nicht. Mindestens "einverstanden." fehlt. Wie kann ich das korrigieren?

Share this post


Link to post
Share on other sites

Und noch ein kleiner Fehler:

Wenn man die Anzeige der MwSt deaktiviert (wie es für die Kleinunternehmerregelung notwendig ist), dann wird einem das Design der abschließenden Bestellübersicht etwas zerschossen:

 

agbsatz-ku.jpgSiehe die Zeile mit "Gesamt" und rechts der Einschub.

Kein funktionaler, aber ein Designfehler.

Share this post


Link to post
Share on other sites

Uebersetzung kannst du im Backoffice "Lokalisierung"---"Uebersetzung" aendern. Musst bei "Programmteil" natuerlich "Installierte Module" auswaehlen und Deutsches Sprachpaket bei "Ihre "Sprache". 

Share this post


Link to post
Share on other sites

so ich habe das Error logging eingeschaltet. Folgen kommt dann bei Aufruf des Warenkorbes..?

 

Parse error: syntax error, unexpected 'parent' (T_STRING), expecting function (T_FUNCTION) in /www/htdocs/w01039b1/svayk/override/controllers/front/ParentOrderController.php on line 56

 

und in der Zeile 56 der OrderController.php steht:   parent::init();
 

Edited by shopalogon (see edit history)

Share this post


Link to post
Share on other sites

so ich habe das Error logging eingeschaltet. Folgen kommt dann bei Aufruf des Warenkorbes..?

 

Parse error: syntax error, unexpected 'parent' (T_STRING), expecting function (T_FUNCTION) in /www/htdocs/w01039b1/svayk/override/controllers/front/ParentOrderController.php on line 56

 

und in der Zeile 56 der OrderController.php steht:   parent::init();

 

Ich wuerde mal raten das die Installation nicht vollstaendig richtig ist. Eventuell genau diese Datei nochmal neu hochladen.

Share this post


Link to post
Share on other sites

ist der mem-cache eingeschaltet(erweiterte Einstellungen-Leistung ganz unten?) dann schalte den aus und lass ihn aus

cache leeren

wenn das nicht hilft:

den kompletten cache ausschalten (ccc)

 

 

Welches Hosting-paket, bei welchem Provider ?

 

gruss

Edited by kulli (see edit history)

Share this post


Link to post
Share on other sites

So ist es auch. Wenn das bei dir anders ist, dann funktioniert das Modul aus irgendeinem Grund nicht richtig. 

 

So ist es auch. Wenn das bei dir anders ist, dann funktioniert das Modul aus irgendeinem Grund nicht richtig. 

Dann hat es bei mir auch noch nie funktioniert....

 

post-434580-0-28761900-1406441203_thumb.png

Edited by kulli (see edit history)

Share this post


Link to post
Share on other sites

unddie max_input_time und.........

 

passt alle snicht hier rein - moderator bitte ab 364 abtrennen und nach installation und einrichtung verschieben

danke

Share this post


Link to post
Share on other sites

Hallo,

es gibt einige Serverkonfigurationsanleitungen für Prestashop im Netz. Ich finde diese http://www.prestatraining.com/12-tips-to-optimise-your-php-ini-file-for-prestashop/ am aufschlussreichsten. Eine Scriptlaufzeit von 1 Minute sollte für den Regelbetrieb ausreichen. Nur ob der Installationsprozess sauber abläuft ....:/

Viele Grüße

Share this post


Link to post
Share on other sites

Die Installation schein ja sauber zu laufen, denn so lange wie ich eu legal nicht installiere läuft alles.
ich kann bestellen, mich einloggen ausloggen usw. nach der installation von eu legal geht dann nichts mehr, obwohl alle voraussetzungen anscheinend passen.

selbst offline bekomme ich das teil nicht zum laufen

Share this post


Link to post
Share on other sites

Uebersetzung kannst du im Backoffice "Lokalisierung"---"Uebersetzung" aendern. Musst bei "Programmteil" natuerlich "Installierte Module" auswaehlen und Deutsches Sprachpaket bei "Ihre "Sprache". 

 

Und wo genau kann ich den falschen deutschen Satz korrigieren?

 

An der von dir genannten Stelle taucht der Satz gar nicht auf, siehe dieser Screen:

 

eulegal-uebersetzung.jpg

 

"AGB" taucht da nur einmal auf und nicht im Rahmen des gesuchten falschen Satzes. Außerdem finde ich, dass Modul sollte keinen solchen Fehler mitbringen, sondern diesen gleich von Haus aus korrigieren, meine ich. Ist ein tolles Modul, solche Kleinigkeiten sind sicher schnell korrigiert.

Share this post


Link to post
Share on other sites

Ich habe es auch nicht hinbekommen. Der Shop war schon komplett fertig.

Es hat nur noch das Rechtssicherheitsmodul gefehlt.

Was kann man tun? das Modul abschalten hilft nichts, da auch nach der Deaktivierung des Moduls der Warenkorb ncht mehr funktioniert?

 

@papa_chico...was meinstest Du mit Zahlungsmodule desinstalliert...? welche Module? und gehts dann bei Dir?

 

Vielen Dank

Share this post


Link to post
Share on other sites

vielleicht gibt das einen Hinweiss auf den Fehler?

Unter dem Peis steht noch einmal ohne Link in der Textgröße des Preises zzgl Versand

siehe Screenshot. Allerdings nicht bei jedem Aufruf der Seite?

 

screen.jpg

 

Wie ist das mit dem Artikelgewicht. Wenn eingeschaltet zeigt der Wert nur das zusätzliche Gewicht an.

Also wenn eine Option 200g mehr wiegt zeigt das Tool nur das Mehrgewicht an und nicht das Gesamtgewicht?

Wo kann man eingentlich ein Grundgewicht eines Artikels eingeben, damit überhaupt berechnungen bzgl. des Gewichtes erfolgen können?

Grüße

Share this post


Link to post
Share on other sites

Ich habe es auch nicht hinbekommen. Der Shop war schon komplett fertig.

Es hat nur noch das Rechtssicherheitsmodul gefehlt.

Was kann man tun? das Modul abschalten hilft nichts, da auch nach der Deaktivierung des Moduls der Warenkorb ncht mehr funktioniert?

 

@papa_chico...was meinstest Du mit Zahlungsmodule desinstalliert...? welche Module? und gehts dann bei Dir?

 

Vielen Dank

ich hab die zahlungsmodule alle deinstalliert und neu installiert, aber das war nicht die lösung, sondern lösche einmal den cache im shop selbst und danach den Browsercache, so hat es bei mir nun funktioniert

Share this post


Link to post
Share on other sites

wie schon gesagt läuft bei mir nun alles, allerdings hab ich noch zwei kleinigkeiten die mich ein bisschen stören.

1. wird bei mir neben dar zahlungsart überweisung statt "Vorkasse" "Pay by Bank Wire" angezeigt

2. ich würde gerne Paypal as standard bezahlsystem auswählen

Share this post


Link to post
Share on other sites

den Cache zu löschen hab ich schon versucht ohne Ergebnis.

Ich habe gerade die Zugriffsrechte der ParrentOrderController.php von 664 auf 755 gesetzt und dann ist der Warenkorb wieder  da. Allerdings mit einer neuen Fehlermeldung

 

Notice: Undefined property: OrderController::$_legal in /www/htdocs/w01039b1/svayk/override/controllers/front/OrderController.php on line 138

 

nach erneutem Aufruf des Warenkorbes war alle wieder beim alten...

Parse error: syntax error, unexpected 'parent' (T_STRING), expecting function (T_FUNCTION) in /www/htdocs/w01039b1/svayk/override/controllers/front/ParentOrderController.php on line 56

 

Ich habe dann die Schreibrechte der Datei ParrentOrderController.php erneut geprüft und komischer Weise hat sich die Datei selbständig wieder auf 664 zurückgestellt?

 

Also hat das Problem wohl mit der Einstellung der Dateirechte zu tun..oder?

 

Wo bekommt man eine Übersicht welche Ordner welche Rechte haben müssen?

Es waren auch keinerlei Infos zu dem EU Legal Modul dabei.

 

Hab nur das für Prestshop 1.4 u 1.5 gefunden.

http://www.prestashop.com/forums/topic/134187-tippserver-mindestanforderung-und-minimal-konfiguration-fur-prestashop/?hl=paypal%20&fromsearch=1

 

Ich habe 1.0.6.8 mit Basistemplate

Hoster ist Allinkl.

 

Grüße

Share this post


Link to post
Share on other sites

Und wo genau kann ich den falschen deutschen Satz korrigieren?

 

An der von dir genannten Stelle taucht der Satz gar nicht auf, siehe dieser Screen:

 

eulegal-uebersetzung.jpg

 

"AGB" taucht da nur einmal auf und nicht im Rahmen des gesuchten falschen Satzes. Außerdem finde ich, dass Modul sollte keinen solchen Fehler mitbringen, sondern diesen gleich von Haus aus korrigieren, meine ich. Ist ein tolles Modul, solche Kleinigkeiten sind sicher schnell korrigiert.

 

Die Uebersetzung ist da nicht unter eu-legal sondern unter "Order Payment". Die Uebersetzung ist da aber vollstaendig also liegts am modul.

Also Ich habe das Problem nicht. Bei mir wird der Text richtig angezeigt. Hast du die CMS alles verlinkt oder im eu legal modul wenigstenst die cms erstellt?

Edited by thepan (see edit history)

Share this post


Link to post
Share on other sites

Und noch ein kleiner Fehler:

 

Wenn man die Anzeige der MwSt deaktiviert (wie es für die Kleinunternehmerregelung notwendig ist), dann wird einem das Design der abschließenden Bestellübersicht etwas zerschossen:

 

agbsatz-ku.jpgSiehe die Zeile mit "Gesamt" und rechts der Einschub.

 

Kein funktionaler, aber ein Designfehler.

Es fehlt die Zuordnung für Widerrufsbelehrung. Unter Einstellungen zu definieren. 

Share this post


Link to post
Share on other sites