Jump to content

Обновление с Prestashop 1.5 на Prestashop 1.6


Recommended Posts

Добрый день ВСЕМ!

 

Собираюсь обновить свой магазин с Prestashop 1.5.6.1 до Prestashop 1.6.х. Хочу поинтересоваться у более опытных кто уже совершыл этот шаг - на сколько сложно на этот раз проходит переход на новую версию?

И второй вопрос - работают ли модули от вер. 1.5 на версии 1.6 ? И, если да/нет, то какие?

 

Заранее благодарен!

Думаю что для многих участников форума очень важен данный вопрос.

Share this post


Link to post
Share on other sites

а куда торопиться то и ставить рабочий магазин? лучше дождаться когда новую версию обкатают и подправят, а потом самому пробовать и тестировать.

Share this post


Link to post
Share on other sites

Спасибо Pir!

 

Разумное решение. Но хочется узнать мнение и тех кто уже сделал обновление до версии 1.6.

 Какие новые возможности?

 Всё ли работает?

и т.д.

 

Ждём Ваших коментариев!

Я думаю это важно для многих.

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Обновил до в.1.6.0.5 - основное работает, но уже обнаружил ошибку:

При нажатии в Админде кнопки Modules->Modules выдаёт ошибку:
 

[PrestaShopException]

Property Carrier->delay is empty
at line 878 in file classes/ObjectModel.php

872.
873.                 $message = $this->validateField($field, $value, $id_lang);
874.                 if ($message !== true)
875.                 {
876.                     if ($die)
877.                         throw new PrestaShopException($message);
878.                     return $error_return ? $message : false;
879.                 }
880.             }
881.         }
882.

  • ObjectModelCore->validateFieldsLang - [line 296 - classes/ObjectModel.php]
  • ObjectModelCore->getFieldsLang - [line 480 - classes/ObjectModel.php]
  • ObjectModelCore->add - [line 191 - classes/Carrier.php] - [2 Arguments]
  • CarrierCore->add - [line 964 - modules/socolissimo/socolissimo.php]
  • Socolissimo::createSoColissimoCarrierSeller - [line 1468 - modules/socolissimo/socolissimo.php] - [1 Arguments]
  • Socolissimo->runUpgrades - [line 84 - modules/socolissimo/socolissimo.php] - [1 Arguments]
  • Socolissimo->__construct - [line 1211 - classes/module/Module.php]
  • ModuleCore::getModulesOnDisk - [line 1237 - controllers/admin/AdminModulesController.php] - [3 Arguments]
  • AdminModulesControllerCore->initContent - [line 180 - classes/controller/Controller.php]
  • ControllerCore->run - [line 373 - classes/Dispatcher.php]
  • DispatcherCore->dispatch - [line 54 - admin/index.php]

 

Може есть какие соображения?

P.S.
Предыдущая PrestaShop v.1.5.6.1 работает без каких-либо явных проблем.

Edited by sassbar (see edit history)

Share this post


Link to post
Share on other sites

  • 4 weeks later...

Переносить с прежней версии на 1.6 не пробовал, но что могу сказать о новой — это революционная версия. На протяжении всех предыдущих мы наблюдали постепенный изменения. Здесь взяли и поменяли разом всё. Нет, в основе-то тот же престашоп, но радикально улучшено всё, что можно было улучшить. Особенно по части понятности и в удобстве админки для новичка. Короче, на мой взгляд, в сравнении с прежними версиями престашопа — небо и земля.

 

Если кто-то только начинает работать с престашопом, не стоит начинать со стабильной версии прежнего. Престашоп 1.6 — это уже другой престашоп. Надо начинать сразу с него. Стабильно работающая версия появится не позднее, чем через месяц. Так что все резоны — начинать прямо с шестой версии...

Edited by Dimitri Yelquin (see edit history)
  • Like 2

Share this post


Link to post
Share on other sites

  • 4 months later...

Обновил до в.1.6.0.5

Как обновили? Использовали ли "1-Click Upgrade"?

У меня что-то никак не выходит обновить. Буду пробовать установить чистую 1.6, а потом импортировать категории и товары.

Может кто подскажет более простой способ перенести магазин с 1.5 на новую 1.6?!

  • Like 1

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Переносить с прежней версии на 1.6 не пробовал, но что могу сказать о новой — это революционная версия. На протяжении всех предыдущих мы наблюдали постепенный изменения. Здесь взяли и поменяли разом всё. Нет, в основе-то тот же престашоп, но радикально улучшено всё, что можно было улучшить. Особенно по части понятности и в удобстве админки для новичка. Короче, на мой взгляд, в сравнении с прежними версиями престашопа — небо и земля.

 

Если кто-то только начинает работать с престашопом, не стоит начинать со стабильной версии прежнего. Престашоп 1.6 — это уже другой престашоп. Надо начинать сразу с него. Стабильно работающая версия появится не позднее, чем через месяц. Так что все резоны — начинать прямо с шестой версии...

ты когда нибудь угомонишься ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More