Jump to content

Recommended Posts

Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /homez.145/evolutiop/www/classes/MySQL.php on line 91

Warning: Invalid argument supplied for foreach() in /homez.145/evolutiop/www/classes/Search.php on line 254
Array
(
[0] => MySQL server has gone away
[1] => Array
(
[0] => (1,'private')
[1] => (1,'lesson')
[2] => (1,'1h30')
[3] => (1,'progress,')
[4] => (1,'discover,')
[5] => (1,'benefit!')
[6] => (1,'instructors')
[7] => (1,'here')
[8] => (1,'packages')
[9] => (1,'with')
[10] => (1,'discounted')
[11] => (1,'liftpasses')
[12] => (1,'available')
[13] => (1,'lessons')
[14] => (1,'hire')
[15] => (1,'equipment')
[16] => (1,'special')
[17] => (1,'tariffs')
[18] => (1,'before')
[19] => (1,'making')
[20] => (1,'your')
[21] => (1,'reservation')
[22] => (1,'please')
[23] => (1,'contact')
[24] => (1,'check')
[25] => (1,'availability')
[26] => (1,'people')
)

)

END



Quelqu'un comprend ?

Share this post


Link to post
Share on other sites
  • 1 month later...
  • 3 weeks later...

voici mon erreur exact :

Lorsque je clic sur Enregistrer lors de l'ajout d'un produit j'ai cette erreur qui s'affiche :

Array
(
   [0] => MySQL server has gone away
   [1] => Array
       (
           [0] => (1,'gourmette')
           [1] => (1,'argent')
           [2] => (1,'maille')
           [3] => (1,'figaro')
           [4] => (1,'étoilée')
           [5] => (1,'19cm')
           [6] => (1,'24grs')
           [7] => (1,'gravure')
           [8] => (1,'comprise')
           [9] => (1,'35507g')
           [10] => (1,'gravée')
       )

)

END

Share this post


Link to post
Share on other sites

J'ai beau chercher mais n'ayant pas touvhé au code je voit pas pk la boutique ferait clôturer la connexion au serveur... Je comprend pk je perd la connexion comme cela :s

Share this post


Link to post
Share on other sites
p'tre que le server est configurer pour avoir une connexion de 10ms, et que ton script met 15ms a s'executer !

Pourtant j'ai rien modifié et ça marchais avant.

C'est lors de l'ajout d'un nouveau produit que j'ai cette erreur.

Share this post


Link to post
Share on other sites
  • 1 month later...

As tu trouvé une solution Alexmp4? je me retrouve avec la même erreur avec un produit qui génère une longue requete (certainement la source du problème) le seul truc c'est que ce produit ca fait 5 mois que je l'ai ajouté et qu'il me fait l'erreur depuis hier seulement :s

Si qqun a une astuce ;)

Merci

Share this post


Link to post
Share on other sites

Oh non toujours pas de solutions...

Je voit avec mon hébergeur pour qu'il augmente le temps de connexion de la base de donnée...

Mais a mon niveau je sais pas quoi faire.

Peut être un problème dans ta base de donnée...

Share this post


Link to post
Share on other sites

A priori les requete de Prestashop sont trop longue.

Voici la réponse d'OVH. J'en appel aux editeurs de Prestashop pour nous eclairer...


Cependant commme indiqué précédent votre site doit généré des requetes trop lourde qui sont coupée par notre serveur.

Voici quelques exemple de requetes longues (mais non coupées) générés par votre site:

# User@Host: xxxxxx[xxxxxx] @ [10.10.10.10]
# Query_time: 20 Lock_time: 0 Rows_sent: 0 Rows_examined: 0
use xxxxxx;
INSERT INTO `bdd_connections_page` (`id_connections`,`id_page`,`time_start`) VALUES ('65779','363','2009-12-30 15:22:13');



UPDATE comptes SET parties='468' WHERE id= 116;
# User@Host: xxxxxx[xxxxxx] @ [10.10.10.10]
# Query_time: 50 Lock_time: 0 Rows_sent: 0 Rows_examined: 0
use xxxxxx;
INSERT INTO `bdd_connections_page` (`id_connections`,`id_page`,`time_start`) VALUES ('0','19','2009-12-24 17:18:29');


Pour ces 2 requetes cela à mit 20 et 50 secondes à être réalisé.
Apparement vous utilisez un system de statistique. Je vous conseil déja de désactiver ce systéme.


Je vous confirme donc pour moi que le soucis provient des requetes effectués sur notre serveur.


De l'aide s'il vous plait...

[Certaines infos ne regardent personne :) - Edit par Patric]

Share this post


Link to post
Share on other sites

tu peux la vider après suivant l'hébergement tu est peut être limité en taille de la bdd et comme la elle est atteinte tu peux plus rien faire dans sur la bdd donc tes erreurs viennent peut etre de la.

Share this post


Link to post
Share on other sites

Bon j'ai fait un grand ménage dans ma base de donnée notamment au niveau des stats... la base est passé de 124Mo a 18Mo !

Mais le problème de l'ajout des produits est toujours impossible... Idem lors de la reconstruction de l'index de recherche. J'obtient ceci :

Array
(
   [0] => MySQL server has gone away
   [1] => Array
       (
           [0] => (1,'gourmette')
           [1] => (1,'argent')
           [2] => (1,'plaque')
           [3] => (1,'ovale')
           [4] => (1,'maille')
           [5] => (1,'figaro')
           [6] => (1,'12grs')
           [7] => (1,'gravure')
           [8] => (1,'comprise')
           [9] => (1,'2056g')
           [10] => (1,'gravée')
       )

)

END




D'ou cela peut il venir ?

Un probleme dans la Base de donnée ?
Si oui comment je pourrais faire... J'ai analysé, réparé, optimisé ma BDD mais toujours rien...

D'ailleurs les mots qui apparaissent dans l'erreur corespondent surement aux mots clefs... mais lequels ! :s

Share this post


Link to post
Share on other sites

Bon et bien, j'ai transféré ma base de donnée chez 1et1 et tout réinstallé...

Et ça remarche.
A mon avis les paramètre d'OVH empêche le fonctionnement de prestashop lorsque les bases de données sont trop remplies...

Temps de connexion trop court.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More