Jump to content
Sign in to follow this  
dbaker

(SOLVED) Permalinks (Friendly URLs) Broken Site

Recommended Posts

Hello,
I recently installed Prestashop onto my MediaTemple grid service. I got it up and running pretty easily, with it working "out of the box" with MediaTemple. I think you the install procedure could learn something from Wordpress (no CHMODing - I'm dreading the PS update process already!) but otherwise it was fine, until I turned on the "Friendly URLs". It's not clear if I need to generate a .htaccess file before I click submit or after, so I did it before hand in a new window. Then I clicked submit. Now I get nothing but blank pages on my test site (http://shop.rickanddrew.com/) and when I try to access admin.

Anyway to recover from this? I tried deleting my .htaccess file from my root, but it didn't help.

Thanks for your help,
Drew

Share this post


Link to post
Share on other sites

What about test-change "PS_REWRITING_SETTINGS" in database table "configuration" using phpAdmin?

Not sure if it helps..

Share this post


Link to post
Share on other sites

Hey KIH999,
Thanks for the help.

It says this:

SQL query:

SELECT *
FROM `db19021_shop`.`ps_configuration`
WHERE (
`id_configuration` LIKE '%PS_REWRITING_SETTINGS%'
OR `name` LIKE '%PS_REWRITING_SETTINGS%'
OR `value` LIKE '%PS_REWRITING_SETTINGS%'
OR `date_add` LIKE '%PS_REWRITING_SETTINGS%'
OR `date_upd` LIKE '%PS_REWRITING_SETTINGS%'
)
LIMIT 0 , 30

And then this:

id_configuration = 4 name = PS_REWRITING_SETTINGS value = 1


What do I change? I tired setting value = 0, but it did nothing.

Thanks again!

Share this post


Link to post
Share on other sites

It's 1 or 0, so if zero don't fix it, put it to 0.. (That turn it off)

Sorry, it was a long shot. :(

It seems like NOTHING is done at all on your page, try to upload a php-script to see if it pharse PHP..

Like this.. test.php

<?php
echo "hello from my shop";
?>

Share this post


Link to post
Share on other sites

Maybe you can get a hint if you turn on display_errors in config.inc.php


@ini_set('display_errors', 'on');

Share this post


Link to post
Share on other sites

OK I fixed it. I changed the PS_REWRITING_SETTINGS value to 0 in myphpadmin. Then for some reason my host had reset the domain to use PHP4, so I set it back to PHP5 again and it works!

Now, what's the correct procedure for enabling Friendly URLs? (If any Dev's read this, take a look at how Wordpress does it, it's much more simpler).

Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More