Jump to content

Recommended Posts

Bonsoir,

 

Après plusieurs tentatives auprès de OVH et de Prestashop (qui se renvoient la balle), je viens solliciter votre aide.

 

Voici mon problème et le message sur Prestashop :

 

"Le mode de réécriture d'URL (mod_rewrite) n'est pas activé sur votre serveur, ou il est impossible de vérifier la configuration. Pour utiliser les URLs réécrites, vous devez activer ce mode."

 

Comment dois-je m'y prendre et comment pourrai-je résoudre définitivement ce problème ?

 

Cordialement

 

 

Ps: Désolé, je n'ai pas pris le temps de vérifier si ce Topic existait.

Share this post


Link to post
Share on other sites

Salut,

 

S'il s'agit bien d'une activation du mod_rewrite, c'est à dire le module apache mod_rewrite, alors ça ne concerne pas PrestaShop mais bien OVH.

 

Maintenant j'ai du mal à croire qu'ovh propose des hébergements sans le mod_rewrite d'actif.

Est-ce un serveur dédié ?

 

A+

Share this post


Link to post
Share on other sites

.....merci pour la réponse "éclaire" !!

 

 

A priori, c'est bien un serveur dédié.

 

Encore merci et A+

Share this post


Link to post
Share on other sites

Alors il faut stoper apache :

 

sudo /etc/init.d/apache2 stop

 

si c'est apache > v2, créer un lien symbolique ou copier le fichier

 

etc/apache2/mods-available/rewrite.load

 

vers

 

etc/apache2/mods-enabled/rewrite.load

 

Puis relancer apache :

 

sudo /etc/init.d/apache2 restart
 

A+

Share this post


Link to post
Share on other sites

Re-Bonsoir......

 

Ce n'est pas gagné mais je vais tenter de résoudre mon problème grâce à vous.

J'espère quand résolvant ce soucis mon référencement sera meilleur car actuellement c'est la cata.

 

 

Encore tous mes remerciements pour ces informations.et ...... surtout pour votre réactivité !!

 

Je vous dis à bientôt

Thierry

Share this post


Link to post
Share on other sites

Bonsoir.....

 

Alors là, rien à faire, je cale .....

 

Où trouve-t-on "Apache" ....sur OVH ?

 

 

Merci pour l'aide

Bonne soirée !!

Share this post


Link to post
Share on other sites

Salut,

 

.....merci pour la réponse "éclaire" !!

 

 

A priori, c'est bien un serveur dédié.

 

Encore merci et A+

 

êtes-vous sur que ça soit un serveur dédié ?

Share this post


Link to post
Share on other sites

....... apparemment Non, je ne le trouve pas dans la liste "serveur dédié" de mon Manager.

Share this post


Link to post
Share on other sites

Je m'incruste...

je suis chez ovh également, serveur mutu. Si vous êtes bien sur un mutu, le mode rewrite est activé par défaut chez ovh.

Le message prestashop :"Le mode de réécriture d'URL (mod_rewrite) n'est pas activé sur votre serveur, ou il est impossible de vérifier la configuration. Pour utiliser les URLs réécrites, vous devez activer ce mode." est un message "automatique".

 

Normalement, vous pouvez utiliser la réécriture url. Si jamais ça ne fonctionne pas correctement, allez dans "preferences->SEO&URL's" et jouez avec l'option apache multiview...

 

Bon courage

Share this post


Link to post
Share on other sites

Bonjour,

 

Une incrustation ...peut être positive et je vous en remercie.

 

Qu'entendez-vous par " avec l'option apache multiview " car.... plus je joue moins j'ai de visite (cela devient même catastrophique) .

 

En tout cas, merci beaucoup pour votre aide......

 

 

 

Cordialement

Share this post


Link to post
Share on other sites

dans le menu SEO&URL, il y a une option "apache multiview" que vous pouvez activer ou désactiver. La laisser activée provoque parfois des soucis dans la réécriture, dans ce cas désactivez la. Normalement, tout devrait fonctionner...

 

Bon courage (et bon référencement ;) )

Share this post


Link to post
Share on other sites

Si je peux me permettre.......Dernière petite question:

 

Faut-il également "Désactiver le module apache "mod_security"  et  cliquer NON sur "Rediriger automatiquement vers l'URL canonique"  sachant que j'ai des soucis avec le Template ?

 

 

Mais en tout cas......encore un Grand MERCI pour votre aide. Cela me fait un "casse tête" en moins .

Cordialement

Share this post


Link to post
Share on other sites

Bonsoir,

 

voici comment j'ai configuré ma boutique, et je n'ai plus eu aucun problème de réécriture depuis. En espérant que ça vous serve :)

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Re-Bonsoir......

 

Je vous remercie pour votre aide. Je vais reconfigurer mon SEO & URLs à l'identique en espérant que les visites seront à nouveau au Rendez-vous.

 

Finalement quand on veut bien faire.....on finit par faire encore plus d'erreurs.

 

En tout cas, je vous tiendrai informé de mes résultats et encore merci.

Cordialement

 

 

Ps: savez-vous comment peut-on et où corriger les erreur W3C.(57 Errors, 3 warning(s)) ?

Edited by thierry68 (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

 

 

Tous mes remerciements à Devnet et  à Zythom, pour leur aide !!

 

Excellente semaine

Thierry

 

 

 

 

       

   

Share this post


Link to post
Share on other sites

De rien thierry ;)

 

pensez à mettre le post en résolu (premier post->edit->use full editor et changer le titre)

 

Bonne semaine à vous

Share this post


Link to post
Share on other sites

Bonjour,

 

La pièce jointe n'est plus active, je souhaiterai connaître la configuration ^^

En vous remerciant,

 

bien a vous 

Bonsoir,

 

voici comment j'ai configuré ma boutique, et je n'ai plus eu aucun problème de réécriture depuis. En espérant que ça vous serve :)

 

attachicon.gifseo.png

Share this post


Link to post
Share on other sites

Bonsoir,

 

voici comment j'ai configuré ma boutique, et je n'ai plus eu aucun problème de réécriture depuis. En espérant que ça vous serve :)

 

attachicon.gifseo.png

Bonjour Zythom

J'ai ce même problème, le lien ne fonctionne plus.

Peux tu me le faire parvenir.

Merci

Bonne journée.

Share this post


Link to post
Share on other sites
On 3/2/2014 at 9:58 PM, Zythom said:

Bonsoir,

 

voici comment j'ai configuré ma boutique, et je n'ai plus eu aucun problème de réécriture depuis. En espérant que ça vous serve :)

 

 

Bonjour @Zythom, je ne vois plus l'image que tu as mise. Peux tu nous redire comment tu as configuré? Je te remercie.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More