Jump to content
misthero

[FREE MODULE] Sliders Everywhere - Responsive Gallery, Image Sliders or Banners - NOW 3D!

Make a Better Module  

1,065 members have voted

  1. 1. What would you like to see as new feature in the future?

    • Automatically enable CMS page slider without manually editing theme file (*ADDED IN VERSION 1.5.4)
    • Video Slides
    • More customizations for colours and controls positions
    • Image map Slides with different clickable areas (*ADDED IN VERSION 1.6.1)
    • Entering custom html in description
    • Option to restart the slider after user click on controls (*ADDED IN VERSION 1.5.4)
    • Different Sliders on Category pages based on categories (*ADDED IN VERSION 1.5.4)


Recommended Posts

Oh,sorry forgot to turn off maintance off .

I did not notice that it is not compatible with 1.7 .

So it really don't work . :(

I deleted all samples in the begining,and added just one image, and tried to fix image full width ,that's why i didn't notice that images not moving .

Will it be ever compatible with 1.7 ?

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, johnxl said:

Oh,sorry forgot to turn off maintance off .

I did not notice that it is not compatible with 1.7 .

So it really don't work . :(

I deleted all samples in the begining,and added just one image, and tried to fix image full width ,that's why i didn't notice that images not moving .

Will it be ever compatible with 1.7 ?

 

hopefully I'll find time to adapt the module to 1.7 someday, but no eta for now.

  • Thanks 1

Share this post


Link to post
Share on other sites

Pour ceux qui souhaitent administrer ce super module en français, voici le fichier de traduction (pour vous éviter de vous taper 259 lignes... :P)

Fichier à copier dans votre dossier \votre_theme\modules\homesliderpro\translations
REMPLACER le nom du thème (issu de mon thème "default-bootstrap")

fr.php

Share this post


Link to post
Share on other sites

HI , I am reinstalling my prestashop, somehow I am not able to download the latest module anywhere, can anyone guide me where I can download the sliderseverywhere new module?

Share this post


Link to post
Share on other sites

Hey I managed to install sliders everywhere by logging in to this forum and downloading and installing the module.

After installing I saw that the Top menu bar is not clickable and even the logo of the website became not clickable, Do I need to do any changes in settings ?please help! I am using default bootstrap theme.

Share this post


Link to post
Share on other sites
14 hours ago, sadgamaya said:

Hey I managed to install sliders everywhere by logging in to this forum and downloading and installing the module.

After installing I saw that the Top menu bar is not clickable and even the logo of the website became not clickable, Do I need to do any changes in settings ?please help! I am using default bootstrap theme.

Got the answer @misthero in this forum which is already answered :) Thank you so much for this wonderful module.

Share this post


Link to post
Share on other sites
En 10/11/2017 a las 0:15 PM, misthero dijo:

 

hopefully I'll find time to adapt the module to 1.7 someday, but no eta for now.

Very good, great module and a great pity that is not for the 1.7,
we are many who have been reading that they ask, I include myself and I ask you,
please, it would be great to adapt it to version 1.7, we are many who We would be grateful for that,
encourage and take a little time in this new year 2018 and give us that great joy,
it is a fantastic module and I would love to try it on my page with version 1.7 :)
Edited by ChuChuah_2017 (see edit history)

Share this post


Link to post
Share on other sites

Hi guys,

 

Im quite bad at Prestashop and I do not know how to make it works.

 

I just need to create a simple banner on the top explaining we have free shipping until a specific data. Just something very easy as attached picture.

 

There is some person who could please let me know, step by step (otherwise I will dont know how to do it) how can I enjoy that simple banner?

 

Please, lets try to explain it like for a child!

 

Regards,

top-banner.jpg

Share this post


Link to post
Share on other sites

Not compatible with 1.7.2.4. Upload error + problem with display :(

  • Sad 1

Share this post


Link to post
Share on other sites

Hi,

VEry nice module.

Please confirm me that this can be used as 360 degree view for a product.

Thank you,

Daniel

Share this post


Link to post
Share on other sites

HI there.
I'm using the great "Sliders Everywhere" module on PS 1.6.1.15 platform.
Thanks a lot to the developer Misthero .
I successfully use this module to display promo images on selected product pages as "Slider1" using the Filters: "Pages / Categories / Products".
However, I seem unable to display another set of promo images as "Slider2" on the same product pages using the same filters.
The "Products" filter of the "Slider2" doesn't allow to select the same Product pages once they've been selected for the "Slider1".
The possible solution is to duplicate the  module "Sliders Everywhere"
Unfortunately, uploading the module with the altered filenames doesn't work.
Pressing the "Modules and Services" button in the back office gives an "error" message: "Unable to reconcile the PerfectResizer.php..."
Please advise on the possible solution of the issue.

Thank you,
Alex K.

Share this post


Link to post
Share on other sites
On 2/7/2018 at 2:26 AM, akps1234 said:

HI there.
I'm using the great "Sliders Everywhere" module on PS 1.6.1.15 platform.
Thanks a lot to the developer Misthero .
I successfully use this module to display promo images on selected product pages as "Slider1" using the Filters: "Pages / Categories / Products".
However, I seem unable to display another set of promo images as "Slider2" on the same product pages using the same filters.
The "Products" filter of the "Slider2" doesn't allow to select the same Product pages once they've been selected for the "Slider1".
The possible solution is to duplicate the  module "Sliders Everywhere"
Unfortunately, uploading the module with the altered filenames doesn't work.
Pressing the "Modules and Services" button in the back office gives an "error" message: "Unable to reconcile the PerfectResizer.php..."
Please advise on the possible solution of the issue.

Thank you,
Alex K.

 

do not duplicate the module, what you describe is a unintended bug can you try this "development" version?

it should be fine to overvrite your version, if that doesn't work try uninstalling, deleting and reinstalling (this will cause the deletion of your sliders).

 

 

homesliderpro.zip

Share this post


Link to post
Share on other sites

Hi Misthero,

Thanks a lot for replying to my question about the issue with the great "Sliders everywhere" module and for offering a solution.
I'll try this solution shortly and post a reply with results.
Just a question.
For the sake of keeping the current working sliders' settings and images, would you advise to FTP/overwrite any particular file(s) from the new homesliderpro.zip file, rather than re-installing the whole module in the backoffice ? 

Thank you,
Alex K.
 

Share this post


Link to post
Share on other sites

Hi Misthero,

The solution you offered worked like a charm.
Thanks a lot! The new version had overridden the previous one.
So, all the sliders with the images and settings were saved - great!
I just had a few minor hiccups, such as.
I had to remove the "/" from Url address in "Edit your slider".
Otherwise an additional "/" was added by the module, and the link didn't work.
Other than this, it works just great!

Share this post


Link to post
Share on other sites

Hi misthero,

Thanks for this good module.

1- I want to post announcements and text at the top of the animated banner site. How can I define the animated text for the banner.
The description is animated, not the title.

example : please see this demo theme http://ipresta.ir/idemo/themes/b/sahand3/

Check this https://daneden.github.io/animate.css/

and click to section top header. open popup notification.

2- Add Color Picker Code to Backup Description .

my site : https://satkala.com

3-The banner Sliders is not on the top of the phone is not on the top hook of the phone Responsive

 

I use prestashop 1.61.18 . please help me .

Thank you.

photo_2018-03-02_22-42-54.jpg

Edited by Satkala (see edit history)

Share this post


Link to post
Share on other sites

Hi

This module is awesome but is not compatibile with PHP 7 on PrestaShop 1,6,1,17 and other.

When i use PHP 7 in sliders have got error.

JS ERROR GOT ","  and "enter a valid number" when i add new slider

If i use PHP 7 do not save my settings without sliders. I click save, refresh page and settings slider not saved.

Above 60 sliders module is slow very slow.

I use PHP 5,6 and above problems do not occur.


I test two version sliders (dev versIon) and 1,6,1,41

 

Share this post


Link to post
Share on other sites

Hello misthero,

 

I need to duplicate your module, I changed the file name, part of the code by respecting the small and capital letters, for example HomeSliderPro / homesliderpro. (I need it because I'll use one for the Mobile and one for Computers)

Called it SlidersEverywhereMobile, I can see it in my BackOffice with the desidered name, but when I try to add an image on the original module appears the same on the duplicated module.

Can you explain me how to solve it?

Thanks in advance.

 

I'm using Prestashop 1.6.1.17

Edited by Brugnolaro.com (see edit history)

Share this post


Link to post
Share on other sites

Hi guys!

Dropping by with the following question.

I cant seem to get the module working as header on for example category pages.
I have tried the automatic activation, but that one unfortunately fails.

I cant seem to fin the how to on how to do this manually, and also have tried to work with the filters, but no luck.

Could someone perhaps point me in the right direction on how to get this at category pages?

Thanks a lot!
(using ps 1.6.13)

Share this post


Link to post
Share on other sites

Hi,

How can I have a different banner for each category page?

"Top" is always showing in every single pages, right?

I thank you in advance.

Share this post


Link to post
Share on other sites

Hi Ben90,

Create a different slider for each category.
In the "Category Image" column of the Slider Setup type the Category ID of the corresponding category you want to place the image for.
Repeat the procedure for each category.
In the Filters > Pages select Category.
In the Filters > Categories select your category from the drop-down menu.
That's it. Works for me.

 

  • Like 1

Share this post


Link to post
Share on other sites

Hello misthero,
I have create 2 different slides and want to visualize them in different brands pages.
I have enabled To Column for the 2 slides and in filters I have choose a brand for the first slide (enabling Only the following) and another brand for the second slide (enabling Only the following).

First Problem: both the slides are visible in every brands page;

Second Problem: both the slides are visible in home page so I have to enable filter for page Manufacturer (enabling Only the following).

How to solve the problem?
Where the slides are associated with the brands and which file can I modify to solve the problem?

Thanks

Edited by gambrinus777 (see edit history)

Share this post


Link to post
Share on other sites
On 4/7/2018 at 5:22 AM, akps1234 said:

Hi Ben90,

Create a different slider for each category.
In the "Category Image" column of the Slider Setup type the Category ID of the corresponding category you want to place the image for.
Repeat the procedure for each category.
In the Filters > Pages select Category.
In the Filters > Categories select your category from the drop-down menu.
That's it. Works for me.

 

 

Thanks. It's working. Appreciate that.

Share this post


Link to post
Share on other sites

Hi Misthero,

You works are really good

Is it possible to organize the module in this way? Several images in the form of a carousel. Each picture is separate, the name of the product and its price and a link to the product page are also displayed.

image.png.104cf7b6d090007461af1fcb8ea51ef2.png

Share this post


Link to post
Share on other sites

How can I make the module, instead of displaying the images in order as they are uploaded, show them randomly? 

 

Well, I want to randomly end up seeing all the images because if the first one is the same, the number of images in the slider will never be seen.

Share this post


Link to post
Share on other sites
1 hour ago, ofimat said:

How can I make the module, instead of displaying the images in order as they are uploaded, show them randomly? 

 

Well, I want to randomly end up seeing all the images because if the first one is the same, the number of images in the slider will never be seen.

 

edit the .tpl file and between the options add:

randomStart : true,

Share this post


Link to post
Share on other sites
On 10-11-2017 at 8:37 AM, misthero said:

the module is not compatible with 1.7 so it is strange it works for you. Your site is in maintenance mode anyway so it is impossible to check it for us

 

I beg to differ, this is shown at the front and I can even access and edit the configuration if I copy the settings page URL of our Prestashop 1.6.x, but ... it has a javascript error in the frontend "$ not defined" No nav buttons.

Share this post


Link to post
Share on other sites
On 4/9/2018 at 4:39 PM, Soyons zen said:

HI, still nothing for the 1.7 ?

 

Hi, I would also be interested in a version that supports PrestaShop 1.7.  Thanks

Share this post


Link to post
Share on other sites

Hello,

it will be possible to add a feature for choosing one starting and one ending date/hour for each slide ? it would be great to schedule displays in advance, for sales or other limited time offers.

I guess it's not that simple but it would be great ;)

Share this post


Link to post
Share on other sites

Hello, 
Great module, i have one question.
How can I do carousel of manufactures but i want use manufacturer image, i don't want add new image in slider.

Share this post


Link to post
Share on other sites

Hi -am using Prestashop 1.6.1.20 and need to be able to put a different banner or slide at top of each product page, above product name, images and description. Can I do that with this module?

 

Many thanks

Baz

Share this post


Link to post
Share on other sites

Hi Misthero,

I've just upgraded to 1.6.1.21 because the hosting told me that PHP 7.0 will not be used any longer. After changed it to PHP 7.2, my CMS page can't be opened and this error appears:

Fatal error: Declaration of AdminCmsController::viewAccess() must be compatible with AdminControllerCore::viewAccess($disable = false) in /home/public_html/modules/homesliderpro/controllers/admin/AdminCmsContent.php on line 3

Do you have a fix for this? Thanks.

Share this post


Link to post
Share on other sites

Hola,

¿No está disponible para Prestashop 1.7? 

Este módulo me serviría de gran ayuda.

Gracias.

 

Share this post


Link to post
Share on other sites

Hello.

We use this module for years and nothing confusing happened until now.
Since a week or so, the slider is showing our images in different sizes.
See the screenshot.

How can we solve the problem?
Is there any correct size which we should use for our images so they can show up properly or the size is automatically resized from the module?

Thank You in advance.

 

Screenshot_2.png

Share this post


Link to post
Share on other sites

Good morning. My prestashop is at 1.6.1.19 and php 7.1.23...

Is the module compatible with these specifications?

Thanks!

Share this post


Link to post
Share on other sites
14 hours ago, Kefa said:

Good morning. My prestashop is at 1.6.1.19 and php 7.1.23...

Is the module compatible with these specifications?

Thanks!

 

Need some work for PHP 7 but it mostly works, you can try the development version attached to this post.

 

3 hours ago, Satkala said:
Hi.
Please upgrade this functional module to Prestashop 1.7. Thank You

 

won't upgrade to PS1.7 because I think 1.7 is a downgrade. stick with 1.6

 

homesliderpro.zip

Share this post


Link to post
Share on other sites
5 hours ago, misthero said:

 

Need some work for PHP 7 but it mostly works, you can try the development version attached to this post.

 

 

won't upgrade to PS1.7 because I think 1.7 is a downgrade. stick with 1.6

 

homesliderpro.zip

Hi misthero;

OK. Thanks .

How can I put the text inside the banner in the middle? Because this section does not have text editor .

Is it possible to put code Html or animation pic ( Gif ) in the module too?

 

Edited by Satkala (see edit history)

Share this post


Link to post
Share on other sites
On 11/1/2018 at 1:02 PM, Info12453 said:

Hello.

We use this module for years and nothing confusing happened until now.
Since a week or so, the slider is showing our images in different sizes.
See the screenshot.

How can we solve the problem?
Is there any correct size which we should use for our images so they can show up properly or the size is automatically resized from the module?

Thank You in advance.

 

Screenshot_2.png

Any answer ?

 

Share this post


Link to post
Share on other sites
24 minutes ago, Info12453 said:

Any answer ?

 

don't know, is hard to tell from a screenshot, did you changed anything on your server? installed new modules? updated something? Changed some slider configuration? It could be due to a number of reasons. Try changing the size of your slider than change it back. A button should appear "Save and resize" click it and see what happen.

  • Like 1

Share this post


Link to post
Share on other sites
32 minutes ago, misthero said:

don't know, is hard to tell from a screenshot, did you changed anything on your server? installed new modules? updated something? Changed some slider configuration? It could be due to a number of reasons. Try changing the size of your slider than change it back. A button should appear "Save and resize" click it and see what happen.

Okay.
You just had to say what type of info you need.
Silence is not the best option when it comes to solving issues, you know that, right?
We're not looking to your support if we didn't need it.
We tried changing the size of our slider and change it back, no difference (save and resize option incl.)
No new modules installed.
 

 

P.S. This is the website. 
lunail.com

 

Edited by Info12453 (see edit history)

Share this post


Link to post
Share on other sites
42 minutes ago, Info12453 said:

Okay.
You just had to say what type of info you need.
Silence is not the best option when it comes to solving issues, you know that, right?
We're not looking to your support if we didn't need it.
We tried changing the size of our slider and change it back, no difference (save and resize option incl.)
No new modules installed.

 

 

P.S. This is the website. 
lunail.com

 

 

support is free, as the module, I come here to help when i can.

The information needed for every bug report is specified in the first post of this thread.

 

Quote

To get a correct answer ask for help in this topic and, if possible, remember to include the following details:
 
1) Prestashop version.
2) Module version used.
3) Steps to follow to reproduce the issue.
4) The issue happens every time, randomly or what?
5) Do you see any errors with developer mode enabled?
6) Url of the website (if you don't want to share it on the forums send me the link with a PM, just the url not the full help request)

 

anyway, if resizing doesn't work from module configuration there is some kind of error during the resize process, you should enable the debug mode and report any error you get trying to resize again the slider, also get the error log from your server.

in your case looking the front page of your site doen't help since the slider does work, the error, if any, happen before that, when the images are uploaded or resized.

If you can't show us the errors, as a workaround, you could resize the images on your computer and than just upload all the images with the same size.
 

 

Share this post


Link to post
Share on other sites
54 minutes ago, misthero said:

 

support is free, as the module, I come here to help when i can.

The information needed for every bug report is specified in the first post of this thread.

 

 

anyway, if resizing doesn't work from module configuration there is some kind of error during the resize process, you should enable the debug mode and report any error you get trying to resize again the slider, also get the error log from your server.

in your case looking the front page of your site doen't help since the slider does work, the error, if any, happen before that, when the images are uploaded or resized.

If you can't show us the errors, as a workaround, you could resize the images on your computer and than just upload all the images with the same size.
 

 

 

Thank you for the answer and your support.
Will write to you soon.

Share this post


Link to post
Share on other sites

*UPDATE

Deactivated HOOKS, and REactivated them. This fixed this.
Must say, i uploaded the DEV version on page 43, overwrite and no difference, uploaded 1.6.41 again and did the deactivate, and activate.
i guess the 1-click upgrade overwrote some essential file.

 

Hey Hey.. we have been using this module for years, as it is one of the best modules for prestashop.

we had to upgrade to 1.6.1.22 to support PHP 7.1 and 7.2 and one function stopped working for us. Category slides.

we will try the developer version posted on page 43 in this forum. and post back. but if it does not work, is there anything we might do our selves to get this reactivated?

 

best regards: OVER HAPPY USER OF SLIDERS EVERYWHERE

Edited by tilbarnet (see edit history)

Share this post


Link to post
Share on other sites

Hello, very nice slider and doing exactly what i want.

by default images are float: right,

is there a way to change that on small screen ? to have the slide image centered ? 

i use a 1920x600 px image, who fits well on all screen sizes.

but for small screens in portrait mode, if i try to set the height and let the width to auto, my images are aligned to right, and i can't find a way to display the slider images centered.

🙏🏻

Edited by Coal_Sa (see edit history)

Share this post


Link to post
Share on other sites

Hello there,

First of all, thanks for sharing this module with the community, it gives muuuch usefull possibilities!

Although, I have a small problem. While adding new slider we have a possibility to either accept the default size of a slider(height and width), or define custom size in pixels. Is there a way to set a percentage value for width like 100%, so uploading a big graphic(like in 4K resolution) would result in covering full width with a slider doesn't matter if someone uses FHD, 2K, 3K or 4K display?

It's quite important for me, please, let me know whether it's possible using your module or not :)

 

Share this post


Link to post
Share on other sites

Buenas tarde, queria prenguntar si con este modulo  puedo incluir en el  home de mi tienda  un carrusel de productos de una categoria especifica   y  si hay algun procedimiento o tutorial donde expliquen como hacerlo. gracias 

Share this post


Link to post
Share on other sites
On 2/24/2014 at 6:59 PM, misthero said:

Hey people!

 

thanks to all of you for your appreciation

I'm very glad you found it useful

 

 

Sure vekia i would like it, thank you!

Hi

I´v tryede it on Thirty bees, it works all right with setting up sliders, but it woné slide, but only show the first image?

Share this post


Link to post
Share on other sites

Hello;
I'm trying to install SlidersEverywhere1.6.41 module on the site. I can install and adjust without any problems in the local machine. But when I try to install the real site I get errors like the following.Local machine and on the real site also installed the same version of prestashop. But my local machine is running smoothly and the working module is not working on the site.
The first error I understand says primary_key cannot be null or empty. But it is installed in the local area. I would like ideas and suggestions. Thank you from now.

 

Hata.jpg

Share this post


Link to post
Share on other sites

Hello,

Great Module!But I am having some issues.

I am using PS 1.61.23 and 1.6.41 of Sliders Everywhere!.

The slider always shows only the last slide on the page and never moves on to the next.Keep in mind that, I can see the generated code of the other slides on the 'Inspect' tab of my browser.

 Also I am getting that weird error on the console:

1087808246_SlidersError.jpg.6870be66d5c7dc884d027f032f022430.jpg

 

Any idea how we can fix that?

 

Thank you!

Share this post


Link to post
Share on other sites
Posted (edited)

Hi,

need help 😕

!Sliders Everywhere! (v:1.6.41)

presta 1.6.1.3

how can i delete slide 

i have 10  and cant delete  ,

i can just  add new

 

 

 

manual delete ????

how can i do that ???

 

 

SE error.jpg

Edited by manieQ (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

HI,

 

Great module! But have i overlooked an forum thread or a functionality in the module? When i try to upload a picture slide, the picture is apparently too big. It is cropped and i cannot reduce the picture size in the upload menu. Does the slider only support up to specific sizes of images? I am running PS 1.6

I know i can resize the gallery afterwards, but the initial picture is cut/cropped. I have testet with a picture that is 1320 x 160 pixels. And 70% of the picture is cropped.

Share this post


Link to post
Share on other sites

I seem to have solved it. I define the Gallery size very large before upload the file, and it is then shown in the right size.

Share this post


Link to post
Share on other sites
On 3/25/2014 at 8:24 PM, misthero said:

 

Good afternoon.
Tell me what could be the problem. I choose to display the slide in a particular manufacturer, but the slider is displayed in all products.

Share this post


Link to post
Share on other sites

Sliders Everywhere (v:1.6.41) not working after shifting to PHP 7.2.X

Prestashop v 1.6

Tried dev (v:1.6.41) version.

CMS admin link 500 error.

 

Share this post


Link to post
Share on other sites
On 5/21/2019 at 6:42 PM, sinbinrin said:

Sliders Everywhere (v:1.6.41) not working after shifting to PHP 7.2.X

Prestashop v 1.6

Tried dev (v:1.6.41) version.

CMS admin link 500 error.

 

You should NOT use php 7.2 with prestashop 1.6. Only php 7.0 i fully suitable for this version.

Share this post


Link to post
Share on other sites

I having a problem with this module, 

firstly It doesnt move slides, it only display single picture  and even after settings changed slides are stuck ...

Another problem is that under page http://leki2.hurt-zdrowieiuroda.co.uk/index.php?fc=module&module=quickshop&controller=QuickShop

each pictures is on the top of another

and on this page which is same page but with different url slider doesnt show : http://leki2.hurt-zdrowieiuroda.co.uk/module/quickshop/QuickShop

 

This is urgent for me 

Share this post


Link to post
Share on other sites

Hello,

I am triying to display the same banner on multiple categories, but it seems only one id is accepted in the field "category"...

How can I display on multiple categories ?

I tried several id separated with spaces, commas, semi commas, but nothing worked out...

Thank you !

 

Screenshot_2019-07-27 Module Manager • Agronova.png

Share this post


Link to post
Share on other sites
On 7/27/2019 at 7:39 PM, Stéphane V said:

Hello,

I am triying to display the same banner on multiple categories, but it seems only one id is accepted in the field "category"...

How can I display on multiple categories ?

I tried several id separated with spaces, commas, semi commas, but nothing worked out...

Thank you !

 

Screenshot_2019-07-27 Module Manager • Agronova.png

I don't think you are using my module, your screenshot doesn't fit

screenshot-126.png

Share this post


Link to post
Share on other sites

I really hope you will add the possibility to open the pic into a fancybox/lightbox. In any case, thanks for this excellent module.

Share this post


Link to post
Share on other sites

1) Prestashop version: 1.6.1.20
2) Module version used: 1.6.41
3) Steps to follow to reproduce the issue: When i add a second slider in the same hook, url don't work for the second slider.
4) The issue happens every time, randomly or what?: Issue happens always if there is a second slider in the same hook (like home for example)
5) Do you see any errors with developer mode enabled?: Nope
6) Url of the website (if you don't want to share it on the forums send me the link with a PM, just the url not the full help request): https://Moviliario.es

 

Thanks for the module.

 

Share this post


Link to post
Share on other sites

Any idea please? I need create more banners in home but only the first banner have URL. For th rest of banners url don't work... 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×