Jump to content

Recommended Posts

Hello. I uploaded a category image to see how it would look on my site. Then I deleted the image and tried to upload a new image to take it's place in the category. I have cleared all of the caches. But everytime I try to upload a new image to my categories, prestashop puts the 1st/originial uploaded image in the new image's place. I have checked the folders where the images are stored. The default image is saved correctly. However the image for my theme is not.

 

Any help is greatly appreciated thank you.

Edited by The Fuzzy Pineapple (see edit history)

Share this post


Link to post
Share on other sites

Hello. I uploaded a category image to see how it would look on my site. Then I deleted the image and tried to upload a new image to take it's place in the category. I have cleared all of the caches. But everytime I try to upload a new image to my categories, prestashop puts the 1st/originial uploaded image in the new image's place. I have checked the folders where the images are stored. The default image is saved correctly. However the image for my theme is not.

 

Any help is greatly appreciated thank you.

 

I have had the same issue.  Try to manually delete the picture and then upload the most current one.  By manually delete i mean hit the delete button for the picture on the category page.

Edited by roamencota (see edit history)

Share this post


Link to post
Share on other sites

I have had the same issue.  Try to manually delete the picture and then upload the most current one.  By manually delete i mean hit the delete button for the picture on the category page.

 

I tried that as well. Not sure why it continues to keep the image even when I deleted it from my image folders. Quick solution is to make a new category, change the picture, move every subcategory and/or product there, and then delete the old category. Luckily I don't have too many things to move. But, I will try to figure out the bug. Hopefully it is fixed in the next upgrade.

Edited by The Fuzzy Pineapple (see edit history)

Share this post


Link to post
Share on other sites

I have the same problem, I considered deleting it but I don't really want to go through the process of changing all the sub categories back just to change a single picture. I can't follow what the shop is doing, I tried deleting the picture on the ftp server, but it doesn't exist anymore. The new image is already in there, but where does the shop grab the old image from? I fail to understand.

 

I have deleted my cache folder, in case you're wondering.

 

A solution or workaround would be greatly appreciated!

 

/edit

 

I forgot that the module "customcontent" manages the categories on my shop main page. You will need to change the picture in that module (If you're in the same situation as me, that is).

Edited by Bimo.ch (see edit history)

Share this post


Link to post
Share on other sites

Hey

 

I had the same issue. Using FF i changed the image on one of my categories.

As it didnt seem to stick, i repeated the process 10000000 times to no avail.

 

Then i opened the site in a different browser (IE) and the newly loaded image showed just fine on the category page.

So a caching issue.

 

Try displaying the category using a different browser/computer.

  • Like 1

Share this post


Link to post
Share on other sites

I am getting error HTTP 500 (white screen of death) when trying to upload a new Category image.
JPG image size is 870px x 217px. Size on disk is 53KB.
BO > Preferences > Images > Size = 900x900, so all ok there.

Whats going on?
How come I cant upload a Category Image?

HELP!

Share this post


Link to post
Share on other sites

Someone has to know an answer to this!

 

Ive wasted 2 days on this ridiculous issue.

 

Help!!!!!

Share this post


Link to post
Share on other sites

Thanks Troca,

 

Appreciate you coming back to us.

 

I've tried that and tried manually deleting the files from the smarty folder.

Share this post


Link to post
Share on other sites

I had this exact same problem and it was driving me nuts. What I realized was that my images always had a "pagespeed.ic" added to the end of the filename. So for example:

 

image.jpg

 

became

 

image.jpg.pagespeed.ic.[random-number-here].jpg

 

It was due to the fact I had enable Google's PageSpeed optimization (mod_pagespeed) with my host. Once I disabled that, I refreshed my site and voila! The images now updated.

 

I will probably enable this when I am done editing my site, however, to make things faster.

 

I hope this helps, and maybe is what is causing the issue for some!

Share this post


Link to post
Share on other sites

hello

 

with pagespeed mod changes will be visible after some time, its due to the fact that these images are cached.

cache is regenerating itself

Share this post


Link to post
Share on other sites

You can change / delete images in backoffice under  Catalog separator_breadcrumb.png Image Mapping 

 

 Catalog_ImageMappin.png

Share this post


Link to post
Share on other sites

I have a similar problem, I am using Prestashop 1.5, when I create a new category with a category image, the image displays as  ?. If I delete the associated image for that category the ? goes away, so it knows there is an image there, it just wont display it.

If I go to category images I had uploaded at the very start & change them, it wont upload the new pic, just keeps the old one there.

So I cannot over write old category images and not upload new ones, so something changed at a particular point in time which is affecting my category images.

A few months back I installed the ebay module, which caused problems with my mobile site, I have since disabled the mobile site & uninstalled the ebay module, the person who deals with my back office part, seems to think the ebay module has disrupted certain aspects of my site, if that is true, why is it just category images that is affected?

 

 

Share this post


Link to post
Share on other sites

this has happened to many other people, personally i dont think is the ebay module. I dont have that module installed and i have the exact same issue..

 

I am still amazed there has not been a solution for this after months! did any of you guys found a solution for your bug?? please share..

Share this post


Link to post
Share on other sites

Switching off the hardware acceleration on chrome helped me thx accidcloud  :) Chrome>settings>advanced settings>system>disable hardware acceleration when aviable

Share this post


Link to post
Share on other sites

Hi everyone, 

 

I know this is an old post, but I am struggling with the exact same issue now. 

 

Has anyone found a solution for this?

 

Thanks!

Share this post


Link to post
Share on other sites

Found a pretty easy solution (or workaround if you want to call it like that):

 

1) Open the image you want to change in a new tab and check the URL.

2) Go to the same path in your FTP-client. If it doesn't exist, create it (some of my images were located in home/c, a map that didn't exist).

3) Replace the image with the image you want to be displayed (don't forget to give it the same name and extension (.jpg)).

4) Refresh your page and clear the cache if necessary, the image will also look better now (uncompressed).

Share this post


Link to post
Share on other sites

Hi,

 

Yes, 3 years later I still have the same issue. But here is the solution for my personal case.

 

I had the exact same issue described by 'The Fuzzy Pineapple'.

Of course, like everybody, since the beginning I knew this was a cache issue.

But, it wasn't a smarty cache, a browser cache. So it could only be a hosting cache !!!

 

Bingo, OVH is using CDN (Content  Delivery Network)

So if you have the CDN Option, go to your admin panel, and hit 'clear cache'.

 

You could also edit .ovhconfig file at your FTP root, to replace 'environment=production' by 'environment=development' while working on your store.

 

 

 
  • Like 1

Share this post


Link to post
Share on other sites

 

Hi,

 

Yes, 3 years later I still have the same issue. But here is the solution for my personal case.

 

I had the exact same issue described by 'The Fuzzy Pineapple'.

Of course, like everybody, since the beginning I knew this was a cache issue.

But, it wasn't a smarty cache, a browser cache. So it could only be a hosting cache !!!

 

Bingo, OVH is using CDN (Content  Delivery Network)

So if you have the CDN Option, go to your admin panel, and hit 'clear cache'.

 

You could also edit .ovhconfig file at your FTP root, to replace 'environment=production' by 'environment=development' while working on your store.

 

 

 

 

 

thanks so much for sharing this

spent hours trying to resolve it and your post helped me work this out

my problem was also with my CDN account, so I purged my image URL and its okay now :)

Edited by tiagomiranda (see edit history)

Share this post


Link to post
Share on other sites

HI,

 

Clear cash in your browser. In Chrome go to Settings/Advance settings/privacy and security/clear your browsing data/cached images and files (may be translation is not exactly like that because my Chrome is on my language - Serbian)

  • Thanks 1

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More