Jump to content
diegopintovieira

[RESOLVIDO] Clientes não conseguem upar imagem

Recommended Posts

Boa tarde Galerinha!

 

Pois então, preciso muito que meus clientes consigam me enviar imagens e comentarios, pois trabalho com brindes personalizados e seria muito bom que eles conseguissem enviar juntamente com o pedido.

Mas quando eles upam a imagem e escrevem o texto, quando clicka em enviar a página fica em branco.

 

Na página do produto tem uma aba do lado da descrição chamada PRODUTO PERSONALIZADO, aproveitando o gancho eu queria colocar esta opção dentro da descrição do produto ao inves de uma aba ao lado, para poder ficar mais visível.

 

Abraços!

Edited by diegopintovieira (see edit history)

Share this post


Link to post
Share on other sites

Boa tarde Galerinha!

 

Pois então, preciso muito que meus clientes consigam me enviar imagens e comentarios, pois trabalho com brindes personalizados e seria muito bom que eles conseguissem enviar juntamente com o pedido.

Mas quando eles upam a imagem e escrevem o texto, quando clicka em enviar a página fica em branco.

 

Na página do produto tem uma aba do lado da descrição chamada PRODUTO PERSONALIZADO, aproveitando o gancho eu queria colocar esta opção dentro da descrição do produto ao inves de uma aba ao lado, para poder ficar mais visível.

 

Abraços!

 

 

Pessoal, a primeira parte do problema foi sanada que era trazer a opção PRODUTO PERSONALIZADO para a página principal para ficar melhor exposto. Fiz isto com a ajuda de um módulo, mas agora falta o PRINCIPAL que é funcionar o uploading das imagens, pois continua ficando em branco quando clicko em salvar. Abraços.

Share this post


Link to post
Share on other sites

Pode ser causado por dois problemas. No back-office vc. restringiu o tamanho do ficheiro que pode ser subido no seu servidor ou o seu provedor nao deixa vc. subir imagens de fora (questao de seguranca !)

 

Veja qual os valores que vc. tem na aba:

 

Administração separator_breadcrumb.png Preferências  > Quota de carregamento. Aumente os valores.

 

Para a segunda opcao vc. terá de verificar qual o max_input_time  e max_execution_time o seu provedor permite. Cada um deveria ter o valor de 300 ao menos, para nao interromper o processo e criar uma imagem branca.

Share this post


Link to post
Share on other sites

Problema resolvido ?

 

Bom dia!!

 

Estou num impasse, encontrei em contato com o rapaz do hosting, ele me deu varias orientaçoes fez as modificações.

 

no final de tudo me autorizou a criar um arquivo php.ini com o que fosse preciso, mas o erro ainda persiste

 

o arquivo ficou na pasta do dominio, pois tenho varios dominios na mesma hospedagem. O arquivo ficou assim: 

 

safe mode = Off

memory_limit = 256M

max_execution_time = 300

max_input_time = 300

post_max_size = 64M 

upload_max_filesize = 64M

enable_dl = Off

 

 

O que devo fazer agora? a pagina continua ficando em branco, mas vasculhando o sistema, descobri que as imagens chegam na pasta UPLOAD sem problemas. Mas o importante que seria concluir o processo para registrar no backoffice as encomendas, agente nao consegue.

 

abraços!

Share this post


Link to post
Share on other sites

Veja a pm que lhe respondi. Espero que resolve, pois sao as últimas dicas que posso te dar que possam resolver o problema.

 

ativou o modo debug e tentou upar uma imagem, com este modo ativo ? Nenhum erro ?

Share this post


Link to post
Share on other sites

Como escrito o seu servidor nao é um dos melhores para correr Prestashop. Nao dá para fazer milagres com um servidor que tenha todos os direitos proíbidos e nao aceita settings ini próprios que estao incluídos nos scripts nativos da software. se nao corre entao nao corre. Entendo que vc. já pagou por um ano, talvez tem alguma maneira de sair e ir para um provedor que suporta Prestashop melhor.

 

Vc. comentando as linhas em questao no seu ficheiro confing.inc.php vai resolver o seu problema

[21-Feb-2014 07:44:04 America/New_York] PHP Warning: ini_set() has been disabled for security reasons in /home/tiagoloc/public_html/kaizenbrindes.com.br/loja/config/config.inc.php on line 34

[21-Feb-2014 07:44:04 America/New_York] PHP Warning: ini_set() has been disabled for security reasons in /home/tiagoloc/public_html/kaizenbrindes.com.br/loja/config/config.inc.php on line 35

[21-Feb-2014 07:44:04 America/New_York] PHP Warning: ini_set() has been disabled for security reasons in /home/tiagoloc/public_html/kaizenbrindes.com.br/loja/config/config.inc.php on line 36

Mas nao vai resolver o problema que Prestashop necessita destas adaptacoes na ini do servidor para trabalhar corretamente. Servidor poíbe entao o script continua trabalhando as outras linhas com o que o servidor sustenta. Infelizmente dando erro como vc. vê.

  • Like 1

Share this post


Link to post
Share on other sites

Como escrito o seu servidor nao é um dos melhores para correr Prestashop. Nao dá para fazer milagres com um servidor que tenha todos os direitos proíbidos e nao aceita settings ini próprios que estao incluídos nos scripts nativos da software. se nao corre entao nao corre. Entendo que vc. já pagou por um ano, talvez tem alguma maneira de sair e ir para um provedor que suporta Prestashop melhor.

 

Vc. comentando as linhas em questao no seu ficheiro confing.inc.php vai resolver o seu problema

[21-Feb-2014 07:44:04 America/New_York] PHP Warning: ini_set() has been disabled for security reasons in /home/tiagoloc/public_html/kaizenbrindes.com.br/loja/config/config.inc.php on line 34

[21-Feb-2014 07:44:04 America/New_York] PHP Warning: ini_set() has been disabled for security reasons in /home/tiagoloc/public_html/kaizenbrindes.com.br/loja/config/config.inc.php on line 35

[21-Feb-2014 07:44:04 America/New_York] PHP Warning: ini_set() has been disabled for security reasons in /home/tiagoloc/public_html/kaizenbrindes.com.br/loja/config/config.inc.php on line 36

Mas nao vai resolver o problema que Prestashop necessita destas adaptacoes na ini do servidor para trabalhar corretamente. Servidor poíbe entao o script continua trabalhando as outras linhas com o que o servidor sustenta. Infelizmente dando erro como vc. vê.

 

Olá, depois de muitos e muitos dias e meses a resposta da minha hospedagem:

 

Essa funcao esta ok porem a funcao ini_set esta por segurança na versao nova do cPanel vem desativada.

Voce nao consegue alterar para outra função?

 

Por favor, mantenha uma questão por ticket para evitar possíveis erros.

Obrigado.

 

Atenciosamente,

Dep Suporte Técnico

Zimba Host - Soluções para a Web!

Share this post


Link to post
Share on other sites

Recomendo você mudar de servidor amigo. Configurações a base de init_set são importantes, e nada garante que você não terá mais problemas com esta hospedagem em vista que ocorreu este transtorno com um detalhe tão simples.

Você pode verificar se o mod_security está desativado também.

 

Boa sorte.

  • Like 1

Share this post


Link to post
Share on other sites

Recomendo você mudar de servidor amigo. Configurações a base de init_set são importantes, e nada garante que você não terá mais problemas com esta hospedagem em vista que ocorreu este transtorno com um detalhe tão simples.

Você pode verificar se o mod_security está desativado também.

 

Boa sorte.

 

Obrigado! Pedi o host para destivar o mod security ele fez e também Joguei o arquivo php.ini dentro da pasta do prestashop ai agora funcionou veja:

 

safe mode = Off

memory_limit = 256M

max_execution_time = 300

max_input_time = 300

post_max_size = 300M

upload_max_filesize = 300M

enable_dl = Off

mod_security = off

 

Só estou com um problemão agora, a imagem está entrando no sistema inteira ao inves de reduzir como acontecia antes. Mas agora está funcionando tudo. Ai está bugando tudo a página de compra e também a do pedido veja:

 

forum.jpg

Share this post


Link to post
Share on other sites

Gostaria de agradecer todo esforço empenhado, vocês como sempre de boa intenção e muita pro atividade. Consertei o problema da imagem gigante que era uma simples configuração que eu havia modificado em outro momento para resolver outro problema kkkkkkkk,
Enfim me deu um flash e lembrei e lá modifiqei e voltou ao normal. Por fim era realmente preciso as PHP.INI e a desativação do MOD SECURITY para poderem funcionar. Mais uma vez muitíssimo obrigado.

 

Reforçando aqui agradecimentos ao Pedro Henrique e o Cony.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More