Jump to content

"Nouveaux produits" en home : aucun produit ne veut s'afficher


Recommended Posts

Bonsoir à toutes et tous,

 

Ayant souhaité afficher le module "Nouveaux produits" dans le corps de mon site (www.florianebijoux.com), j'ai recherché sur ce forum la solution et j'ai apporté les modifications adéquates : le module s'affiche désormais parfaitement dans le corps du site.

 

Cependant, aucun des produits nouveaux ne s'affiche : seul l'entête du module ("Nouveaux produits") et le lien vers la liste des nouveaux produits apparaissent.

 

Je soupçonne un problème de récupération de données, puisque les fichiers système (.tpl, .php, etc.) du module sont identiques à ceux de l'installation d'origine (excepté la petite modification du .php pour l'afficher en "Home", bien sûr).

 

La boucle :

{foreach from=$new_products item='product' name='newProducts'}

du fichier newproductsblock.tpl semble ne rien retourner. Soit un tableau de produits $new_products vide, si je comprends bien.

 

Bien évidemment, j'ai créé un nouveau produit qui s'affiche bien quand on clique sur le lien "Tous les nouveaux produits"...

 

Quelles seraient les points suivants à tester ou vérifier ? Paramétrage du site ? Des produits ?

 

Merci d'avance !

 

Lumbreiser

Edited by Lumbreiser (see edit history)

Share this post


Link to post
Share on other sites

  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More