Jump to content

Recommended Posts

Boa tarde pessoal, Vinha a desenvolver bem o andamento e configuração da loja no Prestashop versão 1.5.6.2, teste em localhost, ate então tinha me virado sozinho e tudo muito tranquilo. Mas agora me deparo com um bug que apesar de falarem muito por ai, não consigo resolver o meu. Se alguém puder me ajudar fico agradecido.


 


As ocorrências de bugs são:


 


Quanto a loja esta com idioma português de Portugal (PT) o slide image deixa de mostrar as imagens e passa a funcionar apenas com o nome que dei a foto, desliza normalmente, sem foto. Já na bandeira do brasil as fotos aparecem normalmente. Nota: ao configurar o slide image so consigo meter as fotos na bandeira do brasil, se ponho  para carregar as imagens na bandeira de portugal da o seguinte erro como na figura rosa abaixo.


 


quando insiro produtos, se meto a bandeira de Portugal da o seguinte erro (ver foto) sobre nome do produto. Já na bandeira do Brasil aceita salvar os produtos e a pagina do produto fica completa como foi inserido os produtos. 


 


Ja na pagina dos produto se meto bandeira PT desaparece as descrições e a barra " mais informações", mas a foto, o nome do produto e preço continuam normais.


 


 


Quando tento gerenciar traduções (foto) e passar para bandeira de portugal da a seguinte mensagem (foto) e nao aceita fazer a bandeira de portugal o idioma oficial da loja


 


Meu objectivo é ter as bandeiras de portugal e UK (que é o publico para quem o site vai trabalhar)


 


Abrigado a quem responder


post-753610-0-10926800-1391188252_thumb.jpg

post-753610-0-06292600-1391188253_thumb.jpg

post-753610-0-01431500-1391188254_thumb.png

Share this post


Link to post
Share on other sites

Qual pacote de instalacao da loja que vc. tomou ? Veja aqui a mesma discussao. http://www.prestashop.com/forums/topic/305631-ideia-para-melhorar-as-ajudas/

 

Vc. vai ter que optar por Brazil ou Portugal dependendo daonde está vendendo, ou seja a localizacao da sua loja. Os pacotes sao diferentes. Dependendo a localizacao da sua loja instale pacote de idiomas somente após de ter instalado e configurado a sua loja.

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

Obrigado por responder

 

Eu instalei o prestashop e estou a configura-lo ainda, nao instalei nenhum idioma, esta como veio da instalação inicial, com os idiamos BR e PT, mas nao consigo fazer o PT ser o idioma oficial, nao autorizada.

Estou com o site em teste em localhost. praticamente so configurei alguns modulos, mas isso esta a atrapalhar o andamento de tudo, nao consigo ver resposta nos links que deixou

 

Obrigado

Share this post


Link to post
Share on other sites

Hm, sinto ter que desapontá.lo, mas as minhas experiencias com localhost sobre WAMPP, XAMPP ou LAMPP nao sao muito positivas. Vc. passando os dados 1:1 ao servidor provavelmente vai encontrar um monte de outros problemas, devido à outra configuracao, versao php, versao SQL, outros módulos ativados e configurados no servidor. Eu iria montar a loja no servidor mesmo e bloqueando o acesso de fora com .htpassword.

 

Vc. está vendendo do Brazil ou de Portugal ? Se a sua loja estiver em Portugal entao o seu pacote de instalacao deverá ser pt/pt ou seja a bandeira Portuguesa. Vc. depois configura a sua loja e somente no final acrescenta outros idiomas através da aba de traducoes.

Share this post


Link to post
Share on other sites

Obrigado

 

Eu ganhei aqui no site do pedro Henrique uma conta de hospedagem com cpanel para testes no prestashop e vou migrar do meu localhost para essa conta. Depois para mudar para uma hospedagem em portugal, acha que vou ter problemas?

 

Estou em portugal, como faço para instalar esse pacote PT/PT?

 

obrigado

Edited by Mbhvirtual (see edit history)

Share this post


Link to post
Share on other sites

Vc. seleciona na instalacao a bandeira Portuguesa. Nao vai selecionar a bandeira Brasileira, pois esta vem com o pacote Brasileiro (taxas, módulos, idioma, etc. programados para o BRAZIL !)

Edited by selectshop.at (see edit history)

Share this post


Link to post
Share on other sites

obrigado

Eu selecionei na instalação apenas a linguagem portuguesa, nao tem na instalação opção para bandeira brasil ou portugal. Quando instalado voce ve que ja tem as duas bandeiras automaticamente instaladas, sendo a do brasil a oficial. tanto que a loja já esta toda em € euros, taxas, nao precisei mudar nada. Dai começa todo o meu problema que coloquei na primeira mensagem deste topico

Share this post


Link to post
Share on other sites

Qual a versao que vc. instalou. Vou instalar no meu server de testes e verificar o que está dando errado.

Share this post


Link to post
Share on other sites

Acabei de fazer a prova com duas instalacoes novas. Vc. baixa o pacote English, Portuguese da página Prestashop.com, só existe um pacote que é Portuguese.

 

Vc. instala este pacote selecionando a Bandeira Brasileira. Escolha o país da sua loja = Brasil e siga a instalacao até o final. Prestashop instala somente o pacote pt/br neste caso e nao o pacote em duplo ou seja idioma pt/br E pt/pt.

 

Se vc. for escolher lá o país Portugal, Prestashop instala ambos os pacote pt/pt e pr/br. Mas corretamente instala somente as taxas de Portugal. Parece ser um bug...

 

A minha solucao para evitar problemas com o idioma: Desative o idioma pt/br na aba localizacao -> idiomas. Se vc. quiser oferecer a sua loja situada no Brasil para ambos os países entao simplesmente edita o icon do idioma colocando a metade da bandeira Brasileira e a metada da Bandeira Portuguesa (no seu FTP /img/l ). Nao trabalhe com ambos os idiomas ao mesmo tempo. Deixe somente o pacote Portugues do país daonde voce opera.

Share this post


Link to post
Share on other sites

obrigado

Mas ja tentei desinstalar, em idiomas tem as bandeiras BR e PT  instaladas, nao autoriza  desinstalar o BR

eu quero trabalhar para o publico PT

 

Nao estou a conseguir postar foto aqui, mas na minha primeira mensagem tem uma foto do erra que da no gerenciamento de idiomas)

Share this post


Link to post
Share on other sites

Recomendo:

  1. Instalar uma loja nova, em inglês;
  2. Adicionar o idioma PT pelo admin e defini-lo como padrão;
  3. Desativar o idioma inglês. 

Boa sorte.

Share this post


Link to post
Share on other sites

Ok pessoal, obrigado, eu vou fazer isso

 

Fico pensando se em adm eu vá conseguir eliminar o idioma inglês, já que é o idioma padrão da loja instalada, assim como esta a ser o BR, o idioma padrão da loja atual que nao consigo mudar nem desinstalar

 

Ou talvez o bug seja so na linguagem portugues, que ao instalar vem com duas linguas portuguesas diferente, (pt e br)

Share this post


Link to post
Share on other sites

Ok pessoal, obrigado, eu vou fazer isso

 

Fico pensando se em adm eu vá conseguir eliminar o idioma inglês, já que é o idioma padrão da loja instalada, assim como esta a ser o BR, o idioma padrão da loja atual que nao consigo mudar nem desinstalar

 

Ou talvez o bug seja so na linguagem portugues, que ao instalar vem com duas linguas portuguesas diferente, (pt e br)

Teoricamente você pode eliminar qualquer idioma, desde que não esteja definido como idioma padrão.

Mas se não conseguir, também não precisa. Basta definir PT como idioma padrão e desativar o idioma EN.

 

Boa sorte

Share this post


Link to post
Share on other sites

so uma duvida, posso estar com os dois prestashop em teste em localhost? posso baixar e mudar a pasta zip e depois mudar de nome? não dará conflitos? ou melhor mesmo eu desinstalar essa loja em portugues?

Share this post


Link to post
Share on other sites

Não tenho experiência com instalações em Português, pois os meus clientes são todos estrangeiros.

 

Mas aconselho-o a seguir a dica do @Daniel-PrestaBR .

 

Pode ter 2 instalações locais desde que com pastas, bases de dados e url diferentes, mas sou da mesma opinião da @selectshop.at de apenas utilizar servidores online, de preferência aquele em que a loja vai ficar. Se prefere dores de cabeça pode continuar a usar localhost ;) . Para ninguém ter acesso á loja, basta coloca-la em modo de manutenção e activar o seu ip como excepção para aceder ao front office.

Share this post


Link to post
Share on other sites

Eu segui o conselho do Daniel. e sim funciona. Como desconfio: ist deve ser um bug, pois normalmente Ingles é standard e na instalacao do pacote em vez de pt-br e pt-pt deveria ficar en-en e pt-pt como standard.

 

Sugiro colocar o problema no bug-trracker. Quem se propoe, de escrever ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More