Jump to content

Recommended Posts

Boa tarde pessoal, Vinha a desenvolver bem o andamento e configuração da loja no Prestashop versão 1.5.6.2, teste em localhost, ate então tinha me virado sozinho e tudo muito tranquilo. Mas agora me deparo com um bug que apesar de falarem muito por ai, não consigo resolver o meu. Se alguém puder me ajudar fico agradecido.

 

As ocorrências de bugs são:

 

Quanto a loja esta com idioma português de Portugal (PT) o slide image deixa de mostrar as imagens e passa a funcionar apenas com o nome que dei a foto, desliza normalmente, sem foto. Já na bandeira do brasil as fotos aparecem normalmente. Nota: ao configurar o slide image so consigo meter as fotos na bandeira do brasil, se ponho  para carregar as imagens na bandeira de portugal da o seguinte erro como na figura rosa abaixo.

 

quando insiro produtos, se meto a bandeira de Portugal da o seguinte erro (ver foto) sobre nome do produto. Já na bandeira do Brasil aceita salvar os produtos e a pagina do produto fica completa como foi inserido os produtos. 

 

Ja na pagina dos produto se meto bandeira PT desaparece as descrições e a barra " mais informações", mas a foto, o nome do produto e preço continuam normais.

 

 

Quando tento gerenciar traduções (foto) e passar para bandeira de portugal da a seguinte mensagem (foto) e nao aceita fazer a bandeira de portugal o idioma oficial da loja

 

Meu objectivo é ter as bandeiras de portugal e UK (que é o publico para quem o site vai trabalhar)

 

Abrigado a quem responder

post-753610-0-80356700-1391005919_thumb.jpg

post-753610-0-89452900-1391006582_thumb.jpg

post-753610-0-42982400-1391006828_thumb.png

Edited by Mbhvirtual (see edit history)

Share this post


Link to post
Share on other sites

Bug ainda resite........

 

Alguem aqui no Forum Portugal com experiencia em fazer o idioma Português de portugal ser oficial na loja versão 1.5.6.2 (instalada em portugues, mas nao autoriza mudanças no idioma pt BR)

 

Por favor ajuda neste topico abaixo ja em andamento com mais informações...

http://www.prestashop.com/forums/topic/305537-conflito-com-idiomas-brpt/?do=findComment&comment=1557629

Edited by Mbhvirtual (see edit history)

Share this post


Link to post
Share on other sites

Antes de desabilitar ingles vc. vai ter que mudar todos os empregados para idioma pt-pt. Senao nao vai poder desativar ingles. Em vez de deletar ingles, somente desative, assim vc. nao vai ter problemas com upgrades. Se bem que Prestashop também corre somente com um idioma. Somente por questao de seguranca, deixe Ingles, mas desativado.

Share this post


Link to post
Share on other sites

Obrigado pela dica pessoal, Mas o Erro persiste:

 

Instalei a loja somente em ingles, desmarquei a linguagem portugues.

A loja nao veio mas com a bandeira BR, mas veio automaticamente com English e Portugues de Portugal (Até então era isso mesmo, tinha animado)

 

Mas quando fui desabilitar English, da "erro" nao aceita desabilitar a linguagem padrão que é o ingles. (até pensei em trabalhar com as duas linguas, mas um grande problema persiste, no "image slide" se tento meter banner com bandeira PT não aceita, da o mesmo erro de antes, e produtos inseridos com bandeira PT nao aparecem completos na loja. Se configuro a loja em ingles e depois  troca-se para a bandeira para portugues (pt), nao aparece quase nada que foi inserido) o slide mesmo fica vazio em pt

 

Não entendo o que se passa!

 

:(

Share this post


Link to post
Share on other sites

Obrigado pela dica pessoal, Mas o Erro persiste:

 

Instalei a loja somente em ingles, desmarquei a linguagem portugues.

 

 

:(

Se vc. desabilitou portugues, entao o idioma padrae é ingles. Nao vai poder desabilitá-lo ou desintalar, pois ao menos um idioma padrao vc. vai ter que ter. ;)

 

Ative Portugues, vai nos empregados coloque o idioma padrao em todos para Protugues, após isto vc. vai poder desabilitar Ingles. ^_^

Share this post


Link to post
Share on other sites

Colega selectshop.at Fiz o que voce disse, Persiste o erro, não autoriza desabilitar ingles

 

Estou com a loja com Ingles e PT, fui em Adiministração > Empregrados > (so havia um empregado, eu) mudei o idioma para portugues > foi aceito > a loja passou > toda Admin foi traduzida para portugues .

 

Depois fui em > localização > Idiomas > tem os dois idiomas, EN e PT > os dois habilitados > tendei desabilitar EN e da o erro que não é permitido alterar o idioma padrão

Share this post


Link to post
Share on other sites

tentei deletar agora tambem, da erro,  ja tentei tudo, nao entendo porque nao aceita o PT ser padrão e desabilitar ingles, Estar em localhost- Xampp pode estar fazendo esse erro?

 Não pode eliminar o idioma padrão.

Edited by Mbhvirtual (see edit history)

Share this post


Link to post
Share on other sites

Entao deixe e desative o módulo de idiomas para nínguem poder selecionar outro idioma. Nao entendo porque  vc. nao pode desativar o idioma ingles.

Share this post


Link to post
Share on other sites

Vamos ver se achamos o erro colega

 

Desabilitei o modulo idiomas, mas um erro grave persistiu, não consigui inserir slideshow com a bandeira PT. Deu erro. nem os produtos ficam completos na loja se inseridos na bandeira PT. ATENÇÃO: na mesma pagina do modulo de slideshow há uma apção de gerenciar idiomas, com EN e PT, escolhi PT e deu o seguinte erro: 

 

Aviso! A sua configuração PHP está a limitar o número máximo de campos permitidos num formulário
1000 para max_input_vars.
Por favor, peça ao seu fornecedor de alojamento para aumentar este limite para 1305 pelo menos ou altere o ficheiro de tradução manualmente.

Share this post


Link to post
Share on other sites

Monte a sua loja em um servidor produtivo. Abra uma pasta para a loja e segure esta com .htpassword, para somente vc. acessar.

 

Este erro é uma configuracao do servidor que vai ter que adaptar. Trabalho desnecessário se está trabalhando com XAMPP.

 

Veja aqui como fixar o problema. http://www.prestashop.com/forums/topic/215803-dica-configuracao-do-servidor-com-phpini-optimizado-para-prestashop

 

Por favor abra um tópico novo, para problemas novos.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More