Jump to content

[MODULE] Western Union 2.2- PS1.2./1.6


Recommended Posts

Wired Bank Module modified for use as a western.
Accept payments by Western Union.
http://catalogo-onli...prestashop.html
module updated:
Include instructions and bugfixes.
INSTRUCTIONS:
1-Upload the module folder westerunion to MODULES folder.
2-Upload the email folder to email folder in your site.
3-Create an order state like the jpg image attached in the module, and select the email template called western union.
4-Go to modules -> western union and install and configure the module.
5-Put your data and the ORDER ID of the state created in the step 3
6-DONE

western-global-transfer.jpg

westernunion.zip

westernunion.zip v2.2

 

Video:

 

12754_TFKtmak7N6b8EQwqXTaJ_t

Edited by shacker (see edit history)
  • Like 3

Share this post


Link to post
Share on other sites
  • 3 weeks later...

I've installed this module and is working fine, except that the Wire Transfer email notification is being sent. How or where to make the respective code changes to use the Western Union email?

Thanks.

Share this post


Link to post
Share on other sites
I've installed this module and is working fine, except that the Wire Transfer email notification is being sent. How or where to make the respective code changes to use the Western Union email?

Thanks.


You upload the email files to email folder?

Share this post


Link to post
Share on other sites
  • 1 month later...

I had install this Western Union module, and it works well in the first 4 setps , But the last step - "I confirm my orders", when i click the bottom, it fails , and the erro message is -- "Order creation failed".

It works well in my localhost, but fail in web.

please tell me how i can solve this problem ? biggest ths!

15396_xctAZUPX6Wz3NzuQ9rL7_t

Share this post


Link to post
Share on other sites
I had install this Western Union module, and it works well in the first 4 setps , But the last step - "I confirm my orders", when i click the bottom, it fails , and the erro message is -- "Order creation failed".

It works well in my localhost, but fail in web.

please tell me how i can solve this problem ? biggest ths!


Hi. What version of presta ?
Please test the module Moneygram, and test if you have the same problem.

Share this post


Link to post
Share on other sites
My Version 1.2.5.0


Hi, you test the monegrm version?


yes, i test all the payment modules in localhost, they work.
but, when i test them in web host, they fail, why ? ths.

Hi. If all modules payment fails, maybe a incorrect installation. Check the correct permissions of the modules folders.

Share this post


Link to post
Share on other sites

hi,shacker,ths for your suggestion.
-------------
1.Now I followed the instructions to installed the module MoneyGram again in my localhost (put the MoneyGram module to .../modules/,and place of the mails file to ../mails), and it showed that "The following module(s) were not installed successfully:
moneygram" , but actually it had been installed when i double click the "install" button. Then I configured it, and test in front office, it works(see the picture). Is there something wrong with my installing ?

2. When I test in the webhosting, the first 4 steps works well, but the 5th step"payment" fails in clicking "I confirm my order", and the problem i said in front appears.

15412_UEhNiQAJNThgjTFyMnTV_t

Share this post


Link to post
Share on other sites
hi,shacker,ths for your suggestion. I re-installed the module moneygram, and it point out "The following module(s) were not installed successfully:
moneygram" .


Hi. Try to install 2 or 3 times, this is a normal issue. If the problem persist, y attach a new version.

Share this post


Link to post
Share on other sites
My Version 1.2.5.0


Hi, you test the monegrm version?


yes, i test all the payment modules in localhost, they work.
but, when i test them in web host, they fail, why ? ths.

Hi. If all modules payment fails, maybe a incorrect installation. Check the correct permissions of the modules folders.


Could you tell me the Newest Version of WesternUnion and the MoneyGram module or where to download ? ths!

Share this post


Link to post
Share on other sites
My Version 1.2.5.0


Hi, you test the monegrm version?


yes, i test all the payment modules in localhost, they work.
but, when i test them in web host, they fail, why ? ths.

Hi. If all modules payment fails, maybe a incorrect installation. Check the correct permissions of the modules folders.


Could you tell me the Newest Version of WesternUnion and the MoneyGram module or where to download ? ths!


I. try this version. Tell me if you have the same error.

westernunion.zip

Share this post


Link to post
Share on other sites
My Version 1.2.5.0


Hi, you test the monegrm version?


yes, i test all the payment modules in localhost, they work.
but, when i test them in web host, they fail, why ? ths.

Hi. If all modules payment fails, maybe a incorrect installation. Check the correct permissions of the modules folders.


Could you tell me the Newest Version of WesternUnion and the MoneyGram module or where to download ? ths!


I. try this version. Tell me if you have the same error.


hi,shacker, i try your new version, and have the same error.but it works in localhost.
I think maybe problem is in the web server.....and does this module support IIS 5.0 ?
My web server is not Apache Web Server.

ths!

Share this post


Link to post
Share on other sites
My Version 1.2.5.0


Hi, you test the monegrm version?


yes, i test all the payment modules in localhost, they work.
but, when i test them in web host, they fail, why ? ths.

Hi. If all modules payment fails, maybe a incorrect installation. Check the correct permissions of the modules folders.


Could you tell me the Newest Version of WesternUnion and the MoneyGram module or where to download ? ths!


I. try this version. Tell me if you have the same error.


hi,shacker, i try your new version, and have the same error.but it works in localhost.
I think maybe problem is in the web server.....and does this module support IIS 5.0 ?
My web server is not Apache Web Server.

ths!


Its a strange problem. I think that is a server problem, maybe you submit a ticket with this problem to your server

Share this post


Link to post
Share on other sites
My Version 1.2.5.0


Hi, you test the monegrm version?


yes, i test all the payment modules in localhost, they work.
but, when i test them in web host, they fail, why ? ths.

Hi. If all modules payment fails, maybe a incorrect installation. Check the correct permissions of the modules folders.


Could you tell me the Newest Version of WesternUnion and the MoneyGram module or where to download ? ths!


I. try this version. Tell me if you have the same error.


hi,shacker, i try your new version, and have the same error.but it works in localhost.
I think maybe problem is in the web server.....and does this module support IIS 5.0 ?
My web server is not Apache Web Server.

ths!

Another option:

you database in incorrectly:
see this post:

http://www.prestashop.com/forums/viewthread/12805/general_discussion/urgent_help_needed_order_creation_failed

Share this post


Link to post
Share on other sites
My Version 1.2.5.0


Hi, you test the monegrm version?


yes, i test all the payment modules in localhost, they work.
but, when i test them in web host, they fail, why ? ths.

Hi. If all modules payment fails, maybe a incorrect installation. Check the correct permissions of the modules folders.


Could you tell me the Newest Version of WesternUnion and the MoneyGram module or where to download ? ths!


I. try this version. Tell me if you have the same error.


hi,shacker, i try your new version, and have the same error.but it works in localhost.
I think maybe problem is in the web server.....and does this module support IIS 5.0 ?
My web server is not Apache Web Server.

ths!

Another option:

you database in incorrectly:
see this post:

http://www.prestashop.com/forums/viewthread/12805/general_discussion/urgent_help_needed_order_creation_failed



Can you solve the problem??

Share this post


Link to post
Share on other sites
Does WU authorize webshops to receive payments with their service ? It would be new.


Hi. This module works like BANK WIRE. your customer select Wester union for payment, and he send the money via wester union office, and send to you via email, the transaction number. So You can go to wester union office to pick the money.

Share this post


Link to post
Share on other sites
My Version 1.2.5.0


Hi, you test the monegrm version?


yes, i test all the payment modules in localhost, they work.
but, when i test them in web host, they fail, why ? ths.

Hi. If all modules payment fails, maybe a incorrect installation. Check the correct permissions of the modules folders.


Could you tell me the Newest Version of WesternUnion and the MoneyGram module or where to download ? ths!


I. try this version. Tell me if you have the same error.


hi,shacker, i try your new version, and have the same error.but it works in localhost.
I think maybe problem is in the web server.....and does this module support IIS 5.0 ?
My web server is not Apache Web Server.

ths!

Another option:

you database in incorrectly:
see this post:

http://www.prestashop.com/forums/viewthread/12805/general_discussion/urgent_help_needed_order_creation_failed



Can you solve the problem??


hey, brother, the problem still un-solved, and i sure that the error is in my server.
now i put my shop on the VPS apache, and all the modules works.
biggest thanks to your.

Share this post


Link to post
Share on other sites
My Version 1.2.5.0


Hi, you test the monegrm version?


yes, i test all the payment modules in localhost, they work.
but, when i test them in web host, they fail, why ? ths.

Hi. If all modules payment fails, maybe a incorrect installation. Check the correct permissions of the modules folders.


Could you tell me the Newest Version of WesternUnion and the MoneyGram module or where to download ? ths!


I. try this version. Tell me if you have the same error.


hi,shacker, i try your new version, and have the same error.but it works in localhost.
I think maybe problem is in the web server.....and does this module support IIS 5.0 ?
My web server is not Apache Web Server.

ths!

Another option:

you database in incorrectly:
see this post:

http://www.prestashop.com/forums/viewthread/12805/general_discussion/urgent_help_needed_order_creation_failed



Can you solve the problem??


hey, brother, the problem still un-solved, and i sure that the error is in my server.
now i put my shop on the VPS apache, and all the modules works.
biggest thanks to your.


Great man. What is the server?. This is important to the community (for solve the same problem).

Share this post


Link to post
Share on other sites
My Version 1.2.5.0


Hi, you test the monegrm version?


yes, i test all the payment modules in localhost, they work.
but, when i test them in web host, they fail, why ? ths.

Hi. If all modules payment fails, maybe a incorrect installation. Check the correct permissions of the modules folders.


Could you tell me the Newest Version of WesternUnion and the MoneyGram module or where to download ? ths!


I. try this version. Tell me if you have the same error.


hi,shacker, i try your new version, and have the same error.but it works in localhost.
I think maybe problem is in the web server.....and does this module support IIS 5.0 ?
My web server is not Apache Web Server.

ths!

Another option:

you database in incorrectly:
see this post:

http://www.prestashop.com/forums/viewthread/12805/general_discussion/urgent_help_needed_order_creation_failed



Can you solve the problem??


hey, brother, the problem still un-solved, and i sure that the error is in my server.
now i put my shop on the VPS apache, and all the modules works.
biggest thanks to your.


Great man. What is the server?. This is important to the community (for solve the same problem).


virtual space, win 2003 iis5.0. it cant support URL rewrite.
now my VPS is ok, and it is my first time to use VPS, so i have to learn more about it, and thanks again to you and wish you a happy weekend.

Share this post


Link to post
Share on other sites
My Version 1.2.5.0


Hi, you test the monegrm version?


yes, i test all the payment modules in localhost, they work.
but, when i test them in web host, they fail, why ? ths.

Hi. If all modules payment fails, maybe a incorrect installation. Check the correct permissions of the modules folders.


Could you tell me the Newest Version of WesternUnion and the MoneyGram module or where to download ? ths!


I. try this version. Tell me if you have the same error.


hi,shacker, i try your new version, and have the same error.but it works in localhost.
I think maybe problem is in the web server.....and does this module support IIS 5.0 ?
My web server is not Apache Web Server.

ths!

Another option:

you database in incorrectly:
see this post:

http://www.prestashop.com/forums/viewthread/12805/general_discussion/urgent_help_needed_order_creation_failed



Can you solve the problem??


hey, brother, the problem still un-solved, and i sure that the error is in my server.
now i put my shop on the VPS apache, and all the modules works.
biggest thanks to your.


Great man. What is the server?. This is important to the community (for solve the same problem).


virtual space, win 2003 iis5.0. it cant support URL rewrite.
now my VPS is ok, and it is my first time to use VPS, so i have to learn more about it, and thanks again to you and wish you a happy weekend.


Thanks to you for use our modules. And happy holidays

Share this post


Link to post
Share on other sites
  • 3 months later...
The module was downloaded Oct 27th.

Oka. I review the module and solve the problem


Can you post the solution how to modify this module not to send bank wire emails anymore, but western union instead.

Share this post


Link to post
Share on other sites
does this one can works on v1.3


Yes. Module updated with instruction and bugfixes


i download the modules download from your website, can't put it in my webiste. could you please upload one that can works on v1.3 in the forum? thanks

Share this post


Link to post
Share on other sites
does this one can works on v1.3


Yes. Module updated with instruction and bugfixes


i download the modules download from your website, can't put it in my webiste. could you please upload one that can works on v1.3 in the forum? thanks


what is the problem you have?

Share this post


Link to post
Share on other sites
does this one can works on v1.3


Yes. Module updated with instruction and bugfixes


i download the modules download from your website, can't put it in my webiste. could you please upload one that can works on v1.3 in the forum? thanks


what is the problem you have?


1 error
unknown archive type

when i install it in my website , the system shows the information above.

Share this post


Link to post
Share on other sites
Hi, I ve installed the module on 1.2.5 and I get this error:

Hack attempt (OrderHistory -> id_order_state is empty)


Can someone solve this?


Hi. you need to see the instructions, if you dont create a order state the module dont work!!

Share this post


Link to post
Share on other sites
does this one can works on v1.3


Yes. Module updated with instruction and bugfixes


i download the modules download from your website, can't put it in my webiste. could you please upload one that can works on v1.3 in the forum? thanks


what is the problem you have?


1 error
unknown archive type

when i install it in my website , the system shows the information above.

replace this file in your module folder to 1.3 version of presta

westernunion.zip

Share this post


Link to post
Share on other sites
Hi, I ve installed the module on 1.2.5 and I get this error:

Hack attempt (OrderHistory -> id_order_state is empty)


Can someone solve this?


Hi. you need to see the instructions, if you dont create a order state the module dont work!!


Hi,

I created order state and entered id into the module. Now I get this note after the transaction:

Please send to us the data of your transaction (ID, Personal info, etc) to validate order customer support.


Why dont I get the page with details of westernunion transaction?

regards,
Tinechem

Share this post


Link to post
Share on other sites
Hi, I ve installed the module on 1.2.5 and I get this error:

Hack attempt (OrderHistory -> id_order_state is empty)


Can someone solve this?


Hi. you need to see the instructions, if you dont create a order state the module dont work!!


Hi,

I created order state and entered id into the module. Now I get this note after the transaction:

Please send to us the data of your transaction (ID, Personal info, etc) to validate order customer support.


Why dont I get the page with details of westernunion transaction?

regards,
Tinechem

the wester union module works like cheque module o deposit, your customer need to send to you the data. This is specified in the final step.

Share this post


Link to post
Share on other sites
Hi, I ve installed the module on 1.2.5 and I get this error:

Hack attempt (OrderHistory -> id_order_state is empty)


Can someone solve this?


Hi. you need to see the instructions, if you dont create a order state the module dont work!!


Hi,

I created order state and entered id into the module. Now I get this note after the transaction:

Please send to us the data of your transaction (ID, Personal info, etc) to validate order customer support.


Why dont I get the page with details of westernunion transaction?

regards,
Tinechem

the wester union module works like cheque module o deposit, your customer need to send to you the data. This is specified in the final step.



In previous version 0.7 (the one that has problems with emails), customer got all the instruction and infos about transaction displayed on the screen after the confirmation of the order. This does not happen in this version. Immediately after confirmation you get only this text: Please send to us the data of your transaction (ID, Personal info, etc) to validate order customer support.

What about instructions for the customer? How does he know where to send westernunion if he does not get the proper info and guides how to make a transaction?

Share this post


Link to post
Share on other sites
Hi, I ve installed the module on 1.2.5 and I get this error:

Hack attempt (OrderHistory -> id_order_state is empty)


Can someone solve this?


Hi. you need to see the instructions, if you dont create a order state the module dont work!!


Hi,

I created order state and entered id into the module. Now I get this note after the transaction:

Please send to us the data of your transaction (ID, Personal info, etc) to validate order customer support.


Why dont I get the page with details of westernunion transaction?

regards,
Tinechem

the wester union module works like cheque module o deposit, your customer need to send to you the data. This is specified in the final step.



In previous version 0.7 (the one that has problems with emails), customer got all the instruction and infos about transaction displayed on the screen after the confirmation of the order. This does not happen in this version. Immediately after confirmation you get only this text: Please send to us the data of your transaction (ID, Personal info, etc) to validate order customer support.

What about instructions for the customer? How does he know where to send westernunion if he does not get the proper info and guides how to make a transaction?


Im sorry, there is a big bug i nthe module. Is solved now, so redownload and reinstall please.

Share this post


Link to post
Share on other sites
does this one can works on v1.3


Yes. Module updated with instruction and bugfixes


i download the modules download from your website, can't put it in my webiste. could you please upload one that can works on v1.3 in the forum? thanks


what is the problem you have?


1 error
unknown archive type

when i install it in my website , the system shows the information above.

replace this file in your module folder to 1.3 version of presta


i uploaded your file to the server but no image of the payment, and the payment doesn't appear when check out

20342_HJ2g8LJBzcoaFJQ6YDxj_t

Share this post


Link to post
Share on other sites
does this one can works on v1.3


Yes. Module updated with instruction and bugfixes


i download the modules download from your website, can't put it in my webiste. could you please upload one that can works on v1.3 in the forum? thanks


what is the problem you have?


1 error
unknown archive type

when i install it in my website , the system shows the information above.

replace this file in your module folder to 1.3 version of presta


i uploaded your file to the server but no image of the payment, and the payment doesn't appear when check out


Its very strange. I check today !!

Share this post


Link to post
Share on other sites
Western union works like a charm now. Al is OK, thanks a lot.

what about moneygram module? Can it be fixed and modified to work as westernunion?

Thanks,


The next update is for the module money gram. I update this week!

Share this post


Link to post
Share on other sites
Western union works like a charm now. Al is OK, thanks a lot.

what about moneygram module? Can it be fixed and modified to work as westernunion?

Thanks,


The next update is for the module money gram. I update this week!


Please let us kindly know when update is done.

thanks a lot.

tinechem

Share this post


Link to post
Share on other sites
  • 3 weeks later...
does this one can works on v1.3


Yes. Module updated with instruction and bugfixes


i download the modules download from your website, can't put it in my webiste. could you please upload one that can works on v1.3 in the forum? thanks


what is the problem you have?


1 error
unknown archive type

when i install it in my website , the system shows the information above.

replace this file in your module folder to 1.3 version of presta


i uploaded your file to the server but no image of the payment, and the payment doesn't appear when check out


Its very strange. I check today !!


Hello Shacker
do you find out the method to solve this problem, i test it in my site many times. there is no image of the WU payment model and the western union module don't appear when check out.

Share this post


Link to post
Share on other sites
Western union works like a charm now. Al is OK, thanks a lot.

what about moneygram module? Can it be fixed and modified to work as westernunion?

Thanks,


The next update is for the module money gram. I update this week!



Hi did you updated the moneygram module?? So it works like weesternunion?

Share this post


Link to post
Share on other sites
Western union works like a charm now. Al is OK, thanks a lot.

what about moneygram module? Can it be fixed and modified to work as westernunion?

Thanks,


The next update is for the module money gram. I update this week!



Hi did you updated the moneygram module?? So it works like weesternunion?


Sorry for the delay. Im very busy with our new product http://www.catalogo-onlinersi.com.ar/templates-12/106-yan-theme-and-template-editor.html, and the updated is comming in a days and we updated for some free modules.

Share this post


Link to post
Share on other sites
  • 1 month later...
  • 1 month later...

Hi shacker,

Please, I can't download your latest version of the module WU, the link is bad :). Could you upload again please?. I have Prestashop 1.3.1.

I don't found the email template for WU.

Thanks a lot

Joseph

Share this post


Link to post
Share on other sites
Hi shacker,

Please, I can't download your latest version of the module WU, the link is bad :). Could you upload again please?. I have Prestashop 1.3.1.

I don't found the email template for WU.

Thanks a lot

Joseph


Hi. You try to logout, and add to cart again?

Share this post


Link to post
Share on other sites
  • 3 weeks later...

HI Shacker,

Thanks for you great module. I just saw a bug or maybe I just misconfigure something.
At the last stage of the payment before clicking on "I confirm my order", when I change the currency from the list, the amount stays the same and there is just the symbol currency which changes.

I have notice that you changed :

onchange="setCurrency($('#currency_payement').val());"



by:

showElemFromSelect('currency_payement', 'amount_')



It works if I use the first code but it refreshes the page, do you have any idea of how I can it do without refresh the page? (As it could be use on bank transfer too) I try to play with the code but unsuccessfully. Im a little new on prestashop.

Thanks

Share this post


Link to post
Share on other sites
  • 1 month later...
HI Shacker,

Thanks for you great module. I just saw a bug or maybe I just misconfigure something.
At the last stage of the payment before clicking on "I confirm my order", when I change the currency from the list, the amount stays the same and there is just the symbol currency which changes.

I have notice that you changed :
onchange="setCurrency($('#currency_payement').val());"



by:

showElemFromSelect('currency_payement', 'amount_')



It works if I use the first code but it refreshes the page, do you have any idea of how I can it do without refresh the page? (As it could be use on bank transfer too) I try to play with the code but unsuccessfully. Im a little new on prestashop.

Thanks



I have the same problem in 1.31.

Share this post


Link to post
Share on other sites
  • 2 months later...
  • 4 weeks later...

Hi and thanks for this module!

I've been testing it and found something strange that I can't fix (I really don't know much about programming).

The notification email that the client gets about his/her purchase is OK: the prices are correctly displayed.

But the notifications sent by the Email Alerts module v2.2 are wrong: the prices are all wrong.

- The {items} value in the email is not converted to the selected currency in the Western module.
- The {total_products}, {total_shipping}, {total_paid} values are wrong and it seems the currency conversion is done twice or something like that.


Do you guys have the same problem or how can I fix it?

Many thanks!

Share this post


Link to post
Share on other sites
  • 1 month later...

Hello! I installed the last version of this module Western Global on PS 1.3.2.

After I press button 'I confirm my order' in the last window, I get an error: Some parameters are missing.

Any ideas?

Share this post


Link to post
Share on other sites

I found the error. Open validation.php and change WU status ID from default 12 on your own. My status ID is 22.

$westernunion->validateOrder($cart->id, 22, $total, $westernunion->displayName, NULL, $mailVars, $currency->id);

Share this post


Link to post
Share on other sites
  • 3 weeks later...

hi there im sorry but ive folowed all instructions and i bet im missing somthing silly

ive instaled set up but when i click the payment selection i get nothing no email and only blank section in my shop

any help would be great

Share this post


Link to post
Share on other sites
I found the error. Open validation.php and change WU status ID from default 12 on your own. My status ID is 22.

$westernunion->validateOrder($cart->id, 22, $total, $westernunion->displayName, NULL, $mailVars, $currency->id);


hi snuff! where can i find my status id?
thank you!

EDIT: I found it! :)

Share this post


Link to post
Share on other sites
I found the error. Open validation.php and change WU status ID from default 12 on your own. My status ID is 22.

$westernunion->validateOrder($cart->id, 22, $total, $westernunion->displayName, NULL, $mailVars, $currency->id);


I had problem after installing moneygram module becouse of same id's. Thank you for your post !


I've also found another bug.

When customer is finalising order he has to choose currency in payment section. If he bought in EUR and will change it later to USD the WU Module wont use correct conversion rate. For exemple 100 EUR = 100 USD whats making big loss.

How to disable this ?

Sorry for my english, hope everybody will undestand my problem.

Share this post


Link to post
Share on other sites
  • 1 month later...

Unfortunly the module it is full of bugs!



- The order status dont are recogniced correctly.


- The module dont work when we use another currency that is not the default, it not convert the amount, only change the currency symbol.


- Some orders are not displayed in the "Back Office >> Orders" only in carts.


- It crash another next orders after anyone use the module.


.

Beware! It is danger use this module in production stores!


.
This module must be alpha version or 0.1.1, it is not an 1.1 version!

Share this post


Link to post
Share on other sites
  • 1 month later...
  • 2 weeks later...
  • 2 weeks later...

Hello and thnx for this module.

I have the latest version of Presta and everything is ok When icome to payment "Please select your preferred payment method ..etc"
and click on Pay by WesternUnion (confirm transaction via email) nothing shows (payment.php)

I am a newbie what is wrong ?
Please help

Share this post


Link to post
Share on other sites
  • 4 weeks later...

hi shacker,

this is a great module. Thanks very much!

But I have a problem with the westernunion1.2 on Prestashop 1.4.3. At the last step ORDER CONFIRMATION, it says like this:

----------------------------------
Your order on 1to1bags is complete.

Please send us a WesternUnion transfer with:

- an amout of $73.05

- to the account owner of FRISTNAME LASTNAME

- with theses details TEST DETAIL

- to this CIF/DNI/NIF 28121545

- Do not forget to insert your order # 3 in the subjet of your Western Union

An e-mail has been sent to you with this information.
----------------------------------

The problem is the customs won't receive an email with information. They will only receive an email titled "[shop name] Order confirmation", in which there is no information as listed above.

Thanks a lot if you can help me this out.

Share this post


Link to post
Share on other sites

Hi, i installed it on PS 1.4.3 and on after payment selection the payment.php page is coming empty. I added order status and uploaded mail files. Any help for this? Regards

Share this post


Link to post
Share on other sites

@armadillo & gorrasriders: i remember this a tiny bug in this module we downloaded. but i don't remember it exactly at the moment. if you turn on the ERROR_REPORT, i think you will find it easily.

Share this post


Link to post
Share on other sites

@armadillo:

the first line in the file config/config.inc.php. change

@ini_set('display_errors', 'off');

to

@ini_set('display_errors', 'on');



Don't forget to change it back when you finish your debugging.

Share this post


Link to post
Share on other sites

this is the error

Fatal error: Uncaught exception 'SmartyCompilerException' with message 'Syntax Error in template "/nfs/c08/h04/mnt/124564/domains/xxxxxxxxxxxxxx.com/html/modules/westernunion/payment_execution.tpl" on line 58 "{include file=$tpl_dir./breadcrumb.tpl}" - Unexpected "/", expected one of: "{" , "$" , "identifier" , INTEGER' in /nfs/c08/h04/mnt/124564/domains/xxxxxxxxxxxxxxxxxx.com/html/tools/smarty/sysplugins/smarty_internal_templatecompilerbase.php:431 Stack trace: #0 /nfs/c08/h04/mnt/124564/domains/xxxxxxxxxxxxxxx.com/html/tools/smarty/sysplugins/smarty_internal_templateparser.php(2855): Smarty_Internal_TemplateCompilerBase->trigger_template_error() #1 /nfs/c08/h04/mnt/124564/domains/xxxxxxxxxxxxxxxxxx.com/html/tools/smarty/sysplugins/smarty_internal_templateparser.php(2920): Smarty_Internal_Templateparser->yy_syntax_error(37, '/') #2 /nfs/c08/h04/mnt/124564/domains/xxxxxxxxxxxxxxxxxxxx.com/html/tools/smarty/sysplugins/smarty_internal_smartytemplatecompiler.php(51): Smarty_Internal_Templateparser->doParse(37, '/') #3 /nfs/c08/h04/m in /nfs/c08/h04/mnt/124564/domains/xxxxxxxxxxxxxxxxxxxxxx.com/html/tools/smarty/sysplugins/smarty_internal_templatecompilerbase.php on line 431

Share this post


Link to post
Share on other sites
Ok solved by adding "" to
file=$tpl_dir./breadcrumb.tpl}”

replace

file="$tpl_dir./breadcrumb.tpl"}”
and
also
order-steps line



hi can you upload the file as i am unable to make the changes :( as i am new to prestashop

Share this post


Link to post
Share on other sites
  • 1 month later...

Hi Shaker

I tested your module to version 1.4.2.5

I regret that offer a free module but is not officially translated correctly.

I found that for the French language in the "Mail" module, the. Html is done in Spanish as well as the. Txt

So I translated properly, by causing careful not to make mistakes

Then I transfer the module on my ftp and since I find myself frequently with error 503 & 303.

As soon as I uninstall the module, I have no errors

 

for information errors are:

503 :Service Unavailable Service temporarily unavailable or maintenance

504 :Gateway Time-out waiting time for a response from a server to a intermediate server elapsed

 

cordially

Share this post


Link to post
Share on other sites
  • 3 months later...
  • 2 weeks later...