Jump to content

Parse error on cache/class_index.php on line 500


Recommended Posts

Hi

I dont know in which situaitions prestashop regenerate the /cache/class_index.php file but when it is regenerated, I am getting 
Parse error: syntax error, unexpected T_ENCAPSED_AND_WHITESPACE in /home/...../public_html/cache/class_index.php on line 500

this error and my website is totally shut down until I manually replace this file.

Thanks in advance for your help

Edited by f_apan (see edit history)

Share this post


Link to post
Share on other sites

you can safely delete this file and it will automatically regnerate.

 

after doing so are you still having the same issue?

 

if so attach that file to your post for review by community

Thanks for your fast reply El Patron

Now , I deleted file then it is regenerated without  problem. when I get error this file is ending at 500th line like 'PrestaShopPaymentExceptionCore' => 'classes/exception/PrestaShopPaymentException.php also without quote then giving syntax error. 

x8lp9d.jpg

Share this post


Link to post
Share on other sites

  • 1 year later...

I am having the same Issue with my website. The error_log says "PHP Parse error:  syntax error, unexpected T_ENCAPSED_AND_WHITESPACE, expecting ')' in class_index.php on line 207" whereas the class_index.php file is absolutely ok (No syntax error in the array declaration).

1. I have Prestashop 1.5.4.1
2. In "Advanced Parameters > Performance" , In "Smarty" section, "Force Compilation" is checked, "Cache" is disabled. In "Caching" section, "Use Cache" is set to "No".
3. Removing the file "class_index.php" file did not help.
4. The above GitHub solution did not work for me.

Please help.

Thanks and regards
Thanks and regards

Share this post


Link to post
Share on other sites

  • 4 months later...

you can safely delete this file and it will automatically regnerate.

 

after doing so are you still having the same issue?

 

if so attach that file to your post for review by community

Hi guys,

 

I'm having the same problem with class_index.php

I have to delete it each time after desactivating/activating the smarty cache, otherwise I get a blank page on back and front office.

After deleting, it is regenerated and everything is working fine!!

 

Do you have any suggestion to fix this issue?

 

Thanks a lot

Share this post


Link to post
Share on other sites

  • 3 months later...
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More