Jump to content

Generate htaccess now site blank

Recommended Posts

I was in the admin of a new installation and clicked generate .htaccess and page reloaded blank. Now admin and front end are all blank white page. Site is dead in 5 minutes. How can I fix it?


Seems when I click generate htaccess, it removes the line to make the site run php5 that my host places in it when the account was set up.

Can I download the contents of what is placed into the file ad paste it in manually?

Link to comment
Share on other sites

  • 3 weeks later...

I have this same problem... removing E from the brackets did not work for me. Not only does it render my page blank .. but when i reset the original .htaccess file, it removes the categories block... makes links 404 and removes pictures... I'm on my 3rd install in a row...


Link to comment
Share on other sites

6 installs and 36 hours of work later... I'm giving up. Chalk this up to a BUG that needs to be fixed!

Quick question: everyone that is having this problem... What hosting provider are you using?

Mine is 1 and 1 web host... I ask because I know 1and1 makes me put a .htacess file in the root with Addtype x-mapp-php5 .php to switch php versions (4 by default)

They also require me to put a php.ini file in the config and install galleries in order to make url rewritable.

Could This Be The Problem? The .htaccess allowing php 5 is being overwritten by the friendly URL code?

Link to comment
Share on other sites

The PrestaShop .htaccess generator removes everything already existing in the file before writing in it. So, after the generation, you must restore manually the previous content.

Well I gave it a try: what I have in .htaccess after adding my piece:

Addtype x-mapp-php5 .php

# .htaccess automaticaly generated by PrestaShop e-commerce open-source solution
# http://www.prestashop.com - http://www.prestashop.com/forums

# URL rewriting module activation
RewriteEngine on

# URL rewriting rules
RewriteRule ^([a-z0-9]+)\-([a-z0-9]+)(\-[_a-zA-Z0-9-]*)/([_a-zA-Z0-9-]*)\.jpg$ /img/p/$1-$2$3.jpg [L,E]
RewriteRule ^([0-9]+)(\-[_a-zA-Z0-9-]*)/([_a-zA-Z0-9-]*)\.jpg$ /img/c/$1$2.jpg [L,E]
RewriteRule ^lang-([a-z]{2})/([a-zA-Z0-9-]*)/([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ /product.php?id_product=$3&isolang;=$1$5 [L,E]
RewriteRule ^lang-([a-z]{2})/([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ /product.php?id_product=$2&isolang;=$1$4 [L,E]
RewriteRule ^lang-([a-z]{2})/([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ /category.php?id_category=$2&isolang;=$1 [QSA,L,E]
RewriteRule ^([a-zA-Z0-9-]*)/([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ /product.php?id_product=$2$4 [L,E]
RewriteRule ^([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ /product.php?id_product=$1$3 [L,E]
RewriteRule ^([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ /category.php?id_category=$1 [QSA,L,E]
RewriteRule ^content/([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ /cms.php?id_cms=$1 [QSA,L,E]
RewriteRule ^([0-9]+)__([a-zA-Z0-9-]*)(.*)$ /supplier.php?id_supplier=$1$3 [QSA,L,E]
RewriteRule ^([0-9]+)_([a-zA-Z0-9-]*)(.*)$ /manufacturer.php?id_manufacturer=$1$3 [QSA,L,E]
RewriteRule ^lang-([a-z]{2})/(.*)$ /$2?isolang=$1 [QSA,L,E]

# Catch 404 errors
ErrorDocument 404 /404.php

I also tried my piece of the code after th catch 404...

Does Not Work:

Catagories are missing
Links dont work: There is 1 error :

1. you do not have access to this product

New Products block goes empty...

... and im off for another install... thanks for your help Patric, but i doubt I'll ever try again.

* I also tired removing the [E] as suggested previously in this thread... no go.
Link to comment
Share on other sites

  • 4 weeks later...

I have the same problem . The .htaccess automaticaly generated by PrestaShop crashes my store.

I have reset and tried it several times, I've also tried taking the E out of the .htaccess file but had NO success.

Not sure what x-mapp-php5 .php is all about

Can any one please offer some suggestions on how to resolve this issue.

We would all appreciate the support on this one.

Any additional comments would be wonderful!.

Link to comment
Share on other sites

Are you familiar with either of these? .htaccess generator or the httpd.conf

I tried to dig up more on the topic to see if we can resolve the issue. Here is what I found.





This page talks it.... but Not sure how to resolve the problem..

Says: Problem is in httpd.conf

I must change this:

AllowOverride none
Order allow,deny

on this:

AllowOverride All
Order Deny,Allow

Link to comment
Share on other sites

  • 4 weeks later...
  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...